Home | Download | Discussion | Help | Site Map | New Posts | Sign in

Latest Site News

2018 Calendar Contest Winners - posted on 10th Jan 2018 at 5:38 PM
MTS has all free content, all the time. Find out how YOU can help to keep it running. Tell me how...


Testers Wanted - Framework Installer tool - Now deprecated

by Tashiketh Posted 28th Dec 2009 at 12:23 AM - Updated 22nd Nov 2011 at 11:56 PM by Delphy
820 Comments / replies (Who?) - 23 Feedback Posts, 1 Thanks Posts
ATTENTION - This tool is NO LONGER UPDATED!

If you want to install a framework to your Ambitions, Fast Lane, Outdoor Living or Generations, just download this file: http://chii.modthesims2.com/FrameworkSetup.zip and extract it to My Documents\Electronic Arts\The Sims 3. Thats it. Next time you load the game you wont see the intro - if you do, then you screwed something up.

For more help, please see http://simswiki.info/wiki.php?title...Setup_and_Files

I will no longer be offering support for this tool and it is now deprecated!


Operating System: Windows

You must have the expansion or stuff packs listed below installed to use this custom content. Please see the post text for any exceptions.

Sims 3
Key: - File was updated after upload was posted
Filename - Tip: You can click the magnifying glass to see the archive contents Size Downloads Date
MonkeyBars.rar 79.3 KB 333,489 28th Dec 2009
Don't forget to Thank the creator after downloading! Use the Thanks button located above the screenshots above.
Quick Guide:

1. Click the file listed on the Files tab to download the file to your computer.
2. Extract the zip, rar, or 7z file. Now you will have either a .package or a .sims3pack file.

For Package files:

1. Cut and paste the file into your Documents\Electronic Arts\The Sims 3\Mods\Packages folder. If you do not already have this folder, you should read the full guide to Package files first: Sims 3:Installing Package Fileswiki, so you can make sure your game is fully patched and you have the correct Resource.cfg file.
2. Run the game, and find your content where the creator said it would be (build mode, buy mode, Create-a-Sim, etc.).

For Sims3Pack files:

1. Cut and paste it into your Documents\Electronic Arts\The Sims 3\Downloads folder. If you do not have this folder yet, it is recommended that you open the game and then close it again so that this folder will be automatically created. Then you can place the .sims3pack into your Downloads folder.
2. Load the game's Launcher, and click on the Downloads tab. Find the item in the list and tick the box beside it. Then press the Install button below the list.
3. Wait for the installer to load, and it will install the content to the game. You will get a message letting you know when it's done.
4. Run the game, and find your content where the creator said it would be (build mode, buy mode, Create-a-Sim, etc.).


Extracting from RAR, ZIP, or 7z: You will need a special program for this. For Windows, we recommend 7-Zip and for Mac OSX, we recommend Keka. Both are free and safe to use.


Need more help?

If you need more info, see:
 
Page 1 of 33
820 Comments / Replies (Who?) - 716 Feedback Posts, 59 Thanks Posts
Thanks are currently OFF: Show Thanks Posts for this thread
Test Subject
#2 Old 30th Dec 2009 at 6:44 PM
I was already having framework issues so I thought ... YES this may help.
Unfortunately no. This is the error I got and I do not know where the 'log' is to check it.


That error also causes the launcher to freeze.

and for kickz and grinz I tried to bypass the launcher and got this
Test Subject
#3 Old 31st Dec 2009 at 12:58 AM
Has anyone else had that issue? I too have had numerous framework issues and confusion, so I was really hoping this would be the "fix" I've been waiting for. Does it work for others?

Sims 3 story is here http://petalpaths.wordpress.com
Dancing Flamingo
staff: administrator
#4 Old 31st Dec 2009 at 1:06 AM
It worked fine for me with Windows7 with an admin account and with Vista and a limited user account. Framework was installed correctly for both EP's. All my cc is working fine.

I don't think that initialization error is a result of installing the framework though.
In the Arena
staff: retired moderator
#5 Old 31st Dec 2009 at 2:18 AM Last edited by ellacharm3d : 31st Dec 2009 at 3:07 AM.
annich02, ZombieBoPeep,
Once you run it and get the green tick, the setup should be fine.
Those errors are not caused by this installer. Those are errors by the Launcher totally unrelated to the usage of this tool.

I would suggest, if you already have the original HelperMonkey, remove the pre-existing framework components (wiki has them listed) out to the Desktop before using this tool.

Then copy+paste the .package contents and any subfolders you had from the old \Mods\Packages\ (on Desktop) to the new one in TS3 base game or WA (but not both).

If you had used the tips in the Help sticky regarding .dbc, then copy+paste those files into \Mods\Packages\DCCache\ folder.
Test Subject
#6 Old 31st Dec 2009 at 7:35 PM
I uninstalled my game and reinstalled it and everything works fine now.
Test Subject
#7 Old 2nd Jan 2010 at 1:19 AM
I can not install any package files to any of my Sims game. It gives me a double click on custom content package thing when I open it. What do package files refer to when they open? Can someone tell me so I can attempt to fix this issue?
Pettifogging Legalist!
staff: moderator
#8 Old 2nd Jan 2010 at 5:39 AM
AssassinRage, you already have a thread about this. Please don't post more than once about the same issue. Thanks.

Stuff for TS2 TS3 TS4 | Please do not PM me with technical questions we have Create forums for that.

In the kingdom of the blind, do as the Romans do.
Test Subject
DELETED POST
2nd Jan 2010 at 1:50 PM
This message has been deleted by BL4CKL4C3.
Test Subject
#9 Old 2nd Jan 2010 at 2:12 PM
Hi I have followed these instructions and that in the Game_Help:Installing_Sims_3_Package_Fileswiki. I have managed to install everything, yet it still says I have no resource.cfg file? I've followed the wiki. I have WA, do i need a new .cfg file or have I put it in the wrong place? Thanks in advance
Warrior Gryphon
site owner
Original Poster
#10 Old 2nd Jan 2010 at 6:22 PM
If you run the Framework Installer tool does it give you a big giant tick, or a big giant cross? If it's a cross, please screenshot the program (as requested). If you have a tick, well, then you already have the framework and the resource.cfg.

Story books are full of fairy tales, of Kings and Queens, and the bluest skies.
Field Researcher
#11 Old 2nd Jan 2010 at 10:29 PM
Worked for me on Windows 7.
Test Subject
#12 Old 2nd Jan 2010 at 10:48 PM
Thanks, everything seems to be in all the right places... I haven't run my game yet, but so far things look better than they did before this tool!

RaynePoodle
Dancing Flamingo
staff: administrator
#13 Old 2nd Jan 2010 at 10:58 PM
Test Subject
#14 Old 2nd Jan 2010 at 11:34 PM
Quote:
Originally Posted by HugeLunatic
SIMone de beauvoir your issue is not this tool, nor the cfg being corrupt. Please read this thread about WA and packages causing slowness.

http://www.modthesims.info/showthread.php?t=379085


Thank you, HugeLunatic. But, I didn't say that the issue was this tool or the that it was my .cfg being corrupted. And also, before uninstalling I was playing WA with all my CC with no problems... that is what's so weird. Nothing was changed, and it used to work and now it doesn't.

I'm reading the thread... and I'm not finding any solutions yet.

Test Subject
#15 Old 3rd Jan 2010 at 11:50 PM
I installed this last night and my sim game worked perfectly. This morning I tied to get on it and the game just wont start up. When I leave the game to go back to my windows screen a pop up is waiting for me "Unable to to start game Service initialization failed". This is the only change i've made to it and its always work fine before. I have windows 7 and sim game version 2.2.8. Is there a way I can just take the mod out of the game? if not how do i get it to work again... thanks
Test Subject
#16 Old 4th Jan 2010 at 1:41 AM
Yay! Thanks so much Delphy.. this really helped me out.
Lab Assistant
#17 Old 4th Jan 2010 at 5:42 AM
so does this mean the double-click ease of the helper monkey is gone and we actually have to do some manual-ish labor?
I thought that's what you said but I'm just looking for verification.
Warrior Gryphon
site owner
Original Poster
#18 Old 4th Jan 2010 at 1:05 PM
lilfixit: Please read the description again. This particular tool only does the framework install part. It has nothing to do with the actual installation of package files. You may, if you want, continue to use the Helper Monkey to double click (or right click) package files to install them, but the framework install should be setup using this program first.

jadams66, service initialisation failed has nothing to do with this program. Please see the first few posts on this thread for more information.

SIMone: WA slowdown with package files is, as HugeLunatic says, nothing to do with this tool. There are solutions on post 275 or so on the WA slowdown thread.

Story books are full of fairy tales, of Kings and Queens, and the bluest skies.
Lab Assistant
#19 Old 5th Jan 2010 at 11:05 AM
Thank you for this download. A question before I install this: There is no advice whether I have to uninstall the previous helper monkey (although I can't find this anywhere - I have just completely reinstalled BG & WA to latest patch) before I install this Monkey Bar. Should I search and destroy it first? or leave it as it is if found? Also, I notice on the lower right corner of my mozilla browser an icon which is similar to Helper Monkey and its called Grease Monkey. What should I do with Grease Monkey? I can't remember how it got there. Or are these questions totally irrelevant and I should proceed anyway?

Sorry, the questions are obviously coming from a complete idiot and a noob...of which I am. hehehe. please advise Sirs & Maams.... dying to start to playing now....
Warrior Gryphon
site owner
Original Poster
#20 Old 5th Jan 2010 at 1:01 PM
Grease Monkey has nothing to do with Sims - it's a browser thing.

As for the helper monkey - well, if you already have your framework setup AND your custom content works in game - you don't need this tool.

Story books are full of fairy tales, of Kings and Queens, and the bluest skies.
Test Subject
#21 Old 6th Jan 2010 at 11:11 AM
I'm having a problem after I installed this framework thingy. My World Adventures crashes without warning as soon as it finishes loading right after the starting movie. I had updated the base game and expansion pack right before I did this but it worked fine. I'm running Windows Vista 32 bit. I'd like to know how to revert the game folders to how things were before I installed the framework tool. Then I can now for sure if it thats the problem or if something else is responsible.
Warrior Gryphon
site owner
Original Poster
#22 Old 6th Jan 2010 at 12:01 PM
AHM: Thats easy - delete the resource.cfg, move your Mods folder, and remove the .DLL.

Story books are full of fairy tales, of Kings and Queens, and the bluest skies.
Test Subject
#23 Old 6th Jan 2010 at 1:05 PM
Thanks Delphy I tried did that and it turns out I had a bad mod, your program works fine.
Test Subject
#24 Old 6th Jan 2010 at 7:46 PM
Thanks a lot Delphy! It really helped. I was having crashes after the intro played but this sorted it out completely!
Page 1 of 33