Home | Download | Discussion | Help | Site Map | New Posts | Sign in
Replies: 9 (Who?), Viewed: 5040 times.
Lab Assistant
Original Poster
#1 Old 4th Aug 2006 at 12:46 AM
'Undefined Transitions' with slots
I'm currently making an object that uses slots. I have gotten the routing slot to work fine, but I can't get my container slot to work fine as well. When testing the object out with testingcheats enabled, I get an 'Undefined Transition' error right before the sim should snap into the container slot.

I think this might have to do with there being an animation right before snapping into the slot, since every time I get that error I need to adjust the animations for the object. But I don't think it's the animation alone, since I took out the reference to the container slot and the object worked fine (except the sim wasn't in the right place).

I think that the parameters I used in the primitive are causing this, since I'm not sure how to set them up correctly.

I've uploaded the package file for you to look at.
Download - please read all instructions before downloading any files!
File Type: rar poiple_playset2_071706.rar (54.1 KB, 9 downloads) - View custom content
Advertisement
Lab Assistant
#2 Old 4th Aug 2006 at 2:16 AM
Knowing absolutely nothing about slots in BHAVs, I can't say anything for sure. But your animations look fine, so that's the only place it could be.

I did notice that it's set to "Snap (to slot number in stack param", which I would think means the value would be set in a parameter somewhere, but you don't have any parameters in your BHAV.

Also, there's a thing on " ask person to move: False," which I would think would force the sim to move to your slot.

The above post should be ingested with 1/4 Tbsp salt. In the event of an allergic reaction, panic and wait for the reaction to pass.
Lab Assistant
Original Poster
#3 Old 4th Aug 2006 at 2:22 AM
Well, about the slot number in stack param thing, the slot number is 0x00, so I guess it's already there, but 'invisible' because of it's number. And about the 'ask person to move' thing, I don't see that anywhere in the BHAV editor.
Lab Assistant
Original Poster
#4 Old 4th Aug 2006 at 11:56 PM Last edited by poifectly_poiple : 5th Aug 2006 at 2:01 AM.
I decided to mess around with the parameters a little, and most of the combinations I tried didn't work, but one came up with a different error. This time it was 'could not find object referance'. This seems to be more of a side-step than an improvement, but I'm going to go ahead and attach the new file incase anyone can find what's wrong with this one.
Download - please read all instructions before downloading any files!
File Type: rar poiple_playset2_071706.rar (54.1 KB, 8 downloads) - View custom content
Retired Duck
staff: retired moderator
#5 Old 5th Aug 2006 at 10:03 AM
Hey

I wasn't able to fix the whole problem, but I've certainly learned a lot about slots in the last few hours! It actually runs through most of the sequence now, but I've run out of time to finish it (whoops!). Here's a couple of notes anyway:

- The "undefined transition" error is telling you that the BHAV failed (ie - it returned false) and you didn't have any alternative path. Obviously, the line that returned False shouldn't have (Snap Into). As you said, skipping this line causes the animation to run correctly.

- Container slots that can contain whole sims have to have an i7 value of '7'. Yours was set to 5, which I believe means "placeable on sims" (plates, accessories etc). The values for i7 are the same as in object intersection flags, see here:
http://www.modthesims2.com/showthread.php?t=82685

- The parameters you had for each of the snap commands are pointing to the wrong objects. In the case of the first one, the object you wanted to snap the sim into was the stack object. In the second one, you wanted to snap the sim back to the routing slot. In both cases, you were actually referencing [param 0], which is mostly not the object you want.

- I changed the support strength in the init to something more closely resembling a sim-containing object

It's still broken, but I've got to head off now and something is better than nothing! At least it's a bit closer now!
Download - please read all instructions before downloading any files!
File Type: zip poiple_playset2_071706.zip (106.2 KB, 12 downloads)
Lab Assistant
Original Poster
#6 Old 7th Aug 2006 at 8:18 PM Last edited by poifectly_poiple : 8th Aug 2006 at 12:44 AM.
Thanks echo, this is a huge help.

EDIT: I messed around with the parameters in the snap primitive and now I no longer get errors.
Test Subject
#7 Old 11th Aug 2006 at 11:20 AM Last edited by Nadira : 11th Aug 2006 at 11:29 AM.
I have been trying to write a BHAV to snap an object into a container slot and make it fade in (making a vase appear on the easel - yes it sounds stupid but I had a project in mind) and ran into the same two errors as poifectly poiple. At first I used the settings of the easel BHAV "create canvas" and since this did not work I have been playing around with the snapinto parameter settings, but it simply does not work (by now I have reached a point where I donīt get an error message anymore, but the BHAV simply is stopped at this point without the object appearing).
Is there some kind of tutorial that could help me to understand this problem better - something which kind of container slots are suitable for which actions (like echoīs information on the I7 value) and what kind of parameter settings should be used correctly with "snapinto"?
I am very much longing to understand this matter from the ground up to be less dependent on the try and error method (which in this case was not even successful)!
Retired Duck
staff: retired moderator
#8 Old 11th Aug 2006 at 12:40 PM
Well the main two resources I've used for slots are:
http://www.modthesims2.com/showthread.php?t=146440
http://www.modthesims2.com/showthread.php?t=143252

The best advice though, is to copy from an item which already behaves in that sort of way. If you're trying to create a new object then fade it in in a particular slot, then I'd suggest you check out the code/slots in the cauldron from the Harry Potter thread - It creates potions in a slot copied from an end table.
Test Subject
#9 Old 11th Aug 2006 at 3:37 PM
Thanks a lot!
Missed the second tutorial!
And thatīs just the kind of object I was hunting around to download and study!
Looking happily forward to do some more testing and learning! :D
Field Researcher
#10 Old 1st Oct 2006 at 5:29 AM
If you ever get the details on the other parameters please let me know. I am trying to make a dresser that doubles as a surface and so far I haven't had any luck. I've added slots to a slot file, given unique instance numbers to the new slot files. Made sure I numbered them and linked them to the Bones thing in the text STR. Made sure I added the slots to the CRES. From what I can see of the Grand Trianon dresser/mirror (which functions as a surface) there doesn't seem to be anything in the bhavs to make it function as a surface but for some reason I can't seem to get it to work for my dresser. I submitted it to the object creation workshop repair thread.
I'm confused about some of the differences in the settings between things in the end table, coffee table, and the grand trianon dresser in terms of the slot files.
I'm hoping that the parameters I don't understand are what are causing the problem and that once I know what they all do I can get it to work.
Back to top

Section jump