MTS has all free content, all the time. Find out how YOU can help to keep it running. Tell me how...

Testers Wanted - Framework Installer tool - Now deprecated

by Tashiketh Posted 28th Dec 2009 at 12:23 AM - Updated 22nd Nov 2011 at 11:56 PM by Delphy
821 Comments / replies (Who?) - 24 Feedback Posts
ATTENTION - This tool is NO LONGER UPDATED!

If you want to install a framework to your Ambitions, Fast Lane, Outdoor Living or Generations, just download this file: http://chii.modthesims2.com/FrameworkSetup.zip and extract it to My Documents\Electronic Arts\The Sims 3. Thats it. Next time you load the game you wont see the intro - if you do, then you screwed something up.

For more help, please see http://simswiki.info/wiki.php?title...Setup_and_Files

I will no longer be offering support for this tool and it is now deprecated!


Operating System: Windows

You must have the expansion or stuff packs listed below installed to use this custom content. Please see the post text for any exceptions.

Sims 3
Key: - File was updated after upload was posted
Filename - Tip: You can click the magnifying glass to see the archive contents Size Downloads Date
MonkeyBars.rar

Size: 79.3 KB · Downloads: 336,826 · 28th Dec 2009
79.3 KB 336,826 28th Dec 2009
Don't forget to Thank the creator after downloading! Use the Thanks button located above the screenshots above.
Quick Guide:

1. Click the file listed on the Files tab to download the file to your computer.
2. Extract the zip, rar, or 7z file. Now you will have either a .package or a .sims3pack file.

For Package files:

1. Cut and paste the file into your Documents\Electronic Arts\The Sims 3\Mods\Packages folder. If you do not already have this folder, you should read the full guide to Package files first: Sims 3:Installing Package Fileswiki, so you can make sure your game is fully patched and you have the correct Resource.cfg file.
2. Run the game, and find your content where the creator said it would be (build mode, buy mode, Create-a-Sim, etc.).

For Sims3Pack files:

1. Cut and paste it into your Documents\Electronic Arts\The Sims 3\Downloads folder. If you do not have this folder yet, it is recommended that you open the game and then close it again so that this folder will be automatically created. Then you can place the .sims3pack into your Downloads folder.
2. Load the game's Launcher, and click on the Downloads tab. Find the item in the list and tick the box beside it. Then press the Install button below the list.
3. Wait for the installer to load, and it will install the content to the game. You will get a message letting you know when it's done.
4. Run the game, and find your content where the creator said it would be (build mode, buy mode, Create-a-Sim, etc.).


Extracting from RAR, ZIP, or 7z: You will need a special program for this. For Windows, we recommend 7-Zip and for Mac OSX, we recommend Keka. Both are free and safe to use.


Need more help?

If you need more info, see:
 
821 Comments / Replies (Who?) - 717 Feedback Posts, 59 Thanks Posts
Hide Thanks Posts for this thread (Show only feedback)
Page 7 of 33
Warrior Gryphon
site owner
Original Poster
#151 Old 23rd Mar 2010 at 12:07 PM
ShawnSpencer: This tool makes one for you.

Story books are full of fairy tales, of Kings and Queens, and the bluest skies.
Test Subject
#152 Old 23rd Mar 2010 at 1:41 PM
Thanks! It works now :D
Lab Assistant
#153 Old 23rd Mar 2010 at 10:48 PM
Resource file is the only source of hassle. Because I did the procedure carefully, so I noticed the game works fine after I remove the "Resource" on sims 3/ sims world adventure (c/programfiles/The sims 3..) in directory system, like that.

Can someone explain this phenomena? I know the resource file is the only problem, yet the goal of this painful installation! Without resource file the game is fine but NO CC could be readable!! Is there any case of World Adventure isn't compatible with resource file? I updated my game to the latest update and this is what happened when I try to install cc HELP
Test Subject
#154 Old 24th Mar 2010 at 9:15 AM
Thanks alot! I was just about to delete all my mods and custom content, but i found a link to your program.. and it works fine now Thankyou!!
Warrior Gryphon
site owner
Original Poster
#155 Old 24th Mar 2010 at 9:43 AM
joswan: It's not the resource file thats the problem. It's the custom content you have in your folders that is. The resource file simply tells the game WHERE to load things. You simply have a piece of custom content thats not compatible with WA. It's as easy as that.

Story books are full of fairy tales, of Kings and Queens, and the bluest skies.
Mad Poster
#156 Old 24th Mar 2010 at 2:23 PM
Cheers for this. I downloaded and used it today without problem to discover why my CC wasn't showing. Turns out I had missed one folder level in my backup files when copying back into the right place after I reinstalled my game.

My deviantART, MTS Yearbook Origin ID = Alistu
Test Subject
#157 Old 25th Mar 2010 at 11:24 AM
Default Hi I did this had same prob
Quote:
Originally Posted by AHM
I'm having a problem after I installed this framework thingy. My World Adventures crashes without warning as soon as it finishes loading right after the starting movie. I had updated the base game and expansion pack right before I did this but it worked fine. I'm running Windows Vista 32 bit. I'd like to know how to revert the game folders to how things were before I installed the framework tool. Then I can now for sure if it thats the problem or if something else is responsible.

I did the same thing and ended up with the same problem Im also windows vista and it sucked I just put the game bake in WA and HEL I also have other downloads that I put in then when I tried this the game would shut down as soon as the start up movie ended I was so flustered I had to uninstall it all then reinstall it all it was a butt and flusterating well I have not downloaded it again till I think the problem has been fixed till them Ill just have to do everything manually.
Lab Assistant
#158 Old 25th Mar 2010 at 11:31 PM
can't i just create the Mods folder???
cuz when i re-installed sims 2 there was no downloads folder and i created it and it worked fine!
and i still don't get this program,if it does not install my content,it doesn't help to install it,then why install it???
i'm totally confused,HELP!
Test Subject
#159 Old 26th Mar 2010 at 2:42 AM
i just downloaded this, and i have tryed so many different ways to add mods to the sims 3 and by far this was the easiest and most direct way.. thank you... so far no problems.. if i find any will let you know.. again THANK YOU!!! NW
Test Subject
#160 Old 26th Mar 2010 at 3:32 AM
So easy to use! The only question I have (and I'll find out soon enough as I reload the rest of my Sims 2 games after a wipe and fresh OS install) is will I be able to run Sims 2 custom content as well. I know I can choose what program runs .package files in Vista. With the previous Framework Installer, I could just switch which program opened up the .package files (Monkey (S3) or SimPE (S2)). I hope I'll be able to play both programs. THANK YOU, Delphy!!!
Test Subject
#161 Old 26th Mar 2010 at 6:28 AM
Major problem. No mods file. I'm using Windows 7. Would that make a difference? Help! Please! I get an error every time I try to install the helper monkey thingy.
Test Subject
#162 Old 26th Mar 2010 at 8:24 AM Last edited by LinksLove : 26th Mar 2010 at 10:32 AM.
This is frustrating...there are no apparent problems with the framework installation according to the Monkeybars Installer Tool, I have a packages folder withing a mods folder, the resource.cfg file in the root folder where it should be...everything! Yet the mods I have in the packages folder aren't showing up in the game at all. I hope there is something that can be done...
Test Subject
#163 Old 26th Mar 2010 at 1:08 PM
help it won't work on my vista what should I do I started to try and play but when the game started the movie before loading the game it crashes and its can't be anything but this because I have went through this six times the first time I had downloads from the store in my game and I downloaded this and I put a few things in the folder it created in HIGH END LOFT because it was the newest then I tried starting the game and it did the movie then it went down the second time I redownloaded all the things I had in my game lancher then I downloaded this thing and tried downloading things to WA and HEL it when down like before the third time I tried just the sims 3 it went down again The forth time I set it up for all three and put downloads in them it went down again the fith time I tried seperating things to go in each seperate mod package thing and I tried to go into the game and again it went down then finally the sixth time I just installed this thing no custom content and tried it and it went down again with no downloads nothing so it has to be this thing its not going well with my vista and from what I understand not may other vistas to how can I fix this
Warrior Gryphon
site owner
Original Poster
#164 Old 26th Mar 2010 at 3:43 PM
Cattoyou1588: tl;dr. Seriously, break your text up or I wont help.

LinksLove: If everything shows in the framework tool as fine (and I mean, big tick and all) then it sounds like you are doing something wrong in game or have tried to install items that aren't compatible, or perhaps are looking in the custom content area, when packages don't appear there.

violet1: What error?

scifinut: Why are you trying to open package files with this? This has nothing to do with packages.

Story books are full of fairy tales, of Kings and Queens, and the bluest skies.
Test Subject
#165 Old 26th Mar 2010 at 3:54 PM
I just don't know what to do Ive tried it all and it just doesn't work for vista sorry must be a vista glitch
Test Subject
#166 Old 26th Mar 2010 at 3:59 PM
what does tl;dr mean and how would you like me to back up my texts I don't understand
Test Subject
#167 Old 26th Mar 2010 at 9:29 PM
Hello Delphy...

I got a problem... but I don't know if it really something about your great tool...

If I put my .dbc in the Mods/DCCache Folder (which your tool generate), I can't build kitchens like I want to do... The corner cabinet allways change the colour and looks really bad... If I take the .dbc out of the Mods/DCCache Folder and put it back to the original place I can build the kitchen corer cabinet on a normal way. maybe it has something to do with your tool? or with the resources.cfg? sorry, that I ask, but I am trying the whole day to find out how to handle it...

I hope you can help me... thx a lot
Warrior Gryphon
site owner
Original Poster
#168 Old 26th Mar 2010 at 9:55 PM
BuffyASummers, as I recall, thats nothing to do with the framework or the tool, it's more something with the counters.

Story books are full of fairy tales, of Kings and Queens, and the bluest skies.
Test Subject
#169 Old 26th Mar 2010 at 10:48 PM
ok... than I don't stop trying to find a solution...

thank you very much... it was only a possibility for me..

THX a lot
Lab Assistant
#170 Old 27th Mar 2010 at 10:52 AM
And that's it???
I just click install and then close,right???
Test Subject
#171 Old 27th Mar 2010 at 7:01 PM
Quote:
Originally Posted by Delphy

scifinut: Why are you trying to open package files with this? This has nothing to do with packages.


I'm not opening the packages themselves... I read somewhere that if you have SimPE loaded on Vista, Vista will want to choose that program to run .package files. I also read (somewhere) that when you run Sims 3 with your previous program, that I would have to tell Vista to choose your program to use (instead of SimPE)... I'm probably getting it all mixed up now... I was just concerned that there would be interference/conflict with having both Sims 2 and Sims 3 custom content. I reloaded my OS and have to load all my games and programs again...and I recently purchased WA and HELS (and found your new Framework Installer...LOVE IT!!!).

Again, thank you!!!!
Test Subject
#172 Old 27th Mar 2010 at 8:13 PM Last edited by ellorial : 28th Mar 2010 at 6:25 PM.
i ran dashboard, it says i don't have framework for WA, everything is running fine since i deleted corrupt files. Do i need the framework in WA files? (game version 2.33, no HEL, win xp prof.)
Test Subject
DELETED POST
27th Mar 2010 at 11:24 PM
This message has been deleted by AngeHellback.
Test Subject
#173 Old 30th Mar 2010 at 12:00 AM
it didn't help me once install the program disapears from ur pc or is really hidden no uninstaller nothing.If you use awsome mod this may give you the same issue as me you get a message from awsomemod that either the core is a mismatch or there is another hack involved..I mean I would offer some sort of uninstaller for this program so people can chose to keep it on their pc or not.most often the game won't finish loading gets stuck it could or couldn't be this program but ehh I am stuck with a choice uninstall my game lose all my cutom content which alot isn't simply placed into the package file but installed using the game..such frusterating things guess it teached me not to use this kind of stuff to begin with..
Warrior Gryphon
site owner
Original Poster
#174 Old 30th Mar 2010 at 8:51 AM
MsRaven: Err, no, the program doesn't just "disappear from your PC". It stays whereever you extracted it from. You are the ONLY person to have ever reported that particular "issue" so to my mind it's not a problem with the program, it's probably something specific you are (or are not) doing.

I highly doubt that this tool caused issues with awesomemod, since this tool only sets up the framework for you to use custom content. It does not and is not custom content in and of itself. I would suggest you look to your actually installed CC for the solution to that one.

Story books are full of fairy tales, of Kings and Queens, and the bluest skies.
Page 7 of 33