MTS has all free content, all the time. Find out how YOU can help to keep it running. Tell me how...

Testers Wanted - Framework Installer tool - Now deprecated

by Tashiketh Posted 28th Dec 2009 at 12:23 AM - Updated 22nd Nov 2011 at 11:56 PM by Delphy
821 Comments / replies (Who?) - 17 Feedback Posts, 4 Thanks Posts
ATTENTION - This tool is NO LONGER UPDATED!

If you want to install a framework to your Ambitions, Fast Lane, Outdoor Living or Generations, just download this file: http://chii.modthesims2.com/FrameworkSetup.zip and extract it to My Documents\Electronic Arts\The Sims 3. Thats it. Next time you load the game you wont see the intro - if you do, then you screwed something up.

For more help, please see http://simswiki.info/wiki.php?title...Setup_and_Files

I will no longer be offering support for this tool and it is now deprecated!


Operating System: Windows

You must have the expansion or stuff packs listed below installed to use this custom content. Please see the post text for any exceptions.

Sims 3
Key: - File was updated after upload was posted
Filename - Tip: You can click the magnifying glass to see the archive contents Size Downloads Date
MonkeyBars.rar

Size: 79.3 KB · Downloads: 336,825 · 28th Dec 2009
79.3 KB 336,825 28th Dec 2009
Don't forget to Thank the creator after downloading! Use the Thanks button located above the screenshots above.
Quick Guide:

1. Click the file listed on the Files tab to download the file to your computer.
2. Extract the zip, rar, or 7z file. Now you will have either a .package or a .sims3pack file.

For Package files:

1. Cut and paste the file into your Documents\Electronic Arts\The Sims 3\Mods\Packages folder. If you do not already have this folder, you should read the full guide to Package files first: Sims 3:Installing Package Fileswiki, so you can make sure your game is fully patched and you have the correct Resource.cfg file.
2. Run the game, and find your content where the creator said it would be (build mode, buy mode, Create-a-Sim, etc.).

For Sims3Pack files:

1. Cut and paste it into your Documents\Electronic Arts\The Sims 3\Downloads folder. If you do not have this folder yet, it is recommended that you open the game and then close it again so that this folder will be automatically created. Then you can place the .sims3pack into your Downloads folder.
2. Load the game's Launcher, and click on the Downloads tab. Find the item in the list and tick the box beside it. Then press the Install button below the list.
3. Wait for the installer to load, and it will install the content to the game. You will get a message letting you know when it's done.
4. Run the game, and find your content where the creator said it would be (build mode, buy mode, Create-a-Sim, etc.).


Extracting from RAR, ZIP, or 7z: You will need a special program for this. For Windows, we recommend 7-Zip and for Mac OSX, we recommend Keka. Both are free and safe to use.


Need more help?

If you need more info, see:
 
821 Comments / Replies (Who?) - 717 Feedback Posts, 59 Thanks Posts
Hide Thanks Posts for this thread (Show only feedback)
Page 30 of 33
Warrior Gryphon
site owner
Original Poster
#726 Old 21st Feb 2011 at 10:11 AM
marcyin3d: The Monkey Helper is deprecated and I no longer give support on it. Besides, this thread is about the framework installer, not the Monkey Helper.

If you want help installing package files, please see the FAQ in the Help -> Sims 3 menu. Thanks.

Story books are full of fairy tales, of Kings and Queens, and the bluest skies.
Test Subject
#727 Old 21st Feb 2011 at 6:07 PM Last edited by cathyjo73 : 23rd Feb 2011 at 5:00 PM.
Hello I have Late night installed and I cant get it to recongize my content and mods. can anyone help me please? Everything runs fine but it just doesnt show up. Is there a fix out there that can have it be recongnized for this exspansion pack?
Test Subject
#728 Old 27th Feb 2011 at 6:15 PM
asdhfea, I have EXACTLY the same thing as you, I have no idea what to do....
I've got Windows7 64-bit, my game is fully updated with WA and Ambitions, so looking at this thread, I shouldn't have an issue.
If I press continue, it takes me to the same screen, but nothing is ticked, and when I press install, it says the same thing.....
HELP ME!!!
Thank you
Test Subject
#729 Old 27th Feb 2011 at 9:41 PM
When I double click the rar files do they just install.. or do I have to actually put them somewhere in a specific folder?

Haven't played Sims in like 3 months to find my beloved Helper Monkey has been replaced with something that I can hardly understand. *sigh*
Warrior Gryphon
site owner
Original Poster
#730 Old 28th Feb 2011 at 6:06 PM
You don't need to install anything to get this tool to work. If you are curious about how to install CC downloads then please see the various FAQs in the help section for that. It's really just a question of sticking everything in one folder, easy as pie.

Story books are full of fairy tales, of Kings and Queens, and the bluest skies.
Test Subject
THANKS POST
#731 Old 2nd Mar 2011 at 6:35 PM
You're a great help to the entire Sims 3 community you are! (Especially for the noobs like me).

And monkey bars is a LOT better than Monkey Helper, it really screwed with everything... and it was starting to get annoying.
Test Subject
#732 Old 7th Mar 2011 at 9:08 AM
I just downloaded this and i have the Resource.cfg file yet it's claiming that i dont have the file and the only thing it's picking up is the mod/package file

help?
Warrior Gryphon
site owner
Original Poster
#733 Old 8th Mar 2011 at 11:26 AM
Ashakiran: Maybe you have it in the wrong place? Why don't you let the tool make the framework for you?

Story books are full of fairy tales, of Kings and Queens, and the bluest skies.
Test Subject
#734 Old 12th Mar 2011 at 2:24 AM Last edited by TsukiWakana : 13th Mar 2011 at 5:17 AM.
I'm still very new to sims 3 and custom content, so please forgive me if it's a simple solution.. I have windows 7 and .NET Framework 3.5.1 (will it work with this version?) I have the green tick like in the image in the overview, but when I run Sims 3, absolutely none of my mods work... I've been sitting at my computer for hours now looking up different help on installing CC for TS3, looking for what might be missing files, and constantly checking to see if I have everything in the right spot.. The mods I have are some sliders for and two hairs for CAS and a slider hack and they wont show up in the launcher... Please help me!
Test Subject
THANKS POST
#735 Old 13th Mar 2011 at 1:10 PM
Never mind, I finally figured it out. I had deleted all the framework I put in and used the framework installer to do it for me instead. Turns out the only thing I was missing was a folder titled DCCache (but after I clicked install, I ended up with a bunch of red ticks? Iwas really confused after that....) and now my mods work! So thanks a ton Delphy!
Test Subject
#736 Old 14th Mar 2011 at 7:23 PM
Default another error
when i run the installer tool i get the error

Quote:
unhandled exception has occurred in your application. if you click
continue the application will ignore this error and attempt to continue. if
you click quit the program will close immediately.

cannot insert the item "checking path
C:\users\duncan\documents\electronic Arts\the sims 3" in more than
one place you must first remove it from its current location or clone it.
perammiter name: item.


then theirs a detail box with this in it

Quote:
See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.ArgumentException: Cannot add or insert the item 'Checking path C:\Users\duncan\Documents\Electronic Arts\The Sims 3' in more than one place. You must first remove it from its current location or clone it.
Parameter name: item
at System.Windows.Forms.ListView.InsertItems(Int32 displayIndex, ListViewItem[] items, Boolean checkHosting)
at System.Windows.Forms.ListView.ListViewNativeItemCollection.Add(ListViewItem value)
at System.Windows.Forms.ListView.ListViewItemCollection.Add(ListViewItem value)
at FrameworkInstaller.Form1.checkLocations()
at FrameworkInstaller.Form1.rescanFrameworkToolStripMenuItem_Click(Object sender, EventArgs e)
at System.Windows.Forms.ToolStripItem.RaiseEvent(Object key, EventArgs e)
at System.Windows.Forms.ToolStripMenuItem.OnClick(EventArgs e)
at System.Windows.Forms.ToolStripItem.HandleClick(EventArgs e)
at System.Windows.Forms.ToolStripItem.HandleMouseUp(MouseEventArgs e)
at System.Windows.Forms.ToolStripItem.FireEventInteractive(EventArgs e, ToolStripItemEventType met)
at System.Windows.Forms.ToolStripItem.FireEvent(EventArgs e, ToolStripItemEventType met)
at System.Windows.Forms.ToolStrip.OnMouseUp(MouseEventArgs mea)
at System.Windows.Forms.ToolStripDropDown.OnMouseUp(MouseEventArgs mea)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
at System.Windows.Forms.ToolStrip.WndProc(Message& m)
at System.Windows.Forms.ToolStripDropDown.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4206 (VistaSP2GDR.050727-4200)
CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
----------------------------------------
FrameworkInstaller
Assembly Version: 1.0.3827.34180
Win32 Version: 1.0.3827.34180
CodeBase: file:///C:/Users/duncan/Desktop/New%20Folder/installer/FrameworkInstaller.exe
----------------------------------------
System.Windows.Forms
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4016 (NetFxQFE.050727-4000)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4205 (VistaSP2GDR.050727-4200)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4016 (NetFxQFE.050727-4000)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
MadScience.Helpers
Assembly Version: 1.1.3827.33743
Win32 Version: 1.1.3827.33743
CodeBase: file:///C:/Users/duncan/Desktop/New%20Folder/installer/MadScience.Helpers.DLL
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
<system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.


if i click continue then nothing happens except the msg box disappears

iv tried cloning and removing the file then putting it back in and same problem thx for taking time to real delphy

help

sigh
Field Researcher
#737 Old 18th Mar 2011 at 4:23 PM
"3/18/2011 9:40:38 PM: [3] The Installer could not find either a Resource.cfg or a Mods\Packages folder! This means that your Sims 3 WILL NOT currently accept custom content and installation via the Helper Monkey." Hey, But It also says,
"3/18/2011 9:40:38 PM: [0] Please install the Framework by clicking the Install button.."
So does this Monkey thing still work for me? Im just confused it says will not accept the things via monkey helper or something. Thanks.

Sorry for my bad English.
Test Subject
THANKS POST
#738 Old 19th Mar 2011 at 9:59 AM
I've seen a few screencaps with this problem, but havent really found the answer so here is my question...

Framework is in, packages in the right folders, everything is good. Now, I open the installer, it gives me the green check for a go, but the install button is grey out which should mean everything is good to go but the content still doesn't show up in the game. Am I doing something wrong here?
Warrior Gryphon
site owner
Original Poster
#739 Old 19th Mar 2011 at 10:29 AM
HavanaLove, that just means you got the content in the wrong place. It's not an error with the framework installer.

Artycka90: It means that you have to actually click Install...

Story books are full of fairy tales, of Kings and Queens, and the bluest skies.
Test Subject
THANKS POST
#740 Old 19th Mar 2011 at 6:11 PM
what about my problem delphy ???
Test Subject
#741 Old 25th Mar 2011 at 9:57 PM
Okay, I have read through the entire thread now and have read comments about similar problems but still don't quite understand the answers they were given. Please forgive me if I'm just being slow and this has already been answered.

I received these error messages, and tried clicking Install, but all that happened was I received the same error messages again underneath.

http://oi51.tinypic.com/11awfbo.jpg

I tried looking to see if I have a mods or Packages folder and I actually don't, if this is a separate issue my apologies again but I thought in one reply I read this tool was supposed to create those folders? I'm not sure tbh. In another reply I read I needed to create those folders myself and place them in The Sims 3 folder but after doing that I'm still getting the same error messages. Also I have no idea about the resource.cfg and which of those I am supposed to put where.

I have no idea what to try now, is there any help you could give?
Test Subject
#742 Old 26th Mar 2011 at 12:37 AM
hello, delphy
I just wanted to know why helper monkey isn't in your uploads anymore.
I also wanted to know if you needed it to install this tool.
thanks for your help!
courtneywuerz

Cookie
Test Subject
#743 Old 26th Mar 2011 at 8:45 AM
I'm having the same problem as Scratcharon (On pg 28) it's reading my sims folder as "C:\Program Files (x86)\Electronic Arts\The Sims (TM) 3" and it wont work, when I hit install it says I don't have the mods folder, package and resource file. However is it supposed to read the EA folder out of My Documents? Because when I try to make it use the EA folder in My Documents, which is where all my content is, it says the error message Scratcharon got. Saying my folder is copied somewhere, it's weird! But it seems to work when I take the (TM) off my folder..but then I can't start the launcher if I take the (TM) off. Any help?
Warrior Gryphon
site owner
Original Poster
#744 Old 27th Mar 2011 at 10:51 AM
Benisu: What patch level do you have? Because if you have the latest patch then it should detect that and do everything in My Documents. It does *try* checking Program Files first, but it should go on to check the My Docs folder after.

Courtneywuerz, You don't need Helper Monkey when installing packages is as easy as putting them in one folder.

Story books are full of fairy tales, of Kings and Queens, and the bluest skies.
Test Subject
#745 Old 30th Mar 2011 at 9:18 PM
hel
Quote:
Originally Posted by Delphy
If you run the Framework Installer tool does it give you a big giant tick, or a big giant cross? If it's a cross, please screenshot the program (as requested). If you have a tick, well, then you already have the framework and the resource.cfg.

well i REALLY need help i try to click install but it wont let me its grey so i cant click it ??? :O
Test Subject
DELETED POST
2nd Apr 2011 at 11:55 AM
This message has been deleted by crashdodgers.
Test Subject
DELETED POST
2nd Apr 2011 at 12:02 PM
This message has been deleted by crashdodgers.
Test Subject
DELETED POST
2nd Apr 2011 at 12:31 PM
This message has been deleted by crashdodgers.
Test Subject
DELETED POST
2nd Apr 2011 at 9:27 PM
This message has been deleted by crashdodgers.
Test Subject
#746 Old 2nd Apr 2011 at 9:52 PM
Hi Dalphy, Please can you help me I am running Windows 7 Pro, as my op’s system, and I just finished installing all of my TS3 games and cc, on to my system. Run framework installer, got a cross not a tick. A red highlighted lines stating “found Mods/Packages folders, but did not finned resource.cfg or dll, files. Both files are installed in the mods/packages folder and are up to date. Please advise as to nature of problem and sir jest a fix. Also I can only get cc packages to work in game if I install folders in c: program files (x86), game is fulley up todate, and will only work the old TS2 way of C: drive path. Sorry unable to post screen shot.
Thank You crashdodgers.
Page 30 of 33