MTS has all free content, all the time. Find out how YOU can help to keep it running. Tell me how...

Testers Wanted - Framework Installer tool - Now deprecated

by Tashiketh Posted 28th Dec 2009 at 12:23 AM - Updated 22nd Nov 2011 at 11:56 PM by Delphy
821 Comments / replies (Who?) - 21 Feedback Posts, 2 Thanks Posts
ATTENTION - This tool is NO LONGER UPDATED!

If you want to install a framework to your Ambitions, Fast Lane, Outdoor Living or Generations, just download this file: http://chii.modthesims2.com/FrameworkSetup.zip and extract it to My Documents\Electronic Arts\The Sims 3. Thats it. Next time you load the game you wont see the intro - if you do, then you screwed something up.

For more help, please see http://simswiki.info/wiki.php?title...Setup_and_Files

I will no longer be offering support for this tool and it is now deprecated!


Operating System: Windows

You must have the expansion or stuff packs listed below installed to use this custom content. Please see the post text for any exceptions.

Sims 3
Key: - File was updated after upload was posted
Filename - Tip: You can click the magnifying glass to see the archive contents Size Downloads Date
MonkeyBars.rar

Size: 79.3 KB · Downloads: 336,832 · 28th Dec 2009
79.3 KB 336,832 28th Dec 2009
Don't forget to Thank the creator after downloading! Use the Thanks button located above the screenshots above.
Quick Guide:

1. Click the file listed on the Files tab to download the file to your computer.
2. Extract the zip, rar, or 7z file. Now you will have either a .package or a .sims3pack file.

For Package files:

1. Cut and paste the file into your Documents\Electronic Arts\The Sims 3\Mods\Packages folder. If you do not already have this folder, you should read the full guide to Package files first: Sims 3:Installing Package Fileswiki, so you can make sure your game is fully patched and you have the correct Resource.cfg file.
2. Run the game, and find your content where the creator said it would be (build mode, buy mode, Create-a-Sim, etc.).

For Sims3Pack files:

1. Cut and paste it into your Documents\Electronic Arts\The Sims 3\Downloads folder. If you do not have this folder yet, it is recommended that you open the game and then close it again so that this folder will be automatically created. Then you can place the .sims3pack into your Downloads folder.
2. Load the game's Launcher, and click on the Downloads tab. Find the item in the list and tick the box beside it. Then press the Install button below the list.
3. Wait for the installer to load, and it will install the content to the game. You will get a message letting you know when it's done.
4. Run the game, and find your content where the creator said it would be (build mode, buy mode, Create-a-Sim, etc.).


Extracting from RAR, ZIP, or 7z: You will need a special program for this. For Windows, we recommend 7-Zip and for Mac OSX, we recommend Keka. Both are free and safe to use.


Need more help?

If you need more info, see:
 
821 Comments / Replies (Who?) - 717 Feedback Posts, 59 Thanks Posts
Hide Thanks Posts for this thread (Show only feedback)
Page 31 of 33
Test Subject
#751 Old 5th Apr 2011 at 10:16 PM
Quote:
Originally Posted by Delphy
Benisu: What patch level do you have? Because if you have the latest patch then it should detect that and do everything in My Documents. It does *try* checking Program Files first, but it should go on to check the My Docs folder after.

Courtneywuerz, You don't need Helper Monkey when installing packages is as easy as putting them in one folder.


I have the latest patch and when I try to make it go to My Documents it wont go D: Tells me that the file is somewhere else and all the stuff Scratcharon or w/e said.
Test Subject
#752 Old 7th Apr 2011 at 10:30 PM
I did every thing and I can't click the Install button.
Warrior Gryphon
site owner
Original Poster
#753 Old 8th Apr 2011 at 9:28 AM
If you can't click the Install Button then your Framework is probably installed.

Hint: Do you see a big tick?

Story books are full of fairy tales, of Kings and Queens, and the bluest skies.
Test Subject
#754 Old 8th Apr 2011 at 9:43 PM
when I start the framework installer ambitions is the only one that has a box and a check under framework.
Warrior Gryphon
site owner
Original Poster
#755 Old 8th Apr 2011 at 10:08 PM
Remarius: Yes, and the check is against "Global" which counts for all games Ambitions and above. So if you have anything recent, this is fine.

Story books are full of fairy tales, of Kings and Queens, and the bluest skies.
Test Subject
#756 Old 9th Apr 2011 at 12:47 AM
Ok just wondered since it did say it found all the framework components, resource.cfg and mod\package folder. but ambitions was the only one in the diagnostics none of the other games were. Thanks for letting me know.
Test Subject
#757 Old 10th Apr 2011 at 8:23 PM
It says everything's a-okay, but the 'install' button won't light up for me to click it. (Is it even suppose to? Gosh, I'm clueless here...) I'm pretty sure that otherwise, it's installed right, but the Helper Monkey still says there's no framework. Can you help, please?
Warrior Gryphon
site owner
Original Poster
#758 Old 10th Apr 2011 at 10:10 PM
Helper Monkey is outdated, and shouldn't be used anymore. If this tool says you have a Global framework, then you are good to go.

Story books are full of fairy tales, of Kings and Queens, and the bluest skies.
Test Subject
#759 Old 12th Apr 2011 at 1:34 AM
Everytime I try to install it,it says I have everything,but it won't let me push the install button.I included a picture any help would be appreciated.
Screenshots
Warrior Gryphon
site owner
Original Poster
#760 Old 12th Apr 2011 at 12:45 PM
twinatopia: If you have everything and you can't push the install button then you are done, and don't need to use the tool to do anything.

Story books are full of fairy tales, of Kings and Queens, and the bluest skies.
Test Subject
#761 Old 13th Apr 2011 at 2:22 AM
Default Help
I know this thread is like reallyyy old, but I just did this now, and its not working for me
Screenshots
Test Subject
#762 Old 16th Apr 2011 at 5:05 PM
does it work with latest expansion? (late night, fast lane, etc)
Lab Assistant
#763 Old 17th Apr 2011 at 8:31 PM
Default Error Message
I am having some issues normally never do and have run this program a numerous amount of times. I keep coming up with the error that some of the famework has not been installed it is especially showing on the Global I am running windows 7 64 framework is installed in fact I even went in manually to install some of the framework itself, but still keep coming up with a specific error. I will send you a copy of what I have for an error message and the text itself.

Another question where is the global supposed to be?
Download - please read all instructions before downloading any files!
File Type: zip Error Message.zip (1.19 MB, 25 downloads)
Description: Error Messages when installing framework
Warrior Gryphon
site owner
Original Poster
#764 Old 17th Apr 2011 at 9:38 PM
kece: What versions / patches do you have installed?

The framework goes in the My Documents folder if you have Ambistions - there is a nice wiki article telling you how to install it manually.

Story books are full of fairy tales, of Kings and Queens, and the bluest skies.
Test Subject
#765 Old 18th Apr 2011 at 12:57 AM
Everytime I try and use dashboard it says framework is not installed,but when I try to install the framework it says I have everything but the button is faded.
Test Subject
#766 Old 18th Apr 2011 at 3:41 PM
Delphy, the framework installer doesn't seem to register that I have Late Night. With the exception High End, my other SP's don't register, either. Is this normal or the sign of an impending problem?
Warrior Gryphon
site owner
Original Poster
#767 Old 18th Apr 2011 at 6:43 PM
Queen: Tis perfectly normal. Everything after Ambitions uses the same "Global" framework anyway.

Story books are full of fairy tales, of Kings and Queens, and the bluest skies.
Test Subject
THANKS POST
#768 Old 21st Apr 2011 at 11:21 PM
Hi Delphy, I just wanted to post my thanks to you... this tool has saved my butt (and my game!) numerous times. Super easy to install and to use
Test Subject
DELETED POST
24th Apr 2011 at 3:01 AM
This message has been deleted by Courtneywuerz.
Test Subject
#769 Old 24th Apr 2011 at 3:08 AM
Quote:
Originally Posted by Delphy
Benisu: What patch level do you have? Because if you have the latest patch then it should detect that and do everything in My Documents. It does *try* checking Program Files first, but it should go on to check the My Docs folder after.

Courtneywuerz, You don't need Helper Monkey when installing packages is as easy as putting them in one folder.


I got a big X when trying to install this1 help!

Cookie
Test Subject
DELETED POST
30th Apr 2011 at 11:22 PM
This message has been deleted by dsfblaze.
Test Subject
THANKS POST
#770 Old 30th Apr 2011 at 11:23 PM Last edited by dsfblaze : 30th Apr 2011 at 11:49 PM.
i redid my comp and reinstlled the sims 3 and put in all the ex and stuff packs in then i updated the sims 3 then tryed to install the Framework and i got a err it sead
4/30/2011 5:08:29 PM: [0] Checking path C:\Users\slow\Documents\Electronic Arts\The Sims(TM) 3.
4/30/2011 5:08:29 PM: [3] Found resource.cfg: No.
4/30/2011 5:08:29 PM: [3] Found Mods\Packages folder: No.
4/30/2011 5:08:29 PM: [3] The Installer could not find either a Resource.cfg or a Mods\Packages folder! This means that your Ambitions WILL NOT currently accept custom content and installation via the Helper Monkey.
4/30/2011 5:08:29 PM: [0] Please install the Framework by clicking the Install button..
and every time i click the button i get the same with the new up dates so i uninstalled the sims 3 and every thing elice and reinstalled just the sims 3 then tryed to put the Framework in and it worked fine is there something i can do to to get it to work with the newest patch ??? ((( or when will this be updated ????
Test Subject
#771 Old 1st May 2011 at 3:33 AM
Quote:
Originally Posted by Delphy
AHM: Thats easy - delete the resource.cfg, move your Mods folder, and remove the .DLL.


Move the mods folder where??? I installed this framework thingy and now my game won't load.

So where would I put my package files then????

Im really upset here.. this is my day off... I just bought Late night and only played like a half an hour.. went on Delphys Organizer to check compatability and it told me I needed to download this framework so I did, now I can't play. Totally Bummed!!!!
Warrior Gryphon
site owner
Original Poster
#772 Old 1st May 2011 at 9:34 AM
apluper: If the game wont load, it's becuase you have a bad package file - ie one that doesn't work with whatever patch level you have. This is not a problem with the framework installer.

dsfblaze: It works fine with the newest patch. Just so long as it has a green tick and a tick against "Global", thats all you need. If you have problems using the installer just do it the manual way (which takes less than 5 mins) as detailed on the Installing Package Files wiki page.

Story books are full of fairy tales, of Kings and Queens, and the bluest skies.
Test Subject
#773 Old 4th May 2011 at 12:13 AM
Help! So I recently had a break in and lost my laptop along with my very old and well-developed Sims game!! Trying to get everything back now and i just cannot get cc to work with ambitions! I don't even understand what is going on. On my old laptop I had the original helper-monkey and every expansion throught late night and never had an issue with installing cc. Now I'm trying to reinstall everything on my new laptop and i just can't get custom content to work and this program doesn't seem to be helping me. I run it and it tells me there's errors but when I click install to fix it, it just gives me the same message and ups the error count. I look in the files and everything seems to be where it needs to be so I don't understand how to fix this and I never had this problem before...What advice does anyone have about fixing this? It's been tooooo long since I've been able to play!
Page 31 of 33