Replies: 154 (Who?), Viewed: 266682 times.
Page 4 of 7
Lab Assistant
#76 Old 20th Oct 2009 at 2:28 PM
I've used the same number of groups, but I seee this @_@.
Seems that I have reversed the map, but I don't think...

Forum Resident
#77 Old 20th Oct 2009 at 2:38 PM
One of those groups (in the original cloned object) is the drop shadow. You need to leave that alone, and make sure the order of the groups in the list matches the original.
What you are seeing in that pic now is the texture of the dropshadow (which is always linked to it) over your own object.
Lab Assistant
#78 Old 22nd Oct 2009 at 7:43 PM
Thanks lemon!
Now i have another problem. Today i've tried to create a bed, when i test it in the game it's all right but...the bed vanish when the sims go to bed....@_@
Lab Assistant
#80 Old 23rd Oct 2009 at 11:00 AM
ok thanks!

question for the programmers: with regard to all mesh in the sims 3 are important the bones (or joint?, excuse me for the language) (in the sims 2 was important also for the body mesh and accessory)and often I've seen the .smd extension, that support the joint. Why for the sims 3 can't use .smd extension?
Original Poster
#81 Old 23rd Oct 2009 at 2:39 PM
The .smd support for Sims 2 was added as a 3rd party plugin to SimPE maybe a year or better after it was released.

So the reason is that no one has written any .smd support. No one has written any object meshing plugins for anything but MilkShape (there is a body meshing plugin for Blender). We seem to be stuck with just a very few people that are actually making any tools at all.

If you like to say what you think, be sure you know which to do first.
Lab Assistant
#82 Old 23rd Oct 2009 at 2:48 PM
ok, I ask because i can't use the joints in milkshape (I could use .smd extension in 3ds) XD
Can you tell me a tutorial for MilkShape/joints?

At the moment i see my objects (bed) right, but the animation has a little problem XD, when the sims gets out ,the bed moves with her
Lab Assistant
#83 Old 25th Oct 2009 at 8:49 PM

Today i tried make a tv but the screen ist black in game. I´ve not changed anything of the screen. No scale or move an leave the original group how it was. But its not working.

I´ve made a new tv for a time with older versions of programs and this will work fine. Just clone and put in game is okay but if decompile and recompile a mlod or odl the screen is black.
Original Poster
#84 Old 26th Oct 2009 at 1:07 AM
If you can post the broken package, it will save me much time investigating this. I am curious, too, which older version worked, so I can see what might have changed after that point.

If you like to say what you think, be sure you know which to do first.
#85 Old 26th Oct 2009 at 9:19 AM
Mister WesHowe, maybe it has to do with the changes you have made, to correct the UVscale overflow?
Original Poster
#86 Old 26th Oct 2009 at 1:05 PM
It could be the .mtlsrc process, perhaps the recompilation of those, and there have been other things I fixed that could have made subtle changes. The old process copied the materials, the new one recreates them.

And I don't need to be called Mr., unless you are making a point. Wes is fine.

If you like to say what you think, be sure you know which to do first.
#87 Old 26th Oct 2009 at 1:19 PM
OK, Wes "making a point" is one of the finer nuances in the English language, I do not fully understand.

I wanted to express my deepest respect and gratitute to you for all the great work, you did and are still doing for us!
I should have called you Sir!
Lab Assistant
#88 Old 26th Oct 2009 at 4:52 PM
Hello Wes.

Here i´ve a testpackage for you. This is the original moderate flatscreen tv. Nothing changed at the package just export the first mlod, decompile and recompile it and after import it to package.

No changes at model or images and the screen is also black.

Thanks for spending time with this problem and hope you can find out where the problem is.

greets Schnuffi
Download - please read all instructions before downloading any files!
File Type: rar Schnuffi1982_TV_Test.rar (632.8 KB, 11 downloads) - View custom content
Original Poster
#89 Old 26th Oct 2009 at 7:39 PM
Thanks. I have it, I will study it soon.
I'll post about it here when I do.

<* Wes *>

If you like to say what you think, be sure you know which to do first.
Original Poster
#90 Old 26th Oct 2009 at 7:46 PM
Originally Posted by Cocomama
"making a point"

Means more or less a formal conclusion, a statement of position.

You are all very welcome to my small contributions to furthering the art of pixel primping. But calling me Mr. and Sir is too formal... and makes me feel as old as I really am.

If you like to say what you think, be sure you know which to do first.
#91 Old 18th Nov 2009 at 9:08 PM Last edited by ToRnado : 27th Nov 2009 at 7:46 AM.
is it possible to make meshes in other programs and export them not milkshape? like 3d studio max 2010?
Me? Sarcastic? Never.
staff: administrator
#92 Old 16th Dec 2009 at 5:16 PM
ERR: 228 bone count specified exceeds 128 limit.

I have cloned the double colonial bed and when I try to decompile I receive this error.

LoL This didn't help as I try to narrow down where the issue is with the bed covers giving tiny pointy bits.
Original Poster
#93 Old 16th Dec 2009 at 6:21 PM
MilkShape only supports 128 joints... you may remember MilkShape would crash in TS2 if you duplicated the skeleton (making 130 joints). There is no technical reason the ObjTool itself could not be made to work with more joints except for the limit in MilkShape.

If you like to say what you think, be sure you know which to do first.
Me? Sarcastic? Never.
staff: administrator
#94 Old 16th Dec 2009 at 6:35 PM
I guess I will test some more double beds then. :/ I wanted this one for the comfort stats.

I wonder if all TS3 double beds will have this issue? I probably could load into Wings but then I will lose all the joints, and I wouldn't know where they were supposed to be assigned to.

How do you suppose TSRW gets around this? I thought it supported .obj's? So how would the joints be reassigned?
Me? Sarcastic? Never.
staff: administrator
#95 Old 16th Dec 2009 at 7:24 PM
Apologies for the double post Wes but you were in the thread when I posted the last one and I wanted to make sure you saw this.

I did find a double bed that didn't give me any errors about number of joints.

However, there seems to an error in the decompile/recompile part of the tool for beds. Or maybe just the joints of the bedding.

This first pic is a clone of the Mission bed, I decompiled and then recompiled. I did not import it into Milkshape.

This is the original bed in game

As you can see the original bedding is nice and smooth, but after decompiling/recompiling it now because pointy and jagged.

Side by side, mine on left original on right.
#96 Old 17th Dec 2009 at 12:05 AM Last edited by orangemittens : 17th Dec 2009 at 12:45 AM.
This is the same error we discussed in the bed thread. If you're looking for a different double bed to try I think the ones we haven't tried between us are the 4 post bed, the Legendary bed, and the Double Sleep Raft. But I think they will give the same issue...just my hunch though.

Perhaps trying one of those would give the surprising result that we discussed in the bookshelf thread below...that one or two of the beds are made differently and will work just as there are two bookshelves made differently that *ought* to work (but, for some unknown reason, won't.)

I think the issues here aren't limited to just us which is why there is a dearth of beds and bookcases in Sims 3. I'm not sure about beds, and maybe TSR has fixed their bookshelf issue by now, but the last time I looked the TSRW couldn't make bookshelves either. It's a tough problem I guess.

Edited to add: scratch the Legendary bed off the list above...I didn't realize at first that this is the EA name of the Mission bed you've shown above HL...sorry about that.
Test Subject
#97 Old 25th Dec 2009 at 9:10 AM
hi dear friends
i'm majid-i'm iranian
i don't have plugins for open (*.s3asc) flies in milkshape 3d
i need to help please
Test Subject
#98 Old 25th Dec 2009 at 1:18 PM
help me when i click on the download button it says no koockies found
What should i doooo ????
Test Subject
#99 Old 7th Jan 2010 at 11:35 AM
Wes i just installed the World Adventures Expansion a few days ago and decided i wanted to mesh again, i updated Inge and Peters Plugins and updated to Object tool V1.00, when i try to Decompile the Modl or any of the Mlods i get this error

ERR: 160 vertex size specified exceeds 64 limit.

this is created from the LightingTableTikiTorch file, here are the modl bounds

MODL Bounds:
Min = -0.172211 0.000000 -0.191781
Max = 0.176125 0.508530 0.162427
Group Count = 2
Group 0: Faces = 36, Vertices = 72, Matl_block = 2
Group 1: Faces = 156, Vertices = 245, Matl_block = 8
Total faces = 192, Total Vertices = 317

This happens with all lighted files so far and concludes with Modl as well as the first Mlod file the remaining two seem to be ok?

is their a workaround? or an update i am missing?

Home of most of my creations.

Custom Sims 3
Original Poster
#100 Old 7th Jan 2010 at 6:58 PM
I always place limits on things when I am reading files so that if a file is damaged, or is of the wrong type, we don't crash and burn. However, by having limits sometimes we find items that are a little larger than the others.

I don't have WA actually installed here, you'll need to post me a MLOD/MODL file to decompile. Although I do know where to change the code to fix this, I don't know what all they would are stuffing in each vertex (usually this is position, normal, uv, assignment, weight and tangent) to make it that large, by contrast most game items have a vertex size of 32 or 36.

If you like to say what you think, be sure you know which to do first.
Page 4 of 7
Back to top