Replies: 4 (Who?), Viewed: 1169 times.
Original Poster
#1 Old 20th Sep 2020 at 3:26 PM Last edited by Dizzy-noodles : 21st Sep 2020 at 7:05 PM.
Default Default replacment, clothes showing with skin texture, please help - SOLVED, please see last post
Hello, I have returned to the Sims 2 after a 5 year hiatus, and have been default replacing some Maxis outfits.

I have been following tutorials, and getting on ok with both meshes with single groups, and meshes with more groups than the original.

However, today I have been trying to default replace an outfit and it has not worked. The Maxis mesh has one group, the new mesh has 2 groups. I have done a few others like this and they have worked fine.

But with this one, the boots of the outfit (the 'body_alpha' group in the mesh) show up fine, but the top of the outfit (the 'body' group in the mesh) has a problem with the texture showing up as skin.

I have added a screenshot (sorry if it's wrong, I can't remember how I used to do it when I posted on the forums last time).

I have double checked everything and even remade it from scratch a couple of times, I just can't work out what I've done wrong.

Please can anyone help?

Download - please read all instructions before downloading any files!
File Type: zip (752.3 KB, 8 downloads)
Mad Poster
#2 Old 21st Sep 2020 at 12:08 AM
Looks like the file is reading the mesh but not the texture, but it's difficult to figure out what's wrong without looking at the files (could pretty much be any of the edited resources, or one you've forgotten to edit). Can you upload them?
Original Poster
#3 Old 21st Sep 2020 at 9:21 AM
simmer22 = Thanks, I've added it to my original post in a zip file, I hope that's ok, thanks.
Mad Poster
#4 Old 21st Sep 2020 at 11:19 AM
One strange thing I can find is that the PropertySets have two sets of Version and Product lines, one at the top and one set at the bottom. It's possible these are causing some trouble, though I can't see why. I don't think you need to keep the bottom set for each of them, though.

Another is that all the TXMTs still have Normal Map references, but no actual normal maps. It's the 4 lines in the lists that start with "stdMatNormalMapTexture" - you can delete these if you want. Not sure if it helps, but you never know...

Also, delete the cache files before going ingame. When you've poked around in a CAS file a bit, especially after testing them ingame, these tend to save old references for meshes and textures, which can mess with your head a bit, especially when you change up meshes/morphs/textures. Deleting the caches resets any CAS/ingame/Bodyshop issues that might show up (Accessory/Groups), and updates Bodyshop thumbnails (cigen, and whatever the contentregistry file does). Sometimes things just "magically" goes back to working. Other times not, but at least you know that's not the problem.
Original Poster
#5 Old 21st Sep 2020 at 7:04 PM
simmer22 = Thank you so much, I tried your suggestions, and that has worked! I'm not sure which one worked, because I did all of them.

I'm really grateful, because I spent about 4 hours trying to fix it on Sunday, and if I would have had to give up on that outfit, it would all have been for nothing!

Thanks for all your help, it was really kind of you
Back to top