Replies: 8 (Who?), Viewed: 465 times.
Test Subject
Original Poster
#1 Old 7th Mar 2021 at 1:23 PM Last edited by dimyl : 7th Mar 2021 at 1:30 PM. Reason: bad English
Default Bon Voyage Accessory Problem
I have a problem with my custom Bon Voyage Accessory.

I want change my accessories as Bon Voyage Jewerly. I start with Earings. But when I want make my earings -for example- wear only with formal dress, it stucks. It become wearable with all clothing types. But it does not happend when I downloaded some custome bon voyage accessory.

I realy need help about it.
Screenshots
Advertisement
Mad Poster
#2 Old 7th Mar 2021 at 3:31 PM
Have you changed any settings in the file, and which?

Hat's tiptorial shows how to change already binned BV jewelry, BUT if you want to bin it directly from Bodyshop you have to use either the Wardrobe Wrangler or the tutorial at Maty. Links below:

https://hat-plays-sims.dreamwidth.org/34791.html (scroll to "BON VOYAGE JEWELRY BINS")
http://www.moreawesomethanyou.com/s...pic,9516.0.html (tutorial)
https://sims.jfade.com/index.php-ca...1&subcat=5.html (WW)
Test Subject
Original Poster
#3 Old 7th Mar 2021 at 5:07 PM Last edited by dimyl : 7th Mar 2021 at 5:19 PM. Reason: English
Quote:
Originally Posted by simmer22
Have you changed any settings in the file, and which?

Hat's tiptorial shows how to change already binned BV jewelry, BUT if you want to bin it directly from Bodyshop you have to use either the Wardrobe Wrangler or the tutorial at Maty. Links below:

https://hat-plays-sims.dreamwidth.org/34791.html (scroll to "BON VOYAGE JEWELRY BINS")
http://www.moreawesomethanyou.com/s...pic,9516.0.html (tutorial)
https://sims.jfade.com/index.php-ca...1&subcat=5.html (WW)


Thank you for reply simmer22!

I made sue earring 007 with a new mesh and recolor at glasses section. (Because of blue flashing problem) And I change it bon voyage jewerly with wardrobe wrangler. I didn't make it from simpe.

I Just check other downloaded jewerlys, which they working perfectly, but recolors and meshes look like same.

Biggest diffrent is how they look like in game. If they are working fine, they look like same with bon voyage jewerlys. If they don't working Fine, they look and act like glasses but seen in bon voyage jewerly section.
Screenshots
Mad Poster
#4 Old 7th Mar 2021 at 7:04 PM
Can you attach the files in a zip?
Test Subject
Original Poster
#5 Old 7th Mar 2021 at 7:16 PM
Quote:
Originally Posted by simmer22
Can you attach the files in a zip?


Sure. It will make me happy too I try to make recolors and change them with wardrobe wrangler. I create a test hood and try in it. Even I create a new game (rename my Program file EA games folder and let game regenerate a new EA games folder) and try in it too. Any of them doesn't show me the problem.

Only when I create a new EA Games folder, game recognize some of them but not the one I made.

In this topic I read the same problem, but cannot find the solution.
Download - please read all instructions before downloading any files!
File Type: rar Earrings-1.rar (266.3 KB, 2 downloads)
Mad Poster
#6 Old 7th Mar 2021 at 10:28 PM Last edited by simmer22 : 8th Mar 2021 at 7:26 PM.
Your files look like they're set up properly according to the tutorial.

For the weird thumbnails, I'm guessing the game uses the thumbnails that generated when the earrings were glasses. You'll have to update them (try Ctrl + Right-click on each thumbnail ingame).

They are showing up in the jewelry bin, and I'm guessing you can add them to a sim? Like with hairs, if you want to add them to a spesific outfit (formal, for instance), you have to click the outfit button "lock" and then select the "formal" category (the bowtie), adding the earrings to that particular outfit (this is not something you can do with regular glasses/accessories, by the way). If you don't do this, the jewelry option will be added to all the clothes as if it was a regular accessory.

Is there any other way you're expecting them to work?

---
The blue-flashing problem for the original files could be because there are leftover references to the frame and lens groups in the mesh, since the creator chose to rename the mesh group to "sue-earrings" (I've had some randomly happening blue-flashing issues wihen renamed accessory mesh groups lately, but only with accessories). Most likely that would need fixing. Another thing is that the TXMT settings need a small fix - go to the "cMaterialDefinition" tab in the TXMTs and change "StandardMaterial" to "SimStandardMaterial" - otherwise you get a lot of strange effects on the meshes.

EDIT: Sometimes a lens and/or Rim group needs to be added, this doesn't seem to be the case here (I thought so at first but then checked the files and saw they were renamed) - if you do find files like that, here's a tutorial for adding a placeholder Lens or Rim group: https://modthesims.info/showthread.php?t=283059 - could come in handy, and it's one of the main causes for why accessories flash blue.
Test Subject
Original Poster
#7 Old 8th Mar 2021 at 6:28 PM
Quote:
Originally Posted by simmer22
Your files look like they're set up properly according to the tutorial.

For the weird thumbnails, I'm guessing the game uses the thumbnails that generated when the earrings were glasses. You'll have to update them (try Ctrl + Right-click on each thumbnail ingame).

They are showing up in the jewelry bin, and I'm guessing you can add them to a sim? Like with hairs, if you want to add them to a spesific outfit (formal, for instance), you have to click the outfit button "lock" and then select the "formal" category (the bowtie), adding the earrings to that particular outfit (this is not something you can do with regular glasses/accessories, by the way). If you don't do this, the jewelry option will be added to all the clothes as if it was a regular accessory.

Is there any other way you're expecting them to work?

---
The blue-flashing problem for the original files could be because there are leftover references to the frame and lens groups in the mesh, since the creator chose to rename the mesh group to "sue-earrings" (I've had some randomly happening blue-flashing issues wihen renamed accessory mesh groups lately, but only with accessories). Most likely that would need fixing. Another thing is that the TXMT settings need a small fix - go to the "cMaterialDefinition" tab in the TXMTs and change "StandardMaterial" to "SimStandardMaterial" - otherwise you get a lot of strange effects on the meshes.

Tutorial for the placeholder: https://modthesims.info/showthread.php?t=283059


Hi. Sorry for late reply.

I just wanna thank you for help. It has solved my 3 diffrent problems.

I change my TXMT settings with SimStandartMaterial like you said and It fixed this weird transparency of my accessory.

And my blue-flashing problems. Thank you for tutorial. It make it much much more easier for me. I don't need to re-create my blue flashing accessory anymore, thanks to you

When I was have that multi-wear bon voyage jewerly problem (Is this the correct explanation? I realy don't know), I was create them at accessory and change them to bon voyage jewrly. And after that they was still acting like accessory. I was choose one jewerly for formal, one jewerly for outwear and no jewerly for everyday. But my Sim was wear them all together with all clothing types all day. So I think, If they was working exactly like orjinal bon voyage jewerly; problem must be with my game; not with CC. So I let game regenerate a new EA Games folder at my Documents folder. It is fixed, when I create them as accessory with a new game folder, change to bon voyage jewerly with wardrobe wragnler and add my real game after that.

I realy realy wanna thank you. And If I said something wrong, please forgive me. It is because of language barrier.
Mad Poster
#8 Old 8th Mar 2021 at 7:31 PM Last edited by simmer22 : 8th Mar 2021 at 7:43 PM.
The placeholder issue doesn't seem to have been the issue with the original files (but it often is an issue with blue-flashing accessories). It still could be a naming issue in the mesh, though (I don't think you added in the original mesh, so I couldn't check).

Accessories are very picky on naming. I don't think I've had these issues with hairs or clothes, but renamed accessory groups will sometimes flash blue out of nowhere, even if it seems all the names are proper in both the mesh and MeshOverlay resources. Sticking to the Frame and Lens groups seems to be the safest option, honestly (I don't have any issues with those).

---

Whenever you do changes to CAS files - ALWAYS, and I repeat, ALWAYS delete the Groups.cache and Accessory.cache files, and also the Contentregistry file if you've worked in Bodyshop. These can muck up how the game sees the files, and store old info about the files, to the point where old info still is being used by the game. They can also cause trouble on individual sims using the items.

Clearing those files before opening either your game or Bodyshop clears this old info and will make the game see the new version of the files properly.

You don't want to skip this step of CAS creation - I've had a lot of trouble with old files lagging behind (now I clear the files every time I play), and those files can create a lot of frustration...

(The Cigen.package can be deleted too if you want, it just holds Bodyshop thumbnails - can be a good idea if you're not seeing the proper thumbnails there, but it doesn't affect ingame thumbnails. If you have a lot of CAS CC and mostly use Bodyshop for making sims, not clearing this one can be useful for faster thumbnail loading)
Test Subject
Original Poster
#9 Old 8th Mar 2021 at 8:21 PM
I was forget to upload original file but you are right. Original file has sueearring007 renamed mesh and there isn't any frame or lens in it.

I was made my accessory.cache and group.cache read only. I Just delete them and all my problems are gone. It fixed how my jewerly acts and I am realy happy right now. I can't believe the solution is that much easy Thank you very much again.
Back to top