Replies: 10 (Who?), Viewed: 3026 times.
Scholar
Original Poster
#1 Old 9th Feb 2021 at 7:18 PM Last edited by Dizzy-noodles : 14th Mar 2021 at 3:29 AM.
Default Default replacement hair showing up orange/red with gaps, does anyone know how to fix this please? SOLVED, not sure how, see last post
Hello everyone,
As you may know from my other thread here https://modthesims.info/showthread.php?t=651980, I am currently working on changing the hair used with a hat, in a default replacement.

I got some advice from a kind person on Tumblr (I think it was Tumblr anyway), who explained that basically I also have to default replace the non-hat hair which is linked to the hat hair via the family string.

I have done 7 of these now, 5 have worked just great, but 2 of them have not worked properly.

I'm baffled as to why, because I have done them in the same way. The only difference I can see is, for the 2 that have not worked, the mesh has the groups 'hair_alpha5' and 'hair', with 'hair_alpha5' appearing first (the 5 that have worked all had multiple groups too, but 'hair' was always first).

I have used the same order in my property sets and 3IDR files, 'hair_alpha5' first (I did also try swapping the order around too, but nothing worked).

The issue is that the hair shows up as red/orange, with gaps too, I have attached a picture so you can see (apologies that it is so small, but I couldn't get a close up picture, as when I tried, the sim then changed outfits back into everyday, so the hair changed to the hat version instead).

I am guessing that maybe the file is struggling to find the textures, but I have added the TXMTs and TXTRs for each mesh group, and they seemed to be linked to each other correctly when I looked at the 'Value' for 'stdMatBaseTextureName'.

Does anyone know where I have gone wrong, and how to fix it please?

I have attached copies of both files (the one for fhairhathip_blue was originally texture only, so the everything else in there apart from those 5 TXTR files is for the non-hat version).

Thanks to anyone that can help
Screenshots
Download - please read all instructions before downloading any files!
File Type: zip fhairhathip_black_DEFAULT_Peggy_07978_Revallsay_Dizzy-Noodles_IKillButterflies.zip (4.18 MB, 9 downloads)
File Type: zip fhairhathip_blue_DEFAULT_Maxis_Maxboy_Dizzy-Noodles.zip (4.84 MB, 8 downloads)
Advertisement
Mad Poster
#2 Old 9th Feb 2021 at 7:53 PM
I think some of the issue is that the mesh layering is "upside down". For the Butterfly mesh, in Milkshape, the "Hair" group should be first in the list, and then the parts should be in order of opacity from lowest to highest number. It's showing up with a lot of opacity issues in Milkshape, which probably will get better when this is fixed.

The "hair" group should be the group linked to the head/scalp part of the hair, the one showing the skintone. At the moment, it looks like there's no blank texture for the "hair" groups, and they use the hairalpha textures instead. You'll want a blank texture for most hairs (or other methods to just have no hair on the head - Skell has a tutorial on that).

Also make sure all the mesh parts have the "HasTangentArray:" line in the comments (if you use Milkshape), or it may get that annoying "bright in CAS" issue.
Scholar
Original Poster
#3 Old 11th Feb 2021 at 12:26 AM
Thanks, I think I actually read that tutorial by Skell the other day, so I'll see if I can find it again.

That makes sense, as it seems to be the ones where 'hair_alpha5' is first that are giving me trouble.

Is it fairly easy/straightforward to re-order the mesh layers and add the 'Has Tangent Array' line in the comments, in Milkshape?

I do still have it on my computer, but haven't used it in years (probably 2014 at the most recent, it could be longer than that), and that was only to make shoe swaps, so I can't really remember how to use it.
Mad Poster
#4 Old 11th Feb 2021 at 3:15 AM
Quote:
Originally Posted by Dizzy-noodles
Is it fairly easy/straightforward to re-order the mesh layers and add the 'Has Tangent Array' line in the comments, in Milkshape?


It should be, yes.

Import the mesh as Unimesh* (not OBJ!). You don't have to do anything to the actual mesh, you just click the "Groups" tab, and find the "Comments" button. The Opacity line has the numbering/order, the HasTangentArray: line should be the 3rd line, and when you're done there, use the Up/Down buttons next to the Comment button to move the layer up/down. Hair should be at the top in the list, -1, 0, 1, 3, 5, 7 (or whichever numbering system is used, odd numbers is the most common) in descending order for the alpha layers.

If you've done it properly, if you add a material to the mesh, it should show up without any alpha issues with the "(right-click in 3D window) --> Transparency --> Depth buffered with alpha reference" setting if you apply the texture to the mesh in Milkshape. The program has a lot of limitations, but it has quite a lot of uses, too (very useful for finding and sometimes even fixing alpha issues in meshes).

When you're done, export as Unimesh, and import back into SimPE as Unimesh*.

(*Unimesh = right-click GMDC in SimPE and choose "Export" or "Import" - you've probably done this before. in Milkshape you scroll down to the "Sims 2 Unimesh Import" (or Export), it's almost at the bottom of the lists).

If you get problems with Milkshape, let me know and I can probably help you with the meshes.
Scholar
Original Poster
#5 Old 17th Feb 2021 at 8:25 PM
Thanks for your help.

Sorry for the late reply, it's been a busy couple of days with family stuff.

I decided to try this tonight, but it's been so long since I used Milkshape that it asked me to register. I think the last time I used it, I was using my old laptop, before it died (it was registered on that laptop I think). I remember transferring my computer programs over to this laptop when I bought it (which is quite old itself now), but I don't think I ever actually used Milkshape on this laptop, I just installed it and set up a desktop shortcut, as it was shortly after that, that I took a break from simming.

The chUmbaLum sOft website says I will be sent a registration code in about 24-48 hours - I have received a Paypal receipt via e-mail, but nothing from chUmbaLum sOft yet, which is a bit scary (I think most retailers send some kind of acknowledgement e-mail when you order something)!

Hopefully I'll get the registration code soon, but I just wanted to say I'm not ignoring you, I do appreciate the help
Scholar
Original Poster
#6 Old 23rd Feb 2021 at 10:16 PM
Hi, my registration code came through a couple of days ago, so I tried this tonight, thanks.

I did get stuck though, on my first attempt, I followed your instructions but I must have gone wrong or missed something out, it didn't work, so I deleted everything and decided to start again.

However, now I can't import the GMDC at all, I keep getting the error message 'ERR:Too many P1 sections for this implementation'. I had a google and found a workaround where you import the GMDC in 2 halves here https://modthesims.info/t/285636 but I keep wondering why it worked the first time and not now, and if there is a different issue too?

Do you know if there is anything else that can cause this error message?

I'm hoping I can try again tomorrow and see if I can get it to work.

I've counted in SimPE, there is one line for 'hair' and 24 for 'hairalpha5'. Some of them have the box to the left of them ticked in SimPE, some don't, do you know if this means anything please?
Mad Poster
#7 Old 23rd Feb 2021 at 11:10 PM Last edited by simmer22 : 23rd Feb 2021 at 11:44 PM.
The ticked box - I don't know exactly what that is, but I think it may have something to do with the Opacity setting. Not entirely sure which numbers give a tick and which don't, though (might have something to do with odd/even numbers, but that's just a theory, and I'm still unsure). Doesn't seem to affect the hair in any way I've found, though.

Not sure about the error message - I don't think I've seen that one before, but could be there's a limit to how many groups Milkshape can handle. There is a limit to how many polys it can handle - I think it's around 60-70k or thereabout. When it reaches the limit, the mesh will start flickering and disappear, or you get errors. Can be a problem if you for instance try to add a morph to a high-poly clothing item or some such.

Milkshape also doesn't like it if there's two materials named the same, or if there are two mesh groups named the same. It's fine if you import these meshes via a GMDC/5GD/SimPE/Unimesh file, but importing OBJs with the same name as another group will collapse those two groups on top of another, so be careful with that.

It does crash without errors when trying to export the Peggy mesh, and I do get the error if I try to import the mesh after the crash into a new file. I was allowed to import the hair over a different skeleton and then export it otherwise unchanged, but when I tried to just add in the "HasTangentArray:" lines, it crashed again. I don't know what's going on. Maybe consider adding a few of the groups together, (the underside layers can be collapsed into one layer, as that's usually not much visible anyway. If you have some distinct left/right sides, those can also be put into one layer, because they'll not be overlapping).

By the way, the "_tslocator_gmdc" text is missing from the GMDCs in the Peggy hair. Could potentially be a problem.
Scholar
Original Poster
#8 Old 10th Mar 2021 at 9:54 PM
Hi, sorry for the late reply.

I've tried this again today, I added the '_tslocator_gmdc' text to the GMDCs. I redirected the 'hair' TXMTs to a blank texture too.

Neither of these things worked, so I tried to export the GMDCs in separate parts in order to import them into Milkshape, but got a bit stuck, I couldn't get it to work.

I think when I read the other thread I just assumed I would be able to right click and extract in the same way as the whole GMDC, but that didn't work, and I could only find 'Export' which didn't work, I had a few options of different file types, but got an error message with the Milkshape one.

I'm starting to think this one is beyond my skills to fix - I might just try making a new default with a different mesh instead.

Thanks for all your help and advice though, I really appreciate the time you've taken to try and help me, and I have learned more about making defaults in general.
Mad Poster
#9 Old 10th Mar 2021 at 10:33 PM
I have no idea why the meshes throw errors. It could be there are too many hair layers with the same name for Milkshape to process.

One way around this would be to rename them maybe four and four (both in the Groups panel and in the Comments, although SimPE technically read the Comments) to for instance "hairalpha7" and "hairalpha9" etc. before exporting, and then rename them again to "hairalpha5" via the "Name" line in the "Groups" tab in the GMDC (SimPE shouldn't have a problem reading them).

If you still have issues with the mesh, I don't know what could be causing the error (especially since I get it too, and I don't think I've seen it before).
Scholar
Original Poster
#10 Old 14th Mar 2021 at 3:29 AM
Thanks, I decided to give this hair one last try this evening.

I started again, completely from scratch, and this time it worked - I have no idea why, or what was different, I even compared both files side by side in SimPE, and compared all the 3IDRs and Property Sets, but they were the same. I was really curious to find what caused the original problem, but I'll never really know I think.

The only thing that I did differently was that I downloaded a different non-bow version to use for the TXMTs, although I'm not sure how that could have caused the issue, so it's a mystery.

Thanks so much for all your help and advice, and being so patient with me, I do really appreciate all the time and effort you've gone to, it's very kind of you .
Mad Poster
#11 Old 14th Mar 2021 at 4:44 AM Last edited by simmer22 : 14th Mar 2021 at 5:08 AM.
My guess is that there was something iffy going on in the mesh you tried at first - but I have no idea as to what it could be. It's good you got it working, though.

Sometimes when everything fails, all you have to do is to start from scratch. You do the exact same things all over again, and then it works - and you have absolutely no clue what went wrong. TS2 and SimPE are funny like that (not)
Back to top