Replies: 4 (Who?), Viewed: 2076 times.
Test Subject
Original Poster
#1 Old 3rd May 2018 at 4:37 AM
Default Completely white/lagged out Sims 3 Game?
Problem here. I was recently on my Sims 3 game and I had quit to fix something with my mods. I went back, and everything was white! Not sure if it's just a glitch or it's a problem internally. No moodlets were there, no family showed up, no lifetime goal, 0$, nada. I couldn't even go and look inside my house! Though, a maid of my household had showed up okay, looking normal. Only thing I could do was look at town, and as I tried to set a house on a plot, it just sat there, there was no moving buttons, it's like it just lagged out. I had to use Ctrl-Alt-Delete to get out and restart my computer, which to no avail. I can provide photos if anybody needs to take a look.
Advertisement
Theorist
#2 Old 3rd May 2018 at 5:36 AM
You say you were working on mods. Rename your game and generate a clean one. If OK, you probably have a mod problem. Or just pull all out first and see what happens. If the only thing you have changed since your game worked was mods, that must be the issue?
Scholar
#3 Old 3rd May 2018 at 5:39 AM
Quote:
Originally Posted by devincita
Problem here. I was recently on my Sims 3 game and I had quit to fix something with my mods. I went back, and everything was white! Not sure if it's just a glitch or it's a problem internally. No moodlets were there, no family showed up, no lifetime goal, 0$, nada. I couldn't even go and look inside my house! Though, a maid of my household had showed up okay, looking normal. Only thing I could do was look at town, and as I tried to set a house on a plot, it just sat there, there was no moving buttons, it's like it just lagged out. I had to use Ctrl-Alt-Delete to get out and restart my computer, which to no avail. I can provide photos if anybody needs to take a look.

Yeah go ahead and post the pictures. Sims 3 is so unbearingly slow on my computer when it loads and the gameplay is even worst that it's like watching a slideshow that I just gave up on it and went back to 2.
Test Subject
Original Poster
#4 Old 3rd May 2018 at 5:48 AM
Thanks for the quick reply. Just decided instead of generating a new game, I would delete one of many mods I had just downloaded, and yeah, it was the problem. Everything it working better now. Thanks @daisylee
Theorist
#5 Old 3rd May 2018 at 7:51 AM
If something works and then is changed and it no longer works it is usually pretty certain the change broke it. I am glad it is OK now.
Back to top