Replies: 20 (Who?), Viewed: 1634 times.
Test Subject
Original Poster
#1 Old 5th Dec 2020 at 1:40 PM
Default Nvidia Settings for Sims 3
Hi.. I've recently purchased a new gaming PC. I had a gaming laptop before and I used this thread https://modthesims.info/t/578062 when changing the settings on Nvidia Control Panel which worked really well for my laptop. However when I've used the same settings on this PC it's not working as well and the graphics seem poor compared to the laptop even though it's supposedly a better graphics card. ie. tearing when moving, not as smooth in detail etc.

I was wondering if anyone had a more recent list of settings I should be using as that blog is from 2016. My graphics is NVIDIA GeForce GTX 1660 SUPER.

2nd question, I also have a gaming monitor with Nvidia G-Sync, any specific settings I need for that? Do I need to limit fps to 60 also?

Thanks for any help received.
Advertisement
Lab Assistant
#2 Old 5th Dec 2020 at 6:22 PM
Quote:
Originally Posted by ClaireSav1989
Hi.. I've recently purchased a new gaming PC. I had a gaming laptop before and I used this thread https://modthesims.info/t/578062 when changing the settings on Nvidia Control Panel which worked really well for my laptop. However when I've used the same settings on this PC it's not working as well and the graphics seem poor compared to the laptop even though it's supposedly a better graphics card. ie. tearing when moving, not as smooth in detail etc.

I was wondering if anyone had a more recent list of settings I should be using as that blog is from 2016. My graphics is NVIDIA GeForce GTX 1660 SUPER.

2nd question, I also have a gaming monitor with Nvidia G-Sync, any specific settings I need for that? Do I need to limit fps to 60 also?

Thanks for any help received.


For the 2nd question, YOU MUST to limit to 60 fps, otherwise,it will damage your graphic card.
Use that tool, Nvdia Inspector, better to set games in advanced.
Test Subject
Original Poster
#3 Old 5th Dec 2020 at 7:09 PM
Quote:
Originally Posted by SecretX
For the 2nd question, YOU MUST to limit to 60 fps, otherwise,it will damage your graphic card.
Use that tool, Nvdia Inspector, better to set games in advanced.


I've set it to 60 using Nvidia Control Panel, I don't see where on Inspector I can change anything though.
Screenshots
Lab Assistant
#4 Old 5th Dec 2020 at 7:44 PM
Quote:
Originally Posted by ClaireSav1989
I've set it to 60 using Nvidia Control Panel, I don't see where on Inspector I can change anything though.


U have to launch the correct .exe
This one "nvidiaProfileInspector.exe"
Test Subject
Original Poster
#5 Old 5th Dec 2020 at 8:44 PM
Quote:
Originally Posted by SecretX
U have to launch the correct .exe
This one "nvidiaProfileInspector.exe"


Thank you. Does the monitor have to be at 60 too as it's max 240
Lab Assistant
#6 Old 6th Dec 2020 at 1:07 AM
Quote:
Originally Posted by ClaireSav1989
Thank you. Does the monitor have to be at 60 too as it's max 240

As I said better is to set at 60fps.
Also, be sure your game recognize your graphic card. If you still feel lag or micro lag, let me know.
Test Subject
Original Poster
#7 Old 6th Dec 2020 at 11:38 AM
Quote:
Originally Posted by SecretX
As I said better is to set at 60fps.
Also, be sure your game recognize your graphic card. If you still feel lag or micro lag, let me know.


Thank you and yes my graphics card is matched. I'm actually now having draw distance problems where the sims houses detail fades when I pan away from the house.. But my draw distance setting is at max. I'm at a loss with this, I could tweak my laptop perfectly and it would be amazing and run great but this new pc just isn't behaving at all
Screenshots
Lab Assistant
#8 Old 6th Dec 2020 at 12:30 PM Last edited by SecretX : 6th Dec 2020 at 12:50 PM.
Quote:
Originally Posted by ClaireSav1989
Thank you and yes my graphics card is matched. I'm actually now having draw distance problems where the sims houses detail fades when I pan away from the house.. But my draw distance setting is at max. I'm at a loss with this, I could tweak my laptop perfectly and it would be amazing and run great but this new pc just isn't behaving at all


1/ I highly recommend you to set "High details lots" to 1 or 2
2/ Please activate the "Enable Objects Hiding"
3/ Set on Windowed Screen, with the higher resolution AND use that awesome tooltool it will allow to play in Fullscreen, even if ur game is set to windowed screen, u just fool it

** OH and I forget to tell you an important Tip, keep in mind each time you update your Graphic Card, Game settings will set as default and u have to repeat the change AND set the game to 60 fps also in Nvdia Inspector settings.
*** An advice, since you are an Nvdia user like me, I highly recommend you to uninstall the Nvdia GeForce Experience service, and each time u update your graphic card, only install Nvdia Driver, don't choose "Druver AND GEforce Experience", it knew to ruin performance in games.
Test Subject
Original Poster
#9 Old 6th Dec 2020 at 1:08 PM
Quote:
Originally Posted by SecretX
1/ I highly recommend you to set "High details lots" to 1 or 2
2/ Please activate the "Enable Objects Hiding"
3/ Set on Windowed Screen, with the higher resolution AND use that awesome tooltool it will allow to play in Fullscreen, even if ur game is set to windowed screen, u just fool it

** OH and I forget to tell you an important Tip, keep in mind each time you update your Graphic Card, Game settings will set as default and u have to repeat the change AND set the game to 60 fps also in Nvdia Inspector settings.
*** An advice, since you are an Nvdia user like me, I highly recommend you to uninstall the Nvdia GeForce Experience service, and each time u update your graphic card, only install Nvdia Driver, don't choose "Druver AND GEforce Experience", it knew to ruin performance in games.


Thank you i'll be spending the day doing everything suggested, in regards to nvidia control panel and.or nvidia inspector, are there any specific settings you have? Like I said the blog I used is from 2016 and I don't know if it's outdated or not.
Lab Assistant
#10 Old 6th Dec 2020 at 1:26 PM
Quote:
Originally Posted by ClaireSav1989
Thank you i'll be spending the day doing everything suggested, in regards to nvidia control panel and.or nvidia inspector, are there any specific settings you have? Like I said the blog I used is from 2016 and I don't know if it's outdated or not.


Just apply everything suggested first, and play/test to have an idea how is going, if it works better or not.
Test Subject
Original Poster
#11 Old 6th Dec 2020 at 1:47 PM
Quote:
Originally Posted by SecretX
Just apply everything suggested first, and play/test to have an idea how is going, if it works better or not.


I applied what you suggested and also removed Nvidia Geforce but the draw distance issues are still there plus graphics wise have become worse. Tree/grass detail blury etc
Lab Assistant
#12 Old 6th Dec 2020 at 2:16 PM
Quote:
Originally Posted by ClaireSav1989
I applied what you suggested and also removed Nvidia Geforce but the draw distance issues are still there plus graphics wise have become worse. Tree/grass detail blury etc


I think I misunderstand what are you talking about that supposed issue. Do u expect to see Sims Houses in full details infar distance ? It s no possible , keep in mind it s an old game .
About what I ve suggested, are you sure to uninstall GEFORCE EXPERIENCE PROGRAMM and no confused with nVDIA DRIVER ?

Go here, and type your engine specification and download the latest nvdia driver : https://www.nvidia.com/Download/index.aspx?lang=en
Test Subject
Original Poster
#13 Old 6th Dec 2020 at 2:21 PM
Quote:
Originally Posted by SecretX
I think I misunderstand what are you talking about that supposed issue. Do u expect to see Sims Houses in full details infar distance ? It s no possible , keep in mind it s an old game .
About what I ve suggested, are you sure to uninstall GEFORCE EXPERIENCE PROGRAMM and no confused with nVDIA DRIVER ?


I mean this is what houses look like when I move away from them (see image). It was never like that with my gaming laptop. And yes it was Geforce experience I removed.
Screenshots
Lab Assistant
#14 Old 6th Dec 2020 at 2:35 PM
Quote:
Originally Posted by ClaireSav1989
I mean this is what houses look like when I move away from them (see image). It was never like that with my gaming laptop. And yes it was Geforce experience I removed.


What s resolution u chose in Game option ?
Test Subject
Original Poster
#15 Old 6th Dec 2020 at 2:54 PM
Quote:
Originally Posted by SecretX
What s resolution u chose in Game option ?


1920 x 1080
Lab Assistant
#16 Old 6th Dec 2020 at 6:09 PM
Here is settings from Nvidia Panel Configuration...


Image smoothing : OFF

Anti aliasing - FXAA : OFF
Anti aliasing - gamma corrrection : OFF
Anti aliasing - mode : Application controlled
Anti aliasing - setting : Application Controlled
Anti aliasing - Transparence : OFF

CUDA : ALL

Shadow Cache : ON

Anisotropic filtering : 16X
Texture filtering - Distorsion LOD Negative : ALLOW
Texture filtering - Sample optimization : ON
Texture filtering - Quality : High Performance
Texture filtering - trilinear optimization : ON

Low Latency Mode : OFF

Power management Mode : Focus on maximum performance

Multi Frame Sampled AA (MFAA) : OFF

Number of frames per second : OFF

Optimization threader : OFF

Graphic processus OpenGL : (Your NViDIA graphic card)

Vertical synchronization : ON

Virtual Reality Frames : 3

Triple buffering : ON
Test Subject
Original Poster
#17 Old 8th Dec 2020 at 4:04 PM
Quote:
Originally Posted by SecretX
Here is settings from Nvidia Panel Configuration...


Image smoothing : OFF

Anti aliasing - FXAA : OFF
Anti aliasing - gamma corrrection : OFF
Anti aliasing - mode : Application controlled
Anti aliasing - setting : Application Controlled
Anti aliasing - Transparence : OFF

CUDA : ALL

Shadow Cache : ON

Anisotropic filtering : 16X
Texture filtering - Distorsion LOD Negative : ALLOW
Texture filtering - Sample optimization : ON
Texture filtering - Quality : High Performance
Texture filtering - trilinear optimization : ON

Low Latency Mode : OFF

Power management Mode : Focus on maximum performance

Multi Frame Sampled AA (MFAA) : OFF

Number of frames per second : OFF

Optimization threader : OFF

Graphic processus OpenGL : (Your NViDIA graphic card)

Vertical synchronization : ON

Virtual Reality Frames : 3

Triple buffering : ON


So much better, thanks for your help it's appreciated!
Test Subject
Original Poster
#18 Old 12th Dec 2020 at 9:13 PM
Quote:
Originally Posted by SecretX
Here is settings from Nvidia Panel Configuration...


Image smoothing : OFF

Anti aliasing - FXAA : OFF
Anti aliasing - gamma corrrection : OFF
Anti aliasing - mode : Application controlled
Anti aliasing - setting : Application Controlled
Anti aliasing - Transparence : OFF

CUDA : ALL

Shadow Cache : ON

Anisotropic filtering : 16X
Texture filtering - Distorsion LOD Negative : ALLOW
Texture filtering - Sample optimization : ON
Texture filtering - Quality : High Performance
Texture filtering - trilinear optimization : ON

Low Latency Mode : OFF

Power management Mode : Focus on maximum performance

Multi Frame Sampled AA (MFAA) : OFF

Number of frames per second : OFF

Optimization threader : OFF

Graphic processus OpenGL : (Your NViDIA graphic card)

Vertical synchronization : ON

Virtual Reality Frames : 3

Triple buffering : ON


Sorry to bother you again but i've just noticed this now. Things are transparent (see pics) and it wasn't like that before I changed settings. Do you know how to fix it please? I wouldn't be so bothered if it was just in CAS, Build/Buy mode etc but it's during game play too and I have a sim story so it's important for my pics.
Screenshots
Lab Assistant
#19 Old 13th Dec 2020 at 2:41 AM Last edited by SecretX : 13th Dec 2020 at 2:54 AM.
Quote:
Originally Posted by ClaireSav1989
Sorry to bother you again but i've just noticed this now. Things are transparent (see pics) and it wasn't like that before I changed settings. Do you know how to fix it please? I wouldn't be so bothered if it was just in CAS, Build/Buy mode etc but it's during game play too and I have a sim story so it's important for my pics.


Hey there,
No problem , you don't bother me
Well...I didn't meet that issue yet, maybe it's because of an option in Settings , the "Edge Smoothing" set to "High"...Try to turn Off and check if that work.
Otherwise, do you use Graphics Improvement tool such Reshade , SweetFX, or HQ mod ?
Test Subject
Original Poster
#20 Old 13th Dec 2020 at 9:56 AM
Quote:
Originally Posted by SecretX
Hey there,
No problem , you don't bother me
Well...I didn't meet that issue yet, maybe it's because of an option in Settings , the "Edge Smoothing" set to "High"...Try to turn Off and check if that work.
Otherwise, do you use Graphics Improvement tool such Reshade , SweetFX, or HQ mod ?


Hey. I don't use anything like that but last night i went through all of my settings and turning them off one by one abs checking in game and i believe it was ambiant occlusion being switched on. When switched off the problem went away.
Lab Assistant
#21 Old 13th Dec 2020 at 11:45 AM
Quote:
Originally Posted by ClaireSav1989
Hey. I don't use anything like that but last night i went through all of my settings and turning them off one by one abs checking in game and i believe it was ambiant occlusion being switched on. switched off the problem went away.


Nice u solve it , and thanks, then next time I ll be carefully about that setting.
Since your graphic card is really good and can handle the game perfectly, If ur looking for more graphic improvement, I suggest u Reshade ( But ! Choose FEWER effects )
Also , about your monitor , finally , In NVIDIA Inspector , in FPS Limiter option, set it to 120 , because you can handle it.
Back to top