Replies: 2 (Who?), Viewed: 9354 times.
Field Researcher
Original Poster
#1 Old 21st Mar 2017 at 6:56 PM Last edited by bellakenobi : 22nd Mar 2017 at 2:43 AM.
Default [SOLVED] .simgeom mesh all black when imported to milkshape
So, I'm retexturing a hair and I usually import the package to TSRW to visualize how the texture and control are and such. It is more practical to me than opening the game to do that.
This one I'm retexturing didn't opened on TSRW, I thought "well, I'll extract the mesh from the package with s3pe, import it to Milkshape and then I'll assign my control texture to visualize it".

But when I import the mesh into Milkshape, it is almost all black like this:

I made a quick research and tried the Face > Smooth All option but it didn't work. I also tried the Align Normals and it messed up the whole thing.

Am I doing anything wrong?
I don't want to edit the mesh and such, I just want to visualize how my control gets on the mesh without opening the game

The hair I'm retexturing is this one:

I'm bad at finding CC on my own
My simblr - My deviantart (where I post pictures of my crafts).
Virtual gardener
staff: administrator
#2 Old 21st Mar 2017 at 10:34 PM
I usually use Blender for this to prevent the weird black thingy from happening, but for some reason it's something that most CC creators don't bother changing or it's because of the way they compressed it into a GEOM file. In blender you'd want to select the entire mesh and use the shortcut CTRL+N and flip the faces/normals that are facing the wrong direction.
With milkshape, it's kinda the same, but I guess in this case you might want to flip them though. But since you're using the mesh for previewing your textures, I guess as long as it looks normal to you in the 3D view, I wouldn't worry about the mesh ^- ~
Field Researcher
Original Poster
#3 Old 22nd Mar 2017 at 2:06 AM Last edited by bellakenobi : 12th Apr 2017 at 6:54 AM.
Hi, thanks for your help! ^^

After some research I discovered that the issue wasn't on the mesh, it was on the texture I was importing to Milkshape.
I took a look a this Anubis control texture tutorial just in case and found out that the issue was because I was importing the control without the proper alpha!

I'm bad at finding CC on my own
My simblr - My deviantart (where I post pictures of my crafts).
Back to top