Replies: 3 (Who?), Viewed: 6733 times.
Field Researcher
Original Poster
#1 Old 12th Jan 2019 at 9:03 AM
Default Blender Error, will only import one group.
Whenever I try to import an object that with more than one group, Blender throws an error: https://i.imgur.com/VpbV8Nv.png

And then the object will only have the first group: https://i.imgur.com/6W324Tj.png
These are the groups it is supposed to have: https://i.imgur.com/ba7hWfT.png

So only the first group is imported.

BTW, my Blender skills are extremely weak and I might be doing something stupid or not doing something obvious. I have been looking for object tutorials that only use Blender but so far no luck.
Advertisement
˙uʍop ǝpᴉsdn ǝɹ,noʎ 'oN
#2 Old 12th Jan 2019 at 6:21 PM
This happens with any object with more than one group? What exact steps do you take to get this problem?

"Part of being a mesher is being persistent through your own confusedness" - HystericalParoxysm
| (• ◡•)| (❍ᴥ❍ʋ) [◕ ‿ ◕]
Field Researcher
Original Poster
#3 Old 14th Jan 2019 at 3:55 AM
I did more testing, I started with your tutorial http://modthesims.info/wiki.php?tit...diting_The_Mesh, and the tissue worked.

Then a cloned the car again, restarted Blender, but the same error came up and only the first group was imported.

Cloned sunset valley distant terrain (6 groups), Restarted Bender and this worked as normal in Blender. No error.

Cloned another car with 3 groups and it worked in Blender!

Now cloned the car that gives the same error again, restarted Blender and the same error persists. I exported MLOD 0001 of this problem car and that worked. The high detail mesh refuses to open. It has 6k verticles according to s3pe. The car that worked had 5k. The distant terrain had 3k.

So maybe having lot of verticles/polygons is the issue? Well: https://i.imgur.com/OZldrj5.png

My Wolrd Machine generated mesh has 65k and it loads without an error, but it does act weird when trying to open an image in UV window. The image becomes partially white when in Edit mode. After I UV unwrap it with Project from view (bounds), the image becomes whole again.
Field Researcher
Original Poster
#4 Old 18th Jan 2019 at 2:25 PM
I did more testing.

So, when I follow your @cmomoney simple mesh replacement tutorial with the tissue box, everything works great, no errors.
When I move on with your Creating end table with Blender and try to assign vertex and swap mesh, I have to swap the mesh with the EA end table mesh first and change the faces into triangles. Then I can assign the vertex to the mesh. After that, I try to export it and replace the old .s3m2b with my new mesh i get this error: https://i.imgur.com/hwmrJVn.png

It won't export it as SIMS3 MLOD\MODL. I had to export it as .obj and then go milkshape, replace the old mesh with my and test in game. It worked in game, but I still had to use milkshape which is a problem as I can't use milkshape to model my distant terrain. And distant terrain modelling is the whole reason why I am looking at blender tutorials in the first place.

I have attached the mess of a table (.blender file) but I don't have much hope.
Download - please read all instructions before downloading any files!
File Type: zip final.zip (76.9 KB, 10 downloads) - View custom content
Back to top