Replies: 75 (Who?), Viewed: 26804 times.
Page 1 of 4
Forum Resident
Original Poster
#1 Old 11th Oct 2009 at 1:21 AM Last edited by Hraklis943 : 11th Oct 2009 at 1:32 AM.
Default I need help with converting from TS2 to TS3...
Hello Guys....
I was desperate to convert some objects from TS2 into TS3 so i followed this tutorial:
http://www.blackpearlsims.com/showthread.php?p=537490
Step By Step
(Its Deluxe Designs tutorial but more simplified... )
So ok i followed all the steps(Well except the steps with mapping and cast cause i dont really know what to do there because nobody ever explains that part )
(I made the images black as it says but i dont know if thats right...)
So i choosed a table from University that used to be one of my favourites and as a clone from TS3 i choosed the Table-Licious table....
So as i said i bypassed the whole Mapping step and the Cast part....
I know i messed up but i really wanted to see if it would work....
So....this is the result...

Dont laugh please....i know its ridicilous..but its my first conversion... (Well actually its the second because i tried to convert the bear from OFB but something happened and the only thing that showed up in game was a weird thing like a shirt... )
Anyway...
I would really appreciate some help on how to make this table work....
I really want to convert stuff but im stuck on these steps....
So please help....
PS: I dont know how i managed to get the shadow to work....well actually is really small but if you notice its the actual shadow of the table...
PS2: Oh and please just to elt you know i dont know anything about meshing....this was my first attempt ever...
Screenshots

Check my tumblr:
http://eliasctifler.tumblr.com/
:)
Advertisement
Test Subject
#2 Old 11th Oct 2009 at 1:04 PM
you have to uv map it, that's your problem.. there is a small tuturail here http://www.modthesims.info/showthread.php?t=373981
Forum Resident
Original Poster
#3 Old 11th Oct 2009 at 1:17 PM
Yeah i just started reading it but i really dont understand some parts...mainly the part with the UV....can someome explain to me...?
Its the only part that im stuck....

Check my tumblr:
http://eliasctifler.tumblr.com/
:)
Forum Resident
Original Poster
#4 Old 11th Oct 2009 at 4:05 PM
Ok i converted another object from Uni and the same thing happens....

What should i do with the cast and uv mapping part?
Please help...
Screenshots

Check my tumblr:
http://eliasctifler.tumblr.com/
:)
Forum Resident
#5 Old 11th Oct 2009 at 4:39 PM
Dude, they won't just magically fix themselves for you
There's the tut that is linked above to help.
But maybe MS's Texture Coordinate Editor is more simple for you,
to map with that, you can use either MS's own helpfiles (I learned from that to be honest),
also Orangemittens has a link to her mapping tutorial somewhere around here, that is very easy to follow.
If you only want Sims2 objects converted, then you don't really need much editing on the UVmap, only some scaling and moving (while having all coords selected). Like you can see in my tutorial http://linna.modthesims.info/showthread.php?t=372692
Forum Resident
Original Poster
#6 Old 11th Oct 2009 at 4:56 PM
Quote:
Originally Posted by lemoncandy
Dude, they won't just magically fix themselves for you
There's the tut that is linked above to help.
But maybe MS's Texture Coordinate Editor is more simple for you,
to map with that, you can use either MS's own helpfiles (I learned from that to be honest),
also Orangemittens has a link to her mapping tutorial somewhere around here, that is very easy to follow.
If you only want Sims2 objects converted, then you don't really need much editing on the UVmap, only some scaling and moving (while having all coords selected). Like you can see in my tutorial http://linna.modthesims.info/showthread.php?t=372692

I know....
It would be cool if they were though
Ok im going to follow your great tutorial for the Textures and mapping...
Do i have to do the Bones assignments thing too?
Cause i dont know what that means...

Check my tumblr:
http://eliasctifler.tumblr.com/
:)
Forum Resident
#7 Old 11th Oct 2009 at 5:55 PM
If you're not doing objects with moving parts, then the bone-assignment is easy. Then there is only one bone. So you choose the "Joints" tab, click the button "SelUnassigned" and then the button "Assign". This will assign everything to that one bone that is highlighted above these buttons. You can ignore this all as well, but then the message will pop up when you are exporting ("Bone assignments missing!").
Forum Resident
Original Poster
#8 Old 11th Oct 2009 at 5:57 PM
Thank you!
Im converting a desk from TS2 right now following the guidelines...
I will post the results!

Check my tumblr:
http://eliasctifler.tumblr.com/
:)
Forum Resident
Original Poster
#9 Old 11th Oct 2009 at 6:52 PM
Ok something went terribly wrong this time...
I followed all the steps and thats what i got...

What the heck is that?
Its black because i CASTed on it....
Screenshots

Check my tumblr:
http://eliasctifler.tumblr.com/
:)
Forum Resident
#10 Old 11th Oct 2009 at 7:33 PM
You mixed up the order of the groups in Milkshape. The shadow has now your object texture and the object has the dropshadow texture. Reorder the groups.
Forum Resident
Original Poster
#11 Old 11th Oct 2009 at 7:39 PM
So this is my window...
group01 is the desk and group00 is the shadow...should i rename the desk to group00 and shadow to group01?

Thanks
Screenshots

Check my tumblr:
http://eliasctifler.tumblr.com/
:)
Lab Assistant
#12 Old 11th Oct 2009 at 7:45 PM
Hraklis943 I think you misunderstood. Look at the original Sims 3 desk that you are cloning. If the shadow is the group00 and the desk group01. Then the desk that your converting has to be the same way. You can not change the order of the groups. So like I said if the TS3 object order is shadow group00 and the desk group01 the TS2 object should be shadow group00 and desk group01. Hope this helps.
Forum Resident
#13 Old 11th Oct 2009 at 8:04 PM
Only renaming won't do it by the way, use the UP and DOWN buttons to reorder. I feel like a parrot for saying this like the tenth time... I hope we can get that all-around tut thingy working soon with all the info like this will be at one place for people to look up.
Forum Resident
Original Poster
#14 Old 11th Oct 2009 at 8:12 PM
Sorry for bothering you with stupid questions....
Its my first time ever....
Well i renamed them i re ordered them and i replaced the MLODS and the MDLO files of the package and now that i opened up the game there is but its invisible and non castable...
I mean its like placing an insible item....:/
Im gonna start over.....

Check my tumblr:
http://eliasctifler.tumblr.com/
:)
Lab Assistant
#15 Old 11th Oct 2009 at 8:19 PM
Hraklis943 these are not stupid questions and we all need help from time to time. This is the best place to ask for help by the way. Why don't you post your package so that someone can look at it.
Alchemist
#16 Old 11th Oct 2009 at 8:21 PM
It isn't a stupid question Hraklis943. The problem is that all the information people need is scattered through bunches of threads. At some point there will be a tutorial that will make the steps you're going through now easier to learn.

I'm wondering when you replaced the MLODs and MODL, did you make sure they were replaced and that the S3PE didn't merely add them to the package? When you run the object through S3OC it will automatically give the MLODs and the MODL new numbers so if you try to replace them again using the same MLODs and MODLs you were using it will add the MLODs and MODL but not replace the old ones you were trying to fix.

I hope that makes sense. The bottom line is, once those MLODs and MODLs have been through the S3OC you will have to figure out the new numbers and replace them or export the MLODs and MODL again and fix those.

OM
Forum Resident
Original Poster
#17 Old 11th Oct 2009 at 8:23 PM
Thank you very much petallotus....
I know that we all need help sometimes but i may being annoying with all these stuff...
So heres my package....
You can take a look if you want... (:
Download - please read all instructions before downloading any files!
File Type: rar Hraklis_DeskMission.rar (684.6 KB, 9 downloads) - View custom content

Check my tumblr:
http://eliasctifler.tumblr.com/
:)
Forum Resident
Original Poster
#18 Old 11th Oct 2009 at 8:24 PM
Quote:
Originally Posted by orangemittens
It isn't a stupid question Hraklis943. The problem is that all the information people need is scattered through bunches of threads. At some point there will be a tutorial that will make the steps you're going through now easier to learn.

OM

Thank you too orangemittens....
I really hope that this tutorial is going to be up soon....

Check my tumblr:
http://eliasctifler.tumblr.com/
:)
Alchemist
#19 Old 11th Oct 2009 at 8:39 PM Last edited by orangemittens : 11th Oct 2009 at 8:56 PM.
Use the up button to reorder the Groups.



Edited to add:

Hmm...I initially thought the shadow was the issue. But now I am not sure because it sounds like you have tried it both ways. There is something odd with your Red/Green IMG in MS. Something I haven't seen before so I don't know what is causing it. But when I apply that dds to the desk the desk partially disappears.

OM
Lab Assistant
#20 Old 11th Oct 2009 at 8:51 PM
I am looking at it again. I will post my findings. Hopefully we can help you fix this.
Forum Resident
Original Poster
#21 Old 11th Oct 2009 at 9:05 PM
Thank you very much guys...
I think that i might solved the problem....
I cloned the mesh again from TS3 and i replaced the MLODS,MDLO and the IMG files again...
The texture is not ok....and i cant change colours....when i recolor it with CAST to black this is the darkest it gets:
Heres the package
Screenshots
Download - please read all instructions before downloading any files!
File Type: rar Hraklis_2DeskMission.rar (602.1 KB, 9 downloads) - View custom content

Check my tumblr:
http://eliasctifler.tumblr.com/
:)
Lab Assistant
#22 Old 11th Oct 2009 at 9:12 PM
In the second package you mixed up your dds files. The red/green one should be the mask you have it as the specular?(i think that is what it is called) it is the one with the s in the filename. Try switching those two and see how it works.
Forum Resident
Original Poster
#23 Old 11th Oct 2009 at 9:24 PM
Ok i think its getting better
petallotus i did what you said (Stupid me... ) and now its much better i think....
Although there are still some negative parts....

There these strange litlle boxes at the corners and these lines in the middle and down....and how do i change this texture?
Screenshots

Check my tumblr:
http://eliasctifler.tumblr.com/
:)
Lab Assistant
#24 Old 11th Oct 2009 at 9:37 PM Last edited by petallotus : 11th Oct 2009 at 9:45 PM. Reason: Adding link for texture mapping
I just saw this great tutorial on texture mapping. It is very easy to follow and I believe it will help you with your textures.

http://linna.modthesims.info/showthread.php?t=373981

I am currently working on your texture. I too have trouble when it comes to this part, but I know that it has to do with uvmap. Don't worry we will get there and it is getting better.
Forum Resident
Original Poster
#25 Old 11th Oct 2009 at 9:40 PM
Thank you very much....
I also edited the texture images a bit and now im waiting for the game to load...

Check my tumblr:
http://eliasctifler.tumblr.com/
:)
Page 1 of 4
Back to top