Replies: 11 (Who?), Viewed: 804 times.
Field Researcher
Original Poster
#1 Old 24th May 2021 at 12:18 AM
Default Replacing Live.package UI Text Strings
I'm trying to replace the strings in the "Interests" section of the ui. I feel pretty certain I found the appropriate files, but the replacement isn't taking.

I tried to follow Chris Hatch's instructions, found in this thread, but changing the instance number to the one he gives didn't work for me, and I can't for the life of me find these "Filename:" or "Group:" boxes to actually see the instance number myself.

I have also tried renaming the file to Live.package (like name mods do), to no avail. (It currently has a descriptive name primarily for my own version control/organization.)


My test file is here:
(Trying to attach to post threw a 500 error.)
Field Researcher
#2 Old 24th May 2021 at 6:57 PM
Your test-file worked fine in my game. The only modification I made was to compress it's STR#-files. Btw I put the test-file in Downloads..
Field Researcher
Original Poster
#3 Old 24th May 2021 at 8:12 PM
It... just worked? Huh. That is absolutely not the answer I expected. I guess I have a different, more mundane cc puzzle to solve then. XD
Thanks for the compression and the testing! <3
Field Researcher
Original Poster
#4 Old 27th May 2021 at 7:57 AM
Okay, I can't figure out why it doesn't work for me. Even with no cc at all, it's inert.
I don't even really know what I should even be looking for that would be causing problems. :?
Field Researcher
#5 Old 27th May 2021 at 12:49 PM
The altered Interest-ui in my game is:
Field Researcher
Original Poster
#6 Old 27th May 2021 at 10:05 PM
Oof! It's so tantalizingly close! xD

What version of the game are you running? Is it possible the Ultimate Collection needs a different instance number? That sounds absolutely absurd, but I'm at a loss.
Let's see, what else is different...? Maybe I compressed the files wrong in my version? It's just that one dropdown, isn't it? (I just followed this old wiki entry:
Field Researcher
#7 Old 27th May 2021 at 11:10 PM
I have UltimateCollection and compressed in SimPe's resource tab. .
Field Researcher
Original Poster
#8 Old 28th May 2021 at 12:56 AM Last edited by AlfredAskew : 28th May 2021 at 3:10 AM.
Well then.
I'm completely lost. :/
I recompressed. I rebuilt the file. I've cleared out every cache file. I regened my Documents.

Okay, this is the same as yours, right?

I can't imagine what would be wrong with my program files that it would specifically break this package and nothing else. I have to have done something wrong.
Edit: Clean install, still no dice. This has got to be on me.
Field Researcher
#9 Old 28th May 2021 at 9:12 AM
I have compared the two files in SimPE and they are the same. I have tested both ingame and also looked at pets interest. All looked fine.
Field Researcher
Original Poster
#10 Old 28th May 2021 at 9:07 PM
Thank you so, so much for your help. <3
Do you (or anyone else out there) have any idea what would possibly get in the way of this thing loading?
I'm completely out of ideas.
Field Researcher
#11 Old 29th May 2021 at 9:02 AM
Most obvious reason is that your game have another language-setting than US English.
Field Researcher
Original Poster
#12 Old 30th May 2021 at 3:03 AM
Mystery solved!
Thanks so much. <3
Back to top