Replies: 6 (Who?), Viewed: 235 times.
Test Subject
Original Poster
#1 Old 5th Jul 2021 at 1:49 AM
Default Alpha blend mode makes my custom neighborhood deco pixelated
Hi! for some reason, when I put my neighborhood deco in alpha-blend mode (which in future steps I'll need to), it gets all pixelated (see the attached gif). Is there a way to go around this?
Screenshots
Advertisement
Mad Poster
#2 Old 5th Jul 2021 at 4:53 AM Last edited by simmer22 : 5th Jul 2021 at 5:12 AM.
Blend and full opacity don't mix very well. You'll want to make sure you only put Blend on parts that have transparent textures, or you get strange effects like this. It probably will look a bit better after you fix the textures.

Blend works best for glass and other see-through-type transparency.

If you have cutouts and not transparency (type leaves and flowers, items where the alpha is black and white), you can try different settings for a better result (stdMatAlphaBlendMode = none, stdMatAlphaTestEnabled = 1 )

For transparent textures, use DXT5 (or DDS).
DXT3 should be enough for cutouts unless the edges aren't neat enough.
Test Subject
Original Poster
#3 Old 5th Jul 2021 at 7:29 PM
Quote:
Originally Posted by simmer22
Blend and full opacity don't mix very well. You'll want to make sure you only put Blend on parts that have transparent textures, or you get strange effects like this. It probably will look a bit better after you fix the textures.

Blend works best for glass and other see-through-type transparency.

If you have cutouts and not transparency (type leaves and flowers, items where the alpha is black and white), you can try different settings for a better result (stdMatAlphaBlendMode = none, stdMatAlphaTestEnabled = 1 )

For transparent textures, use DXT5 (or DDS).
DXT3 should be enough for cutouts unless the edges aren't neat enough.



So, how do I put blend only on parts that I want to be transparent? Should I split the mesh or something?
Mad Poster
#4 Old 5th Jul 2021 at 9:10 PM
It depends on what you're making.

If you have some parts you want transparent and other parts not, then splitting the mesh might give you a better result, at least if the mesh is easy to split up.

If the texture is a mix between opaque, cutout and/or transparent, you may have to see which settings give the best results.

I can't quite see what you've made (the gif looks like very glitchy mountains) - if it's mountains of some sort, then aren't they supposed to be opaque?
Test Subject
Original Poster
#5 Old 6th Jul 2021 at 12:22 AM
It's basically a "skin" on the whole neighborhood terrain. I want it to be transparent in places where I's place the lots. I could split the mesh, though I'm gonna need to learn about making objects that have submeshes
Mad Poster
#6 Old 6th Jul 2021 at 2:39 AM
Not sure if neighborhood deco can have subsets like regular buy/build items can.

If you need the areas fully invisible, you could do the (stdMatAlphaBlendMode = none, stdMatAlphaTestEnabled = 1 ) method. It allows for cutouts, and is the one to go for if you need some areas to be fully invisible and others fully visible.
Test Subject
Original Poster
#7 Old 6th Jul 2021 at 6:09 AM
I'm already doing that. I want to make it so that the texture of the mountains gradually blends into the neighborhood texture so that the border doesn't look obvious or pixelated. I tried to get around this by making the default terrain close in color to my mountains, but it only works for certain angles.

Edit: this is in lot view. I'm already *almost* happy with this. I could try and cover up the edges with rocks. But it'd be nice if there was a solution that blended the two textures together
Screenshots
Back to top