Replies: 4 (Who?), Viewed: 8982 times.
Test Subject
Original Poster
#1 Old 14th Nov 2018 at 10:35 PM Last edited by SeptemberSimsForum : 15th Nov 2018 at 7:13 PM. Reason: Solved.
Default SOLVED Problem With Wall Mask When Cloning a Window
Yay! I managed to solve the problem! I opened "Text Lists" (STR#) > Object - Model Names and noticed that ##0x1C050000! is missing in front of name, so I just added it and wall mask appeared in the game.

Last month I have successfully created a new window following tutorial by IgnorantBliss. Before few days I decided to make a new one following the same tutorial but even though I tried many times there's a problem with wall mask when cloning. Today I tried again with simple cloning of "function plate glass window" (or something like that) and just giving it new GUIDs and then testing it in the game. The wall mask is not working. I was wondering is this SimPE's problem or with GUIDs (which I really doubt) or maybe other cc (which I also doubt)? I tried with 2 SimPE versions and the latest one from official site - same problem...
Dancing Flamingo
staff: administrator
#2 Old 15th Nov 2018 at 2:57 AM
Did you change any of the settings in Object Workshop? I would suggest you try clicking the link on the right side of Plugin View that says "Restore Defaults". I'm wondering if the box for Pull Wallmasks was unchecked. I've never quite pinned down the scenegraph and how the wall masks are linked, so I wasn't able to see the issue in your other thread. I think the issue is when cloning, and the wall masks are not linked.

Have you tried the version of SimPE you don't install, and just run from a folder?
Test Subject
Original Poster
#3 Old 15th Nov 2018 at 4:22 PM
Yes, I cloned at default settings and pull wallmasks checked. I'm also using SimPE from folder version

I will try later today delete and uninstall all SimPEs and try again with that one from folder which I used when I created window last month without wall mask problem.
Field Researcher
#4 Old 16th Nov 2018 at 1:39 PM
Congrats on finding that. I was coming online to tell you something similar. I edited the shadow mesh and mask txtr of the file you uploaded, and got the same results as you, then remembered to go back and Fix Integrity, which made the change to the STR as well as renaming your NREFs to your prefix instead of the SimPE prefix for the plate glass window. Voila - window works.


We have been stuck too long with "New Mesh" as the apex of creation.
_ WesHowe
Test Subject
Original Poster
#5 Old 16th Nov 2018 at 4:02 PM
d4RE, thank you for your time! This problem always kept me away from making windows and now to know how to fix it it's really a blessing.
Back to top