Replies: 1 (Who?), Viewed: 9956 times.
Test Subject
Original Poster
#1 Old 10th Dec 2018 at 2:03 AM
Default Milkshape: Black Spots on Hair Mesh
(Please let me know if this thread belongs to Sims 4 discussion instead!)

Hello, I'm currently attempting to convert Sims 4 hairs to the Sims 2, but I have encountered a problem. Every time I import the Blender object file to Milkshape, there are black spots all over the mesh.



I have the feeling that I messed up somewhere in Blender (maybe I don't know how to correctly select all the alpha hair), but I can't think of what exactly. By the way, the method I used to select hair has been pressing A and Shift-clicking everything labeled as a mesh.

Can someone with way more knowledge about Milkshape and Blender help me identify where I went wrong? Thanks in advance!
Advertisement
Mad Poster
#2 Old 10th Dec 2018 at 3:06 AM Last edited by simmer22 : 10th Dec 2018 at 3:16 AM.
You need to use the proper OBJ settings in Blender, or you'll get mesh normals all over the place.
Use the exact settings below and you'll usually get a good result (unless it's a pre-existing problem with the mesh)

(where it says 'operator presets' you can save the settings with the +, so it's just one click away every time you want to export OBJs).

And just a tip, but that mesh does look very high poly. You may want to consider if you really want to convert it, or whether it's possible to reduce the polycount (most high-poly meshes end up looking pretty much identical ingame if done properly).
Screenshots
Back to top