Replies: 17 (Who?), Viewed: 2248 times.
Scholar
Original Poster
#1 Old 8th Mar 2019 at 3:23 AM
Default Why does Appaloosa Plains keep crashing?
It has been a long time since I played in Appaloosa Plains, but recently I decided to give it another try. On my previous computer it gave me nothing but problems. It took forever to load, and would most often crash after playing for only a few minutes, or whenever I went into Edit Town mode. So I gave up on it. But I thought I might have better luck with my present machine, which handles TS3 far better. And I also decided to try Ellacharmed's fixed version. Everything seemed to work fine, until I went into Options to turn ageing on, and then minutes afterwards I had the "Sims 3 has stopped working..." message again. After several tries I found that it crashes every time I go into Options, whether or not I change any settings. This doesn't seem to happen in any other world, whether it is one of the default worlds or a custom world. So what is it about Appaloosa plains that's causes this?

Googling this, I find that others have had the same or similar problems. I have read many suggestions. A couple of people suggested it was a problem with public parking lots, which AP seems to have a lot of. Well, I deleted all the public parking spaces - I'm pretty sure I got them all - but that made no difference, it still crashed shortly afterwards. Another person suggested bugged horses. Hmm, well horses are rather the point with Appaloosa Plains, aren't they? And they don't seem to crash the game anywhere else.

Can any one offer any suggestions? Or must I once again give up on Appaloosa Plains?

Simblr: Elyndaworld *** Wordpress: Tales of Nantrelor
Advertisement
Inventor
#2 Old 8th Mar 2019 at 3:32 AM
TS3 doesn't crash at all on my PC, whether I'm playing in AP or any other world. CRASHES in The Sims 3 are generally caused by faulty custom content OR not having enough RAM. How much RAM do you have? How much RAM do you have free when you play the game? Could you share your DeviceConfig file, located in My Documents/Electronic Arts/The Sims 3?
Field Researcher
#3 Old 8th Mar 2019 at 5:25 AM
Have you temporarily tried to launch the game without CC? Or temporarily moved your user files?
What happens if you remove your user files (so no CC, no previous saves or families etc.), start the game and load Appaloosa plains fresh?
I were you, i'd just follow these steps: http://simswiki.info/wiki.php?title...Sims_3_Crashing even if I had just installed the game.

Another thing, Ellacharmed fixes are bit more complicated because they are multi-part files. I think I had trouble getting them to work when I was using winRAR, so used 7zip instead.

You do not have any problems with Isla Paradiso?

If the horses are a problem, maybe use one of the NRAAs (cannot remember which) to delete current horse population and let the game generate new set of horses?
Scholar
Original Poster
#4 Old 8th Mar 2019 at 6:13 AM Last edited by Elynda : 8th Mar 2019 at 6:37 AM.
@Naus Allien:

I've appended a screenshot of my device configuration below. I should note that, although it does say Intel(R) HD Graphics, I am actually using switchable graphics to use a more powerful Radeon 6490M graphics card, but for some reason that doesn't show in the file.

@MeowMixPls:

I did remove my user files and started a new game in Appaloosa Plains. I played for around half an hour and it didn't crash. So I concluded it must be mod or cc related. So then I used the 50/50 method to try and identify the culprit, but couldn't. Once all packages were back in, the game seemed to work fine for a while, and then started with the crashing again, whenever I went into Options. I can only conclude that it is two mods conflicting, but nothing shows up using Dashboard.

I shall certainly take a good look at that list.

I haven't had the same problems with Isla Paradiso. I am using Ellacharmed's fixed version of that too, and apart from the fact that it lags a bit, it appears fine.

As for the horses, I shall try that. You can use Nraas Register to delete them.

Thanks, both.
Screenshots

Simblr: Elyndaworld *** Wordpress: Tales of Nantrelor
Mad Poster
#5 Old 8th Mar 2019 at 7:04 AM
Have you tried the original version, not the Ellarcharmed version?

Sanity is overrated.

Nitromon is a type of Pokemon encountered in the Pokemon Nitrome Version series.

There. Mystery solved.
Inventor
#6 Old 8th Mar 2019 at 12:28 PM
@Elynda Two things about your DeviceConfig file: First, your CPU is pretty weak for the game, that's why it was given a rating of 2 (ratings go from 1 to 4) and the clock speed is quite low (2.20 Ghz) for TS3. I recommend that you unpark your CPU to squeeze as much performance out of it as possible; Second, I'm concerned about the game not detecting your dedicated GPU. If I were you, I'd disable your integrated Intel CPU from the BIOS to avoid incompatibility issues. There's no reason to have your integrated graphics card enabled if you have a dedicated one. Also, make sure the game detects your Radeon GPU by adding it to the GraphicsCards.sgr data base.

Why does it only happen in AP? Appaloosa Plains may be the world that pushes your PC beyond its limits (especially for an underpowered CPU and/or graphic card issues). AP has more horses and pets than any other world and these require more processing power (both from GPU and CPU) to be rendered. That's why people with integrated GPUs see lots of graphical glitches related to animals, like stretched meshes or black deer (I've always used powerful GPUs so I've never experienced those issues).
Scholar
#7 Old 8th Mar 2019 at 1:57 PM
Try lower resolution I would say. Lower resolution and lower your graphics settings especially for trees. Apaloosa Plains has kind of a lot of trees. Also you can try a smaller world that has a similar country vibe. Try this link http://www.carls-sims-4-guide.com/f...p?topic=26753.0 to recognize your graphics card.

If you like my mods. Consider supporting me on Patreon

Follow me on
Twitter
Instagram
Scholar
Original Poster
#8 Old 8th Mar 2019 at 10:36 PM Last edited by Elynda : 9th Mar 2019 at 12:00 AM.
@nitromon: yes, I've gone back to using the original version while I'm testing all this stuff out and it does the same thing - crashes whenever I got into Options.

@Naus Allien: I think we may have cracked it! I downloaded the Park Control program and set it to 'Bitsum Highest Performance'. Loaded up my Appaloosa Plains save and let it run for a bit. There was a noticeable improvement in performance, hardly any lagging even with graphics set high. Then came the biggy - going into the dreaded Options! I changed a few settings (BTW, I noticed that I had not enabled horses, but that doesn't seem to stop them appearing anyway). Then I went back into the game, zoomed out into map view, right clicked on some of my sims friends so that the camera focused on them, zoomed out again, scrolled the camera about a few times - and no crashing! Fingers crossed it stays that way.

As for your other suggestions: well, I'm a little nervous about disabling my Intel GPU, or meddling about with Bios in general. But I shall certainly look into getting the game to recognize my Radeon card. I've found a tutorial on how to do it, and when I've a quiet hour (when I'm unlikely to be interrupted) I'll work my way through it.

@PuddingFace: I have my graphics set high for story telling purposes, especially Sim detail so that my screenshots do my characters justice, but usually I turn them down for regular play. That was the reason I needed to go into Options. And, of course, when you change some of the settings, you're supposed to restart the game. But it kept crashing before I could do that. Hopefully that is now fixed.

Anyways, thanks all of you for your help, it's much appreciated. This problem with Appaloosa Plains has been baffling me for a long time.

EDIT: I've been playing for over an hour now, in and out of Options and Edit Town, and no crashes. I think it's fixed!

Simblr: Elyndaworld *** Wordpress: Tales of Nantrelor
Mad Poster
#9 Old 9th Mar 2019 at 12:56 AM
That's weird, while you should unpark your cores for max performance, however I cannot understand why it would have any affect on entering the options menu.

Anyways, are you on a laptop? If you're on a laptop your system runs optimus dual graphics so you shouldn't disable the Intel. The reason your Sims 3 is recognizing the Intel is either you ARE running the Intel or it is running your AMD but funneling through the Intel, which I've seen a couple of cases before. If you like, you can get GPU-Z to monitor your GPU usage to verify you are running it on the proper GPU.

https://www.techpowerup.com/download/techpowerup-gpu-z/

Sanity is overrated.

Nitromon is a type of Pokemon encountered in the Pokemon Nitrome Version series.

There. Mystery solved.
Inventor
#10 Old 9th Mar 2019 at 2:10 AM
there should be an option "run program with" (or something similar for Radeon like the NVidia panel control). And as @nitromon wrote do *not* try to disable the intel GPU on laptop (or any Optimus-kind-like switchable machine until it's some Linux distro and you know what are you doing). It is suppoused to switch by itself while detecting "high GPU power demand", which not always works. Anyway keep that Radeon enabled, because HD 3000 it's a really low low end for the S3 and you even do not have double channel RAM configuration, so the integrated GPU is crippled even more.

AP has some typical design problems (Ellacharmed templates does not solve them 'cause these are lot problems often, or problems beyond the scope of "fixes") but it would produce lag not "kill the game by entering options". Maybe template file is somewhat mysteriously damaged?

Fox-Lambert (A)RL
hiatus 'till the life run again in the normal-abnormal way
favorite quote: "When ElaineNualla is posting..I always read..Nutella. I am sorry" by Rosebine
self-claimed "lower-spec simmer"
Site Helper
#11 Old 9th Mar 2019 at 3:27 AM
@Elynda Make sure you make a copy of your original SGR files before you make alterations (In case things don't go as planned when making game recognize your new graphics card).
Scholar
Original Poster
#12 Old 9th Mar 2019 at 3:31 AM
Yes, I ought to have mentioned that I was using a laptop - sorry. And I'd a feeling that disabling the Intel GPU wouldn't be a good idea. The machine should switch to using it when it's unplugged and on battery power, although it usually resides on my desk and never goes anywhere. When I want a game to run using the AMD Radeon I right click on the screen to get to Switchable Graphics and then browse to the games .exe file.

So I've now gone back to using Ellacharmed's fixed AP and the game is still holding together with no crashing. I don't know what has actually fixed things, its all beyond me - being a tech ignorant old fossil. I downloaded the CPU-Z program that nitromon mentioned but I have no idea what I ought to do with it.

For now I'm just glad I can finally play Appaloosa Plains, and getting improved performance into the bargain is the icing on the cake.

EDIT: @fascisthater: Okay, I'll remember to do that. Thankyou.

Simblr: Elyndaworld *** Wordpress: Tales of Nantrelor
Mad Poster
#13 Old 9th Mar 2019 at 4:27 AM
Quote:
Originally Posted by Elynda
I downloaded the CPU-Z program that nitromon mentioned but I have no idea what I ought to do with it.


Oh sorry, um... ok so it is best used running Sims 3 in windowed mode, though it will also work in full screen, just have to alt-tab it.

Ok, so

- run GPU-Z first and you see it running. (technically it doesn't really matter which you run first. you can run this in the middle of TS3 or even close it) On the bottom you see a pull tab to switch which GPU to monitor. This only monitor the GPU, it doesn't switch the usage. On the top select "sensors" tab. When you're not running any major programs, Intel should be the one that is working so you will see "activity" in the Intel GPU stats while the AMD should be idling, with no activity.

- Run TS3 as you would run it. Load into a game and play a minute. Now if your TS3 is running the AMD, you will see the AMD GPU with a lot of activity such as high frequency, load, and temperature. The Intel will still have some activity, but far less.

If it is in windowed mode, you can observe GPU-Z at the same time. If you are in fullscreen, you have to alt-tab out to see it. When you alt-tab out of the game, the GPU-Z will show AMD GPU going idling, but it will still show the previous data it recorded in the minute you played.

- Now if your GPU-Z shows only activity on the Intel and not your AMD, then it is not using your AMD.

Sanity is overrated.

Nitromon is a type of Pokemon encountered in the Pokemon Nitrome Version series.

There. Mystery solved.
Scholar
Original Poster
#14 Old 9th Mar 2019 at 5:01 AM
Aha! Thanks for explaining that. I tried it in both windowed and full screen mode. It appears that the AMD GPU is being used. When I use full screen and alt-tab out of it, I can see where the Intel GPU kicks in and the AMD activity starts to idle. Very useful little utility that!

Simblr: Elyndaworld *** Wordpress: Tales of Nantrelor
Field Researcher
#15 Old 9th Mar 2019 at 10:36 AM
Glad you got it to work, but yeah bit suss that you had that problem only with CC on. Probably having that faulty CC was the last straw for your system under the old conditions but now it has more resources so it can deal with your CC? I was about to suggest http://modthesims.info/wiki.php?tit...ackage_File_Lag in case it could shed a light which file it was accessing when it crashed.

I once managed to make my options panel not work at all by fiddling with graphics rules file and putting inappropriate numbers in.
Scholar
Original Poster
#16 Old 9th Mar 2019 at 2:08 PM
I shall continue to try and track down whatever faulty cc there might be. My game has way to much of it anyway, and I am planning a purge.

In the meantime I cannot get my head around how to get my AMD Radeon card recognized by the game. The tutorial I was going to follow (http://www.carls-sims-4-guide.com/f...p?topic=26753.0) is no use to me, since it doesn't cover the case of having two graphics cards. In the example he gives his Nvidia card is already listed in DeviceConfig, although not yet recognized. The information in my own file all pertains to the Intel card.

This site https://crinrict.com/blog/2013/06/g...phics-card.html says that for Radeon cards I should use switchable graphics and that there ought to be a box to check saying "Show a pop up warning for unassigned applications", and that when you run the game you will be able to choose the better graphics card. But in my case there isn't any check box.

Simblr: Elyndaworld *** Wordpress: Tales of Nantrelor
Mad Poster
#17 Old 9th Mar 2019 at 2:22 PM
Quote:
Originally Posted by Elynda
In the meantime I cannot get my head around how to get my AMD Radeon card recognized by the game.


If the GPU-Z shows your AMD is being used, then you don't need to worry about getting Sims 3 to recognize it b/c there are a handful of laptop systems I've seen which they filter the AMD through the Intel driver. It only recognizes Intel b/c that is the driver responsible for all display, it just runs the appropriate hardware you switch to.

Sanity is overrated.

Nitromon is a type of Pokemon encountered in the Pokemon Nitrome Version series.

There. Mystery solved.
Scholar
Original Poster
#18 Old 9th Mar 2019 at 2:53 PM Last edited by Elynda : 9th Mar 2019 at 3:08 PM.
I see. So I guess my system must be one of those. And, in any case, so long as it works I shall be content to leave things as they are. If it works don't fix it, as the saying goes. Thanks nitromon.

Simblr: Elyndaworld *** Wordpress: Tales of Nantrelor
Back to top