Replies: 11 (Who?), Viewed: 1465 times.
Field Researcher
Original Poster
#1 Old 23rd May 2020 at 6:42 PM
Default My tattoos are there but invisible
I've created several tattoos and only the few that I did a long while ago show up (only one is clear the rest are blurred) I followed the tutorial I found on Youtube almost exactly to the letter. The only difference is I started with a PSD file but even converting it to DDS it still won't show up. It also doesn't explain why there are blurred ones because those I didn't do with a PSD file.
Even on the thumbnail they are invisible.

The weird thing is they show up fine on the Tattooinator or else I wouldn't get this far.
Advertisement
Lab Assistant
#2 Old 23rd May 2020 at 9:03 PM
I can take a look at it if you would like to share the file.
Field Researcher
Original Poster
#3 Old 23rd May 2020 at 10:00 PM
Quote:
Originally Posted by Slamyy
I can take a look at it if you would like to share the file.


Ok I don't know if you need both the DDS and package file but here's both:
https://filebin.net/u0ohhja9tvksxej3



Uploaded the one I worked with again recently and a past one just in case I did something different.
Lab Assistant
#4 Old 23rd May 2020 at 11:56 PM
Ok, I've done my testing. Firstly about looking blurry; all tattoos look blurry at some scaling grades. I even made a higher resolution image and that made no difference. But I think you can improve it a bit by making your image take more space of the canvas. Because I've noticed that it's very small, especially the cake one.
Now about the main problem; I'm not sure why yours look blank. And it's strange that it looks ok in Tattooinator. Just to confirm, you create a full black alpha layer and save it as DXT5 interpolated alpha right? I did the same thing and it showed fine in game.
Field Researcher
Original Poster
#5 Old 24th May 2020 at 5:04 AM
I just realized I said blurry when I meant to say faded. I'm a regular wordsmith today.

I was sure I saved as that but I will try again just to be sure. I haven't started over in Photoshop yet just opened it in Tattooinator. I was really hoping not to have to start over since I had a lot of tattoos.
Field Researcher
Original Poster
#6 Old 25th May 2020 at 2:29 AM Last edited by Drakesecaravdis : 25th May 2020 at 2:44 AM.
Ok I just redid that one and it looks like it did show up. It's still not showing up in the thumbnail but oh well at least it shows up on the body. I only wish I can see it better in CAS since it's difficult to tell if it looks right on the body. My main problem is the cake is shaded so I don't know if it's okay to color it all in black but I suppose I will have to settle for not being able to really see it until I go to live mode.

I'm saving another one as DDS and this one won't show up at all but I can see where it's supposed to be because of the color palette. What the heck? Do I have to redo the whole design over like I did the cake?
Virtual gardener
staff: administrator
#7 Old 28th May 2020 at 5:29 PM
Heya @Drakesecaravdis !

I just checked out the DDS files, and from the looks of it, it doesn't have the correct alpha channel. Without the alpha channel, but saving it as a DXT5, you will end up with an entirely transparent texture. (See S3PE as a reference, where the IMG isn't showing up in the preview, unless you untick the alpha channel). The reason why is, when you are exporting a texture as a DXT5, but there are no Alpha channels, the DDS exporter will make it's own alpha channel based on how much transparency there is in the background of the regular image. Now because the background is entirely solid colour in your case, it's going to think that there is nothing to be transparent.

So there are 2 methods you can try:

METHOD 1:
1. With the magic wand or quick selection tool, select the entirety of the cake (so without the black background being selected with it).
2. In the layers menu, click on 'add mask'. now you should see a checkered background.
3. Right-click on the Mask and click 'apply mask'.
4. Export as DXT5.

METHOD 2:
1. With the magic wand or quick selection tool, select the entirety of the cake (so without the black background being selected with it).
2. Go to Channels (You can also find this under Window > Channels).
3. When in the Channels section, you see 4 Entries. RGB, Red, Green, Blue. At the bottom, click the 'create new channel' option (is the same icon as adding a new layer).
4. Go to the paint brush and make sure you still got your pie selection. Then, paint that selection (in the alpha channel!!) white. White means visible, black means invisible.
5. Click on RGB again and save as a DXT5

Hope this helps!
Lab Assistant
#8 Old 28th May 2020 at 10:03 PM
@Lyralei Actually the alpha layer in tattoo case should be pure black unless 4 recolor channel is desired. Otherwise it looks weird. And when such image(dds with full black alpha) is opened in photoshop for some reason the alpha channel doesn't show up. It applies even to the original tattoo images of the game. But it actually has the black alpha and looks fine in game.

EDIT: @Drakesecaravdis Did you delete your thumbnail caches b4 trying it out?
Virtual gardener
staff: administrator
#9 Old 30th May 2020 at 11:41 AM
Oh whoops! My fault! Should've researched them better! I've always made overlay skins with tattoos, so I think that's why I forgot about the AMB tattoos... oops

The 2 methods though indeed wouldn't work for AMB tattoos. It would though, if you're applying them as an overlay skin with skininator.
Field Researcher
Original Poster
#10 Old 13th Jun 2020 at 2:38 AM
So I deleted the thumbnail cache and a few thumbs are still blank. But they are showing up on the body after redoing them so far (have a lot of tattoos I want to make)..you just can't see the detail and I did make them bigger in Photoshop. I'm going to have to redo the circle text one somehow because all it shows on the body is little dots.
Lab Assistant
#11 Old 13th Jun 2020 at 8:50 PM
Quote:
Originally Posted by Drakesecaravdis
So I deleted the thumbnail cache and a few thumbs are still blank. But they are showing up on the body after redoing them so far (have a lot of tattoos I want to make)..you just can't see the detail and I did make them bigger in Photoshop. I'm going to have to redo the circle text one somehow because all it shows on the body is little dots.

Interesting. I tested the circle text one and it looked fine as well as its thumbnail. I don't know what else to do about thumbnails but the detail loss might be caused by your texture quality setting set to low.
Field Researcher
Original Poster
#12 Old 27th Jun 2020 at 10:01 PM
Quote:
Originally Posted by Slamyy
Interesting. I tested the circle text one and it looked fine as well as its thumbnail. I don't know what else to do about thumbnails but the detail loss might be caused by your texture quality setting set to low.

What does it look like on your screen? When I put it to the body, I can still tell it is a circle but the detail is lost even though the texture quality is set to high. I guess this is not going to show up as well as the others as it is more detailed.
Back to top