Replies: 15 (Who?), Viewed: 27912 times.
Test Subject
Original Poster
#1 Old 29th Jun 2011 at 4:23 PM Last edited by Rope : 29th Jun 2011 at 9:08 PM.
"Ceiling is too low" error when placing pool on rooftop and floors
I am trying to place a pool on a fourth floor with no ceiling or roof above it. The very weird thing is that the game lets me do it only on some specific tiles. The floor below is empty so that's not the problem. Here's pictures of both floors:

I did google this problem but the only suggestions were to disable the auto roof feature and remove all roofs, but I had already did that.
Any help?
Test Subject
Original Poster
#2 Old 29th Jun 2011 at 9:01 PM
Seems like this topic is not being as successful as my other one, in terms of replies.
Veteran Finn
retired moderator
#3 Old 29th Jun 2011 at 9:46 PM
One thing that you could try is Constrainfloorelevation false, to flatten those floors. There might me a bump that is not visible to eye. Based on the elevators you have already used that cheat on the lot.
Test Subject
Original Poster
#4 Old 29th Jun 2011 at 10:49 PM
Thanks for the reply, but it didn't work. I think it's a bug. It behaves like a bug, because it does things it's not supposed to do. For example, when I click on one corner of the empty space and I hold and drag to the opposite corner, it tells me it can't be done, but it still creates some squares of pool here and there. Now this kind of behaviour I think it's wrong, cause normally if you can't build, say, 4 walls by dragging through an object, it just shouldn't do anything, not create some walls here and there and then tell you it can't be done.

The thing that surprises me is that, after searching with google, it seems that many people had this problem since the game came out, and it is still not fixed by an update.
Test Subject
#5 Old 30th Jun 2011 at 11:22 AM Last edited by Jamesalot : 30th Jun 2011 at 11:32 AM.
I had this same problem a few days ago- two different messages, actually, one being the message about the ceiling being too low with the pool, and the other was about the spiral staircase I was trying to put on the floor below- "needs standard height wall" or something like that.

That second message is what finally tipped me off to what the problem with the pool was- it wasn't referring the the ceiling above the pool (which didn't exist), but the ceiling of the floor below. In other words, the reason why I couldn't put the pool in was that there wasn't enough room between the floor below and the one I was putting the pool on for it to fit. Other places it had enough room (or more, for all I know) so it would work there. Near as I can tell, what happened is that I put down the individual walls one at a time and then filled in the floor afterwards, which as Armiel said left small bumps. That kind of thing probably never mattered before, when you could only put pools on the ground, and all the staircases were variable height anyway, but now that the expansion has added a couple things that really have to have the right height, it's causing issues.

And I did use the CFE cheat to fix it, but had to do it a particular way since just doing the floors would warp the other while fixing the one I was leveling. (Or possibly, I was leveling from a "bad" spot and just made them all equally off. I've not tested enough to be 100% sure). What I did was to turn on CFE, then level from a spot just outside the building on the ground to smooth out the ground floor. Then on that same spot, I built a 1x1 box and smoothed out the second floor, and so on, always working from the same lot square to make sure the elevation was correct each time. Which, oddly, worked on that one but not on the next one- an EA-built I'm rehabbing because my wife likes it. But EA lots often have weird elevation blips so I basically just did the same thing only starting from the top and working down which cleared the problem enough for my purpose.

Otherwise you basically are left with the option of starting over and using the level terrain tool to make absolutely sure the land you're building on is table-flat from the start. Which I'm positive will work but doesn't help much in your current situation, I'm afraid.

Anyway, hope that helps. But the main thing to remember is that it has nothing to do with the ceiling above the pool, but the amount of room between the floor below (where the bottom of the pool will be) and the floor you're putting the pool on. So for once it's not so much a glitch as just a really poorly worded error message.
Test Subject
Original Poster
#6 Old 30th Jun 2011 at 4:19 PM
Thanks for your post Jamesalot, even if I have to say I got a bit confused at some point. Probably cause I only used the Constrainfloorelevation cheat once and I thought it was an automatic thing that flattens everything. I haven't played around with this cheat or with various terrain elevations, but I am sure that my lot was completely flat since the beginning, cause I bulldozed a park (the one with the dome in Bridgeport) and then put a 64x64 lot there and it was completely table-flat.
Also, there IS enough room on the floor below the floor where I'm trying to put the pool, in fact it is completely empty, as you can see it in the second picture in my first post. Yes, there is a cimney and some stairs but there is a lot of empty room in which the game is not letting me put even a 1x1 square of pool, as shown in the first picture.
That was a lot for testing and playing around anyway, so I guess I'll try to start over and put the pool first of all.
Test Subject
#7 Old 1st Jul 2011 at 3:07 AM
That wasn't quite what I meant- I wasn't referring to there being any objects (chairs, tables, what have you) on the floor below, but the amount of room between the actual floor and the floor above. As in, let's say for argument's sake that the default height of a room- i.e. the distance between floor and ceiling- is, in real-world terms, exactly ten feet (not that it necessarily is, but it's a nice round number). And that the amount of space required for a pool to fit is also exactly ten feet. This doesn't matter on the ground, (plenty of room underground) but on the upper floors, it starts to matter.

Why? Because, if your ground isn't completely, *perfectly* level, but just looks that way, every time you add a floor to that the one above is also off. So in some spots on the grid, instead of there being ten feet of difference, it's off by, oh, let's say two inches- which would be about 1/4 the height of a stair. Not really enough to notice, but when the game goes to add the pool, some squares end up having the necessary height on all four squares and so that square can have a pool. But the next one over might have only three corners of the square that have ten feet between it and the one below, with the last one having 9'10". Not good enough- it's ten feet or nothing, so, sorry, "ceiling too low". Does that make more sense?

Again, this is all just a guess, but it's based on at least a little testing. When I tried the same thing again today on the same lot on a duplicate version of Sunset Valley, I got the same results both with the pool and the staircase. So I'm fairly sure I'm at least on the right track as to what the problem was. (The lot I used was the pool next to the bookstore in SV, if you'd like to try it yourself and see if I missed something. Lord knows it wouldn't be the first time). But even if I'm not I can definitely say that using the level tool to make sure it's completely flat will keep that problem from happening. It did the four or five times I tried it, anyway.

Also, just bulldozing a plot and then replacing it with another is not enough to be sure the land you're building on is totally flat. It may look that way but that doesn't guarantee that it is. And when you bulldoze a building, the game resets the elevation on that lot to whatever it was before there was anything there. Which means that if there were slight bumps in the land before you put down your 64x64, they'd still be there until and unless you used the level terrain tool to smooth them out completely.

Hope that makes more sense than the 2 a.m. post.
Test Subject
Original Poster
#8 Old 1st Jul 2011 at 12:39 PM
Thank you Jamesalot, that is perfectly clear now. I've also seen a video explaining how the CFE cheat works, and I've seen that with that cheat you *can* change terrain elevation on a certain spot *after* you have already placed objects or walls/doors/etc, but if you put new objects (in the video, it was the car park space) on a terrain with different elevation, it will flatten it again. So a terrain with floor and walls can have bumps only if you manually apply them after you have put down those walls and floor, is this correct? Cause my point is, if my terrain had any bumps, by putting floor tiles over it, shouldn't it have gone flat again? I'm not sure myself but I'll check this now, I'll let you know..

Also, I just thought, when you have bumps on the ground, doesn't that push up the ceiling too? If a bump on the ground makes the floor 2 inches higher, won't the ceiling on that tile be 2 inches higher too? I mean, the actual distance between floor and ceiling shouldn't decrease, right? Cause, again, in that case the ceiling should not be considere as too low.
Test Subject
Original Poster
#9 Old 1st Jul 2011 at 12:52 PM
1: Placing a pool on a terrain with any kind of elevation, flattens that terrain. So that was a very good theory but seems like that's not what's causing the "ceiling is too low" issue.
2: Yes, if floor goes up for bumps, ceiling goes up too, distance between them remains the same.

Test Subject
Original Poster
#10 Old 1st Jul 2011 at 12:56 PM
The absurd thing is that, now that my floor is all messed up with various elevations, IT IS letting me place the pool anywhere (as long as there's no object on the floor below).

Test Subject
Original Poster
#11 Old 1st Jul 2011 at 1:02 PM Last edited by Rope : 1st Jul 2011 at 7:11 PM.
And now this is off topic, but I just made everything go underwater! Pretty cool effect, could be used for something:
Even my test-sim is underwater now, he's not drowning!
Test Subject
#12 Old 2nd Jul 2011 at 4:23 AM
Yep, placing a pool will flatten all the surrounding terrain- but only if the pool can be placed in the first place. If it can't, it won't flatten anything. With CFE on you can place the floor no problem; it just adjusts everything to fit. But I'm assuming from your original post that you didn't have it on, which is why it didn't work- the floor elevation was constrained. Same thing with the parking space- with CFE on, it will flatten the land. If not, it will say "can't place on slope" unless you use moveobjects on.

And I understand your point about the ceiling going up, along with the floor; in fact that was part of the problem I had when trying to figure out what was going on. What I realized though is that yes, those little bumps all go up in concert, but only by a single point (i.e. one corner of a tile). So let's say that one corner of a square is off by our hypothetical two inches. So the ground floor tile height at corner one is 0', corner 2 is 0', #3 is 0', and the last one is at 0'2". Move up three stories and at 10' a story, #'s 1,2, and 3 are all at 30' and #4 is at 30'2". They've all gone up in concert, yes, but only three have the same elevation on any given floor. (Which makes sense- when you raise or lower terrain you're acting on the corners of lot squares, after all).

What this leads to is, you start drawing your pool at corner #1, and every measurement follows from that one- 30' of elevation is where the pool is starting, so that's the level of the pool. At corner two, no problem. The second story elevation at that point is 20' so we have ten feet of room. Corner 3, same thing. Corner four though... elevation at that point on the second story is 20'2". And 30' minus 20'2" is only... 9'10". So while there's enough room for the pool at three of the four corners of the square, it doesn't have enough room on the last one, and that's enough to throw it off, and bam, "ceiling too low". Now, if you started drawing the pool at corner #4 it would have 10'2" of room at all three of the other corners, so it might work there; I don't really know.

In any case, I'm assuming you had the CFE cheat turned on in the pics where the elevations were all weird. With CFE on, the game just warps things as much as it needs to to make the pool fit. But it won't if it's not on, which was the problem you were having to begin with. If I'd been more awake I would have thought to point that out in my first post but it was 2 a.m. where I am so I was only half there mentally. Besides that though there is one drawback to using CFE to just force the pool to fit, and I know because I tried that first- because it warps things, it can cause problems in other areas- for instance when I took out the previously mentioned spiral staircase and then tried to put it back, and couldn't.
dodgy builder
#13 Old 2nd Jul 2011 at 11:35 AM
I had the same problem when I wanted a pool sticking out from the house. I tried all solutions possible I think. In solving a different problem I realized that there might be a roof level put in where there is no roof.

See this pic. I had a basement here, then I removed it. That caused the game to make a low 1/4 wall hight in that spot. So I then had tons of troubles placing my stairs. Try using CFE to raise the wall levels again.
Test Subject
Original Poster
#14 Old 2nd Jul 2011 at 5:47 PM Last edited by Rope : 2nd Jul 2011 at 6:12 PM.
Yes, I see now what I was doing wrong with the cheat. I guess I must have written "constrainfloorelevation TRUE" instead than FALSE the first time, so I thought it wasn't working. But I tried again now, without changing the elevation of anything, I just set CFE to FALSE and I was then able to place the pool where I couldn't before.
About that other story of the corners elevation, I have to say that I understand your explaination but I am not entirely sure that it works that way.
I understand you're saying that, if we try to create a pool by starting to drag the pointer from a corner that is lower than another corner on the same tile, the game will find that the "ceiling is too low", because it will calculate the distance between the ceiling and the floor below by keeping the value of the height of the corner we started to drag from rather than using the value of the height of the corner where the pointer is actually being dragged to. So my tile on the third floor has 3 corners at 4m and only one corner at 4.02m, with the floor below having that same corner on the tile below higher of 2cm (0.02m) as well. But if I start to drag the pool pointer from a corner with 0 elevation, and move it over the corner with 2cm of elevation, you say it will do 4m - 2.02m = 1.98m (and say ceiling is too low, as if, let's say, the normal space between two floors is 2m) rather than starting with the correct value of 4.02m - 2.02m = 2m (standard distance between floors, so ok)? Cause I don't think that's the case. But I'll try now.

EDIT: so, I just made some experiments and I've seen this.
With CFE on TRUE (default setting) you can never place the pool on a FLOOR with bumps, from whatever corner you start from, the highest or the lowest. On the GROUND you always can, it will level the ground to the height of the corner you started to drag from.
With CFE on FALSE (the actual cheat) it will let you place the pool anywhere with bumps, ground and floor, levelling the floor/ground to the height of the corner you started to drag from. Basically the effect you have on the ground with CFE TRUE also applied on the floor.
So I think that all that theory of the difference between the ceiling and the floor height it has nothing to do with anything. But it did make sense.
Test Subject
#15 Old 8th Jul 2011 at 4:27 AM
Well it's certainly possible that I'm wrong about the why- it wouldn't be the first time, for one thing. And it's definitely only a theory, for another.

But yes that's basically the point I was making about the corners. But the correct distance-between-floors value you state at the fourth corner is irrelevant (assuming I'm right, anyway). Yes, at that point you still have 2m of room. But that doesn't matter because the pool height has to be level when drawn (or laid down, or however you'd like to put it), just like walls. So with CFE on (i.e. floor tiles will not be warped/leveled) the height of the pool would be drawn at 4m across all four points and checking the height requirement from that point down. Walls do the same thing, only from the bottom up- try to put a wall under a floor that isn't high enough and you get the "blocked by floor tile above" message, or if the two points aren't level, the "can't be placed on slope" message.. The distance from the bottom of the wall to the ceiling/floor above must be exactly correct. And since pools do have walls that's at least not a complete stretch of an analogy, I hope.

(You can off course turn CFE off and then lower parts of walls or pools however you'd like. But even when it's off, they will still be level when drawn, if I remember correctly. Even if they have to warp something else to do it).

However the fact that having CFE turned off will level the ground/floor doesn't necessarily disprove my little theory, though- quite the opposite. Because while CFE can level things up, it can also push them down. This happens when using a modular stair with CFE on on, for example. It will push the floor tile at the level of the bottom of the stairs down. The question then becomes whether or not the pool does the same thing if it's starting at a point lower than the others. For example, you start at a corner with an elevation of 4m and all the others are at our hypothetical 4.02, with corresponding heights at the floor below of 2 and 2.02 respectively. So when the pool is drawn, if I'm right, it levels all the top corners to 4m, and, because it requires that 2m distance for the pool, it lowers the floors below to 2m as well. Starting from a higher corner to a lower, it might not need to touch the floor below at all, simply raising the rest of the floor at the top of the pool to the correct level and ignoring the one below. I don't really know; I just suspect that it does because of the spiral staircase I mentioned which suddenly couldn't reach the top floor despite having been in the same spot before having used the CFE cheat to put in the pool.

Of course I could also very well just be over-thinking the whole thing. It might very well be that, thinking back to the wall analogy, that the pool has to be level when drawn and the whole "ceiling too low" thing really is just a poorly chosen error message. With CFE at "true" it can't level it out, with CFE at "false" it can, so it works. Frankly I could go either way on it but I think that's at least as likely and simpler, to boot. Which wouldn't be the first time I've been slashed with Occam's razor, come to think of it.

Volvenom- did it just lower the walls to that height or actually put them in? Or did it leave them behind? Just curious since I've managed some really weird things with the build cheats on but that's a new one for me, anyway.
Test Subject
#16 Old 23rd Jun 2012 at 2:50 PM
while reading this post i was having the same problem however when i realized that i forgot to flatten the lot it was the cause of the same problem... turning the CFE cheat off then let me do the pool of my liking... also in some point in the game my sim somewhat "phases" between floors. as if he or she was a ghost. cant seem to make a screenie but it happen ALOT to me.. what i do is this.. i create my house and complete it to the point of adding stairs... but what i like to my stair is so that it was suspended in a foundation so it would look like a royal castle like stairs... you know one of em stairs in a cross formation making a balcony inside... dunno if its the problem but sometimes i use placefriezes cheat to use foundation as a stage since i have a mod(that DJ system stuff...) well thats about it... its just that the pool isnt quite quirky sometimes so ALWAYS use the flatten before doing stuffs...
Back to top