Replies: 15 (Who?), Viewed: 5950 times.
Test Subject
Original Poster
#1 Old 31st Dec 2012 at 3:17 PM
Default world objects missing
so im trying to edit some of the pre made worlds.
sunlit tides and monte vista. but the objects that came with the worlds do not show up in caw. the bridges are missing and all the trees have been replaced by oak trees.
the trees from sunlit tides however are in the the tree list in caw but they still get replaced by oak trees.
the bridges and plants from monte vista do not show up in caw only in ts3.
i have update 1.42 and caw is updated to the latest version.

why is this and how can i fix this ? i really want to play these 2 worlds but their layout is not how i want it.
Advertisement
-.-- -.-- --..
retired moderator
#2 Old 31st Dec 2012 at 5:55 PM
Are the items just missing in the world itself, or missing from the metadata list?

We know that there are some objects with Store worlds that are contained inside the world file themselves, so are not useable as custom content in other worlds (or modifications of those worlds) unless you clone the items. I don't have these worlds myself, so I can't check this for Sunlit Tides and Monte Vista, though.
Test Subject
Original Poster
#3 Old 31st Dec 2012 at 6:24 PM
i cant find the bridges or plants from monte vista anywhere in caw but the plants show up in game under build mode and edit town.
the trees and objects from sunlit tides are in caw in the lists. but for some reason when i open sunlit tides in caw all the trees have been swapped for the Oak trees.

im still learning how to use caw. tho i have edited pre made worlds before without any problems and made my own without any bugs or errors. so this is really confusing me.
-.-- -.-- --..
retired moderator
#4 Old 31st Dec 2012 at 6:36 PM
Check that you have Monte Vista and Sunlit Tides installed correctly. If the DCCache files are not intact, the metadata items can show up as a string of numbers instead of the correct text.

I hope that someone who has these worlds can confirm whether they work correctly for them in CAW or not!
Test Subject
Original Poster
#5 Old 31st Dec 2012 at 7:30 PM
well as i have update the game to 1.42 i had the little issue when installing them and had to move the file from DCCache in to non packages - worlds but they work fine in game everything shows up and so on.

i will keep looking on other forums and post here again if i manage to get them to work.
-.-- -.-- --..
retired moderator
#6 Old 2nd Jan 2013 at 6:51 PM
So you mean that the worlds you edited in CAW show up just fine in-game, even though the objects didn't display in CAW?
Test Subject
Original Poster
#7 Old 17th Jan 2013 at 3:45 PM
sorry forgot my password to this site again. ._.

they don't show up properly in game after being edited, but i thought as i had to install them by changing the .package file to .world to be able to use them in game that it might have something to do with it.

anyways i re installed everything last night and CAW today . but the objects still don't show up =S

i have seen other edit monte vista without problems with objects and plants dissappearing and according to them they have'nt updated anything just installed the worlds.
Forum Resident
#8 Old 17th Jan 2013 at 5:19 PM
The only thing that did not show up in caw for me was the Distant Terrain from Monte Vista. I cloned that, and it is available up in the Caw Resources section here at MTS. Everything else showed in the metadata.
Test Subject
Original Poster
#9 Old 17th Jan 2013 at 5:27 PM
why isnt it showing up for me =(
everything is up to date but its just not there. i dont care to much about the distant terrain at this point but more about the trees and plants.. monte vista just dosent look right with oak trees.
Forum Resident
#10 Old 17th Jan 2013 at 7:26 PM
I would try uninstalling, and reinstalling Monte Vista if you haven't already tried that. Make sure you redo the caw files with a fresh one.
Test Subject
Original Poster
#11 Old 17th Jan 2013 at 8:06 PM
redo the CAW files ?
sorry im not 100% sure on what you mean by that.
Test Subject
Original Poster
#12 Old 17th Jan 2013 at 9:20 PM
so i Uninstalled and installed all my extra EA worlds ( sunlit tides, hidden springs,monte vista,lucky palms) and re installed CAW
i opened up sunlit tides in caw and it gives me this.

did a quick search for palm and some of them show up but not the ones used in this world.
and as you can see all the trees are replaced by oak and chestnut.

im getting really annoyed with this as it has been an issue for me for months now. =(
Test Subject
Original Poster
#13 Old 18th Jan 2013 at 1:17 AM
Got it working. had to open the world file and turn it in to packages in s3pe.
Test Subject
#14 Old 14th Jun 2020 at 8:28 PM
Quote:
Originally Posted by Neaschletenram
Got it working. had to open the world file and turn it in to packages in s3pe.


I'm having this exact same issue!! What do you mean you opened the world file and turned it into packages? Please help!
Test Subject
#15 Old 29th Aug 2020 at 3:12 AM
Quote:
Originally Posted by Neaschletenram
Got it working. had to open the world file and turn it in to packages in s3pe.


I agree. What does this mean, exactly? It's not phrased well. Currently, I'm trying to edit Lucky Palms. I got the CAW files from Cawster, but I'm having ugly oak tree problems as well as missing and non-recolored rabbitholes. Yes, I do have LP installed.
In the Arena
retired moderator
#16 Old 29th Aug 2020 at 7:16 AM
This is my work flow, when I do the Store world routing fixes:
First, run the files through the recompressorizer if haven't done so.

In Sims 3 user folder in Documents "\Documents\Electronic Arts\The Sims 3\DCBackup"
  1. start with a clean user folder, or at least a clean, empty DCBackup folder
  2. install world per usual via Launcher
  3. in DCBackup folder, create a new folder
  4. name it the world you just installed
  5. select all the .package files in DCBackup folder except for the ccmerged.package
  6. drag+drop (or cut+paste) the selected .package files into the newly created and renamed folder

In Sims 3 CAW folder in Program Files
  1. create the CAW CC framework as per instructions Create A World - Tutorial: Setting up Your Caw Framework for CC (with pictures!)
  2. drag+drop (or cut+paste) the world folder from DCBackup you just created above to Program Files (x86)\Electronic Arts\The Sims 3 Create a World Tool\Packages

Follow instructions in the Edit pre-made world guide to the get the .world file into CAW.

I never had any missing world content from the Store worlds when I do it this way. If you don't have enough disk space to place the world files wholesale, you'd need another tool to identify which is the .package file you need to place in the CAW CC framework subfolders. or remove the biggest .package file which is actually the .world file in "\Documents\Electronic Arts\The Sims 3\InstalledWorlds"
I separate into subfolders, so it is easier to pull any world out of the folders if I don't want all the files in there and clogging up CAW and lengthening loading/saving times.
Back to top