Replies: 91 (Who?), Viewed: 135045 times.
Page 3 of 4
Test Subject
#51 Old 25th Nov 2007 at 9:55 PM Last edited by strangerous : 25th Nov 2007 at 11:30 PM.
Great tutorial, thanks a ton, HP!

A question (which should be fairly obvious, but I want to make sure): if I have a recolor that's the same colour for elders as it is for the other ages, should I give the xxx_grey property set the same hairtone as I give the other property sets?

Edit: I just came to a file with several different colours in the texture images (black, gray, blonde and either dark blonde or light brown). The package name ends in "_brown", but the different texture colours confuse me. Is there any way to tell which is the right one through SimPE, or should I leave that file be for now and check which colour it really is in CAS! later on?
Test Subject
DELETED POST
21st Dec 2007 at 7:46 PM
This message has been deleted by reab.
Test Subject
#52 Old 8th Jan 2008 at 6:25 PM
Thank you!!! I tried using Theo's bin tool but for some reason it did ABSOLUTELY NOTHING to categorize my hair. I had one nice package, but it was still all under the "custom" tab in BodyShop. I tried for several hours using various problem isolation methods, all to no avail. I'm sure it works for some people, but apparently not for me. Using your tutorial, though, I've corrected the hairtones manually in SimPE, then used the Color Binning Plugin to create one package that cements them together and eliminates any separate mesh files.

ONE QUESTION: This is picky, but I would also like to correct the feature where you can have one hairstyle selected in Bodyshop, then click another color tab and the same hair will be selected, in the new color. The Maxis hairs all do this, so I'm sure there's a property/resourceid/family/something i don't know... to do this. Any ideas?

Thanks again for the clear instructions!
Test Subject
#53 Old 8th Jan 2008 at 7:08 PM
I just answered my own question (above) by the tinkering method.

By making all the "family (dtString)" values identical, you can click between color tabs to view the same style in multiple colors. The way I did it was to just use the existing family string from the first haircolor file I opened, and copy it to notepad to keep it handy. Then, beginning with the second haircolor file opened (since they are already all the same in the first file), I replaced the family string in ALL the EXACT same places where the hairtone string needed to be replaced. That means on the initial Hair Tone XML tab, and each of the ages under the Property Set (GZPS).

Also additional tips I've discovered to enhance this process:
1. As I go through the Property Sets, if I recognize the toddler/child mesh as a copy of a default Maxis style (you can usually tell just by looking at the name), you can delete them to eliminate duplicate hairstyles on the toddler tab.

2. For styles that do not have a separate Gray color file, you can choose which other color to use (usually blond) by deleting the _grey file from the resource list as you go, leaving it in the file for the color you'd like to replace the grey, editing it's hairtone string to 00000005-0000-0000-0000-000000000000 as indicated in the tutorial. Of course, if you have a special Gray color file, you'd just use that and eliminate the _grey Resource from each of the other color files. This differs from the steps in the tutorial here by not causing you to have all four colors available as choices for old age. If you'd like your grandma to have a pink hair option, though, you can of course do that, too.

I hope this helps some people as I have been researching all over the place to pull this together into a process I (and hopefully you!) can successfully use.
Test Subject
#54 Old 8th Jan 2008 at 8:30 PM
Ok One more update as I have finalized my own process and I hope that it will be of assistance to someone else who is pulling their own hair out over their poor Sim's hair.

If you are fine leaving each hair color in a separate .package file, you can use this tutorial + the method I described above of editing the family strings to associate the colors togther. Include all the colors and the mesh file in your downloads folder and you're good to go.

If you want them all in ONE package, you can use Theo's color bin plugin to create the initial package of all the colors and SKIP the process of editing the family strings as it will be done automatically. Unfortunately, the mesh doesn't seem to get packaged with the colors for me, but YEMV. I've used SimPE to manually add the mesh to the final package (right click in the right pane and choose "Add," browse to the mesh, click OK, and resave) so everything is in one place. Using his tool, remember that you can only have one gray color, so if you have other colors specified as grays, you'll be at crunch time to pick one when you create the final package.

I feel that my own method will be to create a "basic" package with a standard black/brown/blond/red/gray/favorite custom, and leave any other mid-tone recolors I reallllly love as their own entities, delete the rest.

Hope this helps.
Lab Assistant
#55 Old 8th Jan 2008 at 8:39 PM
ambrella, it's great you figured out family linking hair. The only thing to consider is only to family link one of each colour in each bin.

Also, good idea to use the family number of the first colour and use for the rest, as Bodyshop assigns unique numbers, so they won't clash with anybody elses.

Thanks Phaenoh for this information, which I got from here

Sorry, no more requests for the preg teens.
Test Subject
#56 Old 15th Mar 2008 at 3:10 AM
I see it's been a bit since this thread had questions, so I hope someone can help me too... I'm brand new to recoloring Maxis hairs, and SimPe. I decided to recolor a hat in 3 colors, in all the 4 basic hair colors.

The hat is to match a suit, and the suit only comes for YA and adults, so that's all I need the hat recolored for too.

So I did this tut with the new Free Time version of SimPe, and I did exactly as told. Only I also deleted the uneeded ages, (toddler, child, teen, and elder), and changed the rest.

Yet when I go into bodyshop, they are all still under the *, even though when I look at them in SimPe, they have the correct string #.

Did I mess up by deleting the elder? Or what?.... Please help a nooB. lol
Screenshots
Instructor
#57 Old 16th Mar 2008 at 2:02 AM
The two main things that must be changed are:

Hairtone XML - the proxy (dtString) value

Then under Property Set, for each age you must go in and apply that very same value to the hairtone (dtString) line, EXCEPT for elder which must have value applied of 00000005-0000-0000-0000-000000000000.

If you have done that just right, and still have them under *, maybe there is some issue with deleting elder, since I have yet to ever have any luck getting elder to go away, and end up using the method of hiding the elder version if it is unwanted or is showing up a total of 4-5 times.
Test Subject
#58 Old 16th Mar 2008 at 6:21 AM
Well, I deleted all the originals I'd made, and redid them. This time, I didn't delete the elder state... I'm recoloring a base game hat

So I now have under property set, 6 files... 2 YA, 2 adult, and 2 elder (1 hat, 1 hair?)

I did this tutorial to the T, commited all changes, and saved as...

Yet nothing shows in BS correct.

So I have tried in everyway I can I know of, and am at a total loss.... I'm so frustrated, I could cry.. Childish, perhaps, but real.

Is there some kind soul willing to one on one with me? I want to know what I'm doing wrong, so I can do this on my own, and enjoy it! As of now, it seems like the programs aren't even registering my changes..

I know the codes for Hairtone XML - the proxy (dtString) value, and Property Set hairtone (dtString) are correct.. But either I have bad luck with SimPe, (at which I am a nooB), or I'm missing something.

And all the stages I thought I'd deleted... they are still there in BS.

I have tried to make these recolors over 15 times in the last two days, and am still at square one.

I have some shots of the newest attempt on this, so hopefully someone can see where (if) I went wrong..

Thanks again...


PS: Also, I have tried the ColorBinning tool, yet it doesn't give me a chance to overwrite a file.. When I click save, it all dissapears from the screen, and makes no changes to the file.. All this crap has made me gain a true respect for the creators who dabble in hair! lol
Screenshots
Instructor
#59 Old 16th Mar 2008 at 7:47 AM
From your explaination and your set of screenshots, I'm not seeing a single obvious or even not so obvious thing that you've not done correctly.

So, to double check if it was something to do with hats with hairs, I did one up quickly myself, then binned it. It went just where it should have, into the black hairs bin.

So...I'm so sorry to say I'm stumped. If you'd like to attach your package file, I'd be happy to have a look at it, though. Maybe its something so simple that isn't being noticed.

Just don't cry!
Test Subject
#60 Old 16th Mar 2008 at 8:37 AM
LOL, already past the cry stage!

I also tried a non hat hair, and still no luck....

I've attatched 2 zips here... Both black hair, one is the hat in green, and that's the file I've already ran through SimPe, to no avail. The other is the hat in pink, and I took that exactly as BS spits it out...

On one hand, I hope you can get it to work fine, but on the other, that'll stink for me! lol

But thank you so much, I really do appreciate it...
Download - please read all instructions before downloading any files!
File Type: rar ZootPinkBlackNOpe.rar (1.84 MB, 7 downloads) - View custom content
File Type: rar ZootGreenBlackAFTERpe.rar (2.06 MB, 11 downloads) - View custom content
Instructor
#61 Old 16th Mar 2008 at 10:07 AM
I could just be suffering from tired eyes, but those look to be the files from your Projects folder instead of just the package file from your Saved Sims folder.

One other thing to check on, is your version of SimPE up to date. Not so likely that would cause this, but its always a good idea to update it, at least when you have a recently new expansion pack for your game that might need it.
Instructor
#62 Old 16th Mar 2008 at 10:15 AM
Yeah, hey...is there some chance that when you tried to bin these hat/hairs, that instead of opening the file from SimPE out of your Saved Sims folder, that you instead opened and edited the file thats in your Projects folder?
Test Subject
#63 Old 16th Mar 2008 at 10:20 AM Last edited by tamlfra : 16th Mar 2008 at 10:31 AM. Reason: tried again
Oh no, can it be as simple as that??

All I saw was get the file from where you saved it... I thought that was the spot! Told ya I'm a nooB!!!! I'll retry them from the other location... I would have never thought the game saved hair under savedsims....


OK, you rock!! I tested it, and that was the issue.... So bad, lol! THANK YOU!!!!
Instructor
#64 Old 16th Mar 2008 at 10:28 AM
Yep! Stuff that you have finished and imported to game from BodyShop get sent into the Saved Sims folder. Also if you've downloaded stuff you want to bin, or have made meshes, those are in your Downloads folder.

Your saved sims folder files will start out with a goofy long gibberish number-letter combo thing attached to the front of the name..you can safely rename it to get rid of that junk to any name you like.
Test Subject
#65 Old 28th Apr 2008 at 7:41 PM
I'm so happy that someone's realised how irritating it is to have all your nice custom hair in the custom bin.
Test Subject
#66 Old 26th May 2008 at 8:05 PM
thanx very much,it's so helpful,when i creat a new hair,i would like to classify to the correct group!

I am not 100% fluent, but at least I am improving.
Lab Assistant
#67 Old 20th Jul 2008 at 12:01 PM
I have 1 question
I did all the steps in simpe, but when i got to step 10
"10. Move your modified file into your SavedSims or Downloads folder and test to make sure it's working correctly in Body Shop and/or the game."
I had no idea where to find the modified file
where do you find it?
Field Researcher
#68 Old 4th Aug 2008 at 4:27 PM
do I need to change the elderly property set to 00000005-0000-0000-0000-000000000000?

because when I do change for all hairshades, it shows the grey hairrecolor for all colors? I have in bs in the grey section the hairstyle 10 times in grey color. How can I get rid of this?

When you are content to be simply yourself and don't compare or compete, everybody will respect you.

I have a social disease. I have to go out every night.


Garden of Shadows- my DL's at GoS
LaPink.net - Make-up & Stuff Downloads
Forum Resident
#69 Old 27th Aug 2008 at 6:31 PM
Wow! Thank you so much for this wonderful tutorial! I was doing the Bon Voyage hair with the leaves in it, Because I'd done some recolors of it, And it worked perfectly! Thank you so much!

Nacho average teen.
Other Stuff By Me.
Field Researcher
#70 Old 23rd Oct 2008 at 3:41 PM
I can no longer use Theo's color binning tool since it hasn't been updated and so SimPE no longer supports it. I had color binned some files a long time ago using Theo's tool. They got deleted and now I'm really irritated.

So I have a request: Can someone please post a tutorial (step by step) on color binning eyebrows, beards, and stubble? Please?
Test Subject
#71 Old 6th Jan 2009 at 11:54 AM
Thanks so much for this! I finally decided to try my hand at recoloring Maxis hairs, just because they look too fake (and because I came across an awesome tutorial for hand painting hair). The hair isn't that great, but not bad for a first attempt! I followed this tutorial and got it right the first time, though I did have major complications with SimPe. I couldn't find the area where step B comes into play. So I uninstalled....twice, deleted folders, restarted my computer, and then I noticed the reset layout button...which set it back to default, and voila! Whew! What a headache...heh.
One horse disagreer of the Apocalypse
#72 Old 6th Jan 2009 at 1:50 PM
Sorry for replying so late, but people with AyameS' complaint are still able to go to Theo's site and obtain the plugins and support there. The SimPE developer(s?) stopped distributing the plugins with SimPE because they were unable to support them. This does not mean Theo cannot.

"You can do refraction by raymarching through the depth buffer" (c. Reddeyfish 2017)
Destroyer of Worlds
staff: administrator
#73 Old 7th Mar 2009 at 12:44 AM
I am going insane! I recolored one of the hairstyles I found on XM because all of the normal colors had little tiaras and stuff but the custom colors (silver, green, blue) all were without the extra tiara. So I recolored the silver to have 4 "normal" colors. They all appeared in the custom bin. I HATE having regular colored in the custom folder and have been trying forever to figure it out.

I tried the Theo's Color Binning...nothing. I tried doing this manually with SimPE using my recolored package files in the Projects folder and then moving those files into my downloads...nothing. I have no idea what I am doing wrong. No matter what I do, it will not put these recolors in their proper bins. I'm about to give up and just deal with having to search for the colors in customs because I am so frustrated.

Is there anyone who can help me?!?!?
Test Subject
#74 Old 28th Jun 2009 at 12:05 AM
Default I apologize in advance if this question has been answered.
This is a very informative tutorial, but how do you do this on a Macintosh computer? You just show how to do it on a PC. When I downloaded SimPE, my computer was unable to compress it. No system opened. Also, when I attempted to download that SimPE file, there was no SimPE folder. Macintoshes don't have that "C://Documents/Package..." thing that PCs have. I'd like to know how to bin because, even though most creators bin their creations on their own, this one creator, whose hair styles, I adore does not, and I'd like to have her hairs binned properly instead of simply staying in the "Custom Content" bin. Is there a special download SimPE for the Macintosh?
Thanks in advance. I apologize if this doesn't meet the rules.
Lab Assistant
DELETED POST
17th Sep 2009 at 5:58 AM
This message has been deleted by HaphazardSim.
Field Researcher
#75 Old 27th Feb 2010 at 3:22 AM
Okay, I'm having a problem. When I first tried this it worked perfectly. Now that I'm trying the second time, when I open the file in SimPe, I get the resource tree, but when I click on one of them, nothing shows up! Did I do something wrong?
Page 3 of 4
Back to top