Replies: 48 (Who?), Viewed: 23640 times.
Page 1 of 2
Original Poster
#1 Old 16th Aug 2009 at 5:44 PM
Default Question re: meshing Sims 3 objects
Well...a couple of questions. I've followed the great new tut by Deluxe Designs. I am up to Step 4: Milkshape Bit. Questions:

1. There are 4 mcfg files for the object I have cloned and want to modify (Elsinore Dining Chair). Do I need to make a single chair and then use this chair to overwrite each of these 4 mcfg files? Why are there 4 such files for a single object?

2. When I import an mcfg file into Milkshape it appears but there is a blue structure around the chair. This blue structure does not have a group name and when I delete the actual chair the blue structure stays there. What is this thing and how do I get it to go away without closing Milkshape and reopening it?

3. When I import an mcfg file into Milkshape and try to see its texture map it doesn't seem to have one. Is this right? I know how to use Milkshape to texture map items (I used it for this when modding Sims 2 objects) but I don 't know if I can use the same method for Sims 3 objects.

Any help is appreciated and if I'm asking questions answered elsewhere a push toward where the information can be found would also be appreciated.

Wiki Wizard
#2 Old 16th Aug 2009 at 6:19 PM
Ok well i wrote the tutorial so i can answer your questions:
1. you need 4 because 1 of them controls the mesh, and the other 3 control the shadows, and unless you want odd shadows you should do them all.

2. the random blue lines are nothing to worry about, they are always there but they do not do anything, you cannot delete them at all, they are not part of the mesh, just ignore them

3. it should have a texture, but if the original doesn't don't worry about it, just make sure that the mesh you import into it does have a texture map.

Hope that helps you

It's ok, we all laugh-snort occasionally!
Check out some of my other stuff here.
One horse disagreer of the Apocalypse
#3 Old 16th Aug 2009 at 8:38 PM
Talking of tutorials I have been waiting for you to come in and get that preview of the new cloner so you can update your tutorial.

"You can do refraction by raymarching through the depth buffer" (c. Reddeyfish 2017)
Original Poster
#4 Old 16th Aug 2009 at 8:49 PM
Thanks so much.

Original Poster
#5 Old 16th Aug 2009 at 9:55 PM
More questions. Here is what I'm doing first and hopefully I'm doing this right. I have a chair I've already made and texture mapped. It is in obj format.

I import that chair into Milkshape (MS) and then import the mcfg in also. I reposition my chair and tinker a little with the size so that it fills the footprint of the EA Sims 3 chair. Then I delete the mcfg group titled group00 and rename my chair group group00. Then I export it as an mcfg and overwrite the original EA one so that mine now has the right name.

I first did this with the MLOD that has two groups group00 and group01. The chair itself was group00 and a flat square lying under the chair feet was group01. I left group01 alone and renamed my chair. Then I exported.

To begin with, when I brought the mcfg in I got a message telling me that importing this with another model there could make my model unreliable. I've never seen this message before...should I worry about it?

Second, while saving my new mcfg I got an error message telling me that I had bones which were unassigned or something to that effect. I saved anyway and it told me it had split vertices.

Third, when I reimported my newly overwritten mcfg it came in without its texture even though I had assigned a texture to it and mapped it to the texture.

Fourth, my new mcfg had two groups but the names were reversed...that is, the flat square which I had saved as group01 was now named group00 and the chair, which I had saved as group00 was now named group01.

Thinking I had mistakenly saved them incorrectly I changed the names around so that the chair was named group00 and the square was group01 and exported again. But when I checked to see if the thing was named correctly the names had switched back so that the square was again being called group00 and the chair was group01.

I'm clearly doing something or several things incorrectly here but I can't figure out what that might be.

Again, any help is appreciated.

#6 Old 16th Aug 2009 at 10:26 PM
The "blue lines" are the joints. As shipped, MilkShape scales them too large for Sims meshing. Set the Joint Size value in preferences to about 0.012. You can also make them invisible in the joints panel by unchecking "show skeleton".

The material (texture) used is not set with MilkShape, although you can display your mesh with one. Textures must be changed using S3PE or Postal and a graphic editor with DDS capabilities.

Importing a model overtop of another can be useful to determine sizing, as you did, but the warning is there because it can also make a mess of your model, such as adding unwanted bones.

The group name is significant only to the .obj format exporter, and that is where the name switches you experienced occurred. What is significant for the game is the group order. If the groundshadow mesh (flat square) is second in the original, it must be second in your new mesh. Changing the group order is easy, you just select one and click on up or down in the groups panel to change it.

The joint assignments should be remade, typically there is only one joint in the simple models (cars and beds have a lot more). On the meshes that have many joint you can study the assignment pattern by turning the option "draw vertices with bone colors" on in the joints panel.

<* Wes *>

If you like to say what you think, be sure you know which to do first.
Original Poster
#7 Old 17th Aug 2009 at 12:01 AM
Many thanks for the explanation. When you say joint assignments need to be remade what does this entail? I am used to meshing for Sims 2 and I never worried about joints at all when making items for that.

What are bones? Do I need to worry that when I save it is telling me I have unassigned ones?

If I don't import something to size and position with I think I'm going to have a tough time making my object sit right and be the right dimensions for the Sims. Is there any way of getting around unwanted bone addition or any way of removing unwanted bones if they get added?

If I am understanding you correctly, the export process changed the names of my groups because I had the groups out of fix this all I need to do is reorder them prior to export...right?

Again thanks for any help...I apologize if my questions are wandering a little off the topic of using the mesh tools and into the topic of actual meshing itself. I thought I knew how to mesh but it seems Sims 3 requires a little more knowledge than meshing for Sims 2 did.

#8 Old 17th Aug 2009 at 2:08 AM
All the Sims 2 objects had by default a root joint. The Sims 3 objects specifically map to a root joint (but not the groundshadow meshes). Different game engine, different details.

No, you did fine by scaling to match something known. The warning is to let you know you are importing a mesh on top of another... for instance, it is possible to hide a group and thus look appear to be importing into an empty project when there is already mesh data there. It's OK, as long as you know there is a difference and adjust your work to that.

You can delete bones, but the order is significant, the assignments disappear, and you need to know which joints were in which mesh if you are planning on combining meshes. If you are extracting bits and pices, and exporting in something like .obj format, this will not be an issue.

The export process does not even use the group names, beczause the game package has no names, there is just a first group, a second one, etc. The importer names the groups for humans starting with "group00" and working it's way up. Quite imaginative, huh?

The .obj importer remembers the names from when the object was exported. If there is a group with the same name, it will add the mesh data to it, if not, it creates a new group with the group name that was in the original file. Not always what you want, but that is how it was made.

Technically, a bone is the space between two joints, but the two terms are generally used interchangeably. Joints are used in the game engine to place and animate objects (and sims), assignment is the process of making specific vertices associate with specific joints. Here is some more about it on the wiki. (Thanks to porky for moving it there).

<* Wes *>

If you like to say what you think, be sure you know which to do first.
Original Poster
#9 Old 17th Aug 2009 at 2:19 AM
Thanks again I'm off to the Wiki to learn more about bones and joints.

Original Poster
#10 Old 17th Aug 2009 at 2:47 AM
Ok...I'm back. I read the section of the Wiki you directed me to and I am wondering if I need to worry about joints and bones if I am making an object like a chair which really has no animations.

The chair I am currently working with has no assigned joints because I made it for Sims 2 and there was no need for them. Can I use this chair as-is or do I need to create joints for it? If I do create joints for an inanimate object does it matter where they go? Is there some way of seeing where the joints are on EA Sim 3 meshes so I can use them as an example of what will work?

Second sounds like you're saying that unreliable warning is sort of a reminder to clean up after you work rather than a message telling you you're going to screw something up majorly if you continue forward with two models in MS at the same time. Is that right? So basically I can continue to use the Sims 3 models as a size/position template for my meshes as long as I delete them when I'm done with that step?

Thank you for your patience and help.

#11 Old 17th Aug 2009 at 3:13 AM
How it was in TS2 and how it is in TS3 are only loosely related. Details are different bacuse the game engine is entirely different in details, the resemblance is because most basic parts (meshes, texture mapping, UV mapping) are all pretty much the same in concept. The tools insulate you from much of the details, but there are nonetheless differences... TS2 made a default root joint for a mesh, TS3 all seem to have a root defined in the package, and many are not named the same.

I can only tell you that when I import almost all TS3 objects, the have at least a single joint defined, and that the main parts of the mesh are assigned to it. Chairs, stereo, almost everything. Placement, including rotation, is a form of animation, and I suspect that is why the joints are there. Assignment of everything to a single joint is easy, it requires you select the joint, select the group, and then click on assign in the joints panel. Done.

And the warning is yes, a warning that something could go wrong. I originally wrote it for myself, as I would import model A, then go to import model B and end up with both models in MilkShape, the joints jumbled together, and have to do a new and then import model B over again. I left it there because people were doing what you were doing, and not removing the other mesh, and then posting about being unable to link the textures properly.

<* Wes *>

If you like to say what you think, be sure you know which to do first.
Original Poster
#12 Old 17th Aug 2009 at 4:19 AM
Thanks once again. Another question if you can take it I have now moved on to Step 5: Preparing for Import in the tutorial. I figured out how to get the separate pieces decompiled and each is in its own folder all decompiled.

I changed the mcfg file and overwrote the EA one with my new one for each (off topic somewhat...why are some of the mcfg's so big when they show up in MS? They're gigantic compared to the actual model) and now I am ready to recompile.

I open your S3Obj tool, click recompile, browse to my folder and pick the mcfg file. I get a message from the S3Obj tool but nothing in my folder appears to change. There are still all those separate files sitting in it.

The next step of the tutorial says to use S3PE to import each MODL and MLOD file back into the package but I'm not sure my MODL and MLOD files are actually recompiled. Are they? How do I know if they are or aren't?

Am I correct in assuming that the Object Tool has recompiled all those files, including my altered mcfg file, but left each of the individuals sitting there in a list under the recompiled MODL or MLOD file as well? Or am I doing something wrong?

As far as joints sounds like you're saying each object should have at least one but that for inanimate stuff it doesn't really matter too much where it that correct? When I make the joint should it have the same name as the joint in the S3 original one did?

If I import something with no joints into MS with an EA object that has a joint, resize/reposition my object, delete the EA object, and then make a joint for my object will that allow me to use the EA object without getting joints jumbled up?

#13 Old 17th Aug 2009 at 4:45 AM
There actually is a new version of the tool with buttons and such that says no errors when you recompile. But let's not confuse you at this stage of learning. Generally, if there is an error the recompiler will tell you. But you can tell from teh file timestamp if you want to be SURE you got compiled.

The recompiler actually never modifies the original files, except the .mcfg itself, it renames them by adding ".bak00" (and incrementing the digits) and making a new file. So when you see something like S3_myprojectname_MODL.model and S3_myprojectname_MODL.model.bak00, the .bak00 was the original, and the recompiled file is now named with just .model for the extension.

(off topic somewhat...why are some of the mcfg's so big when they show up in MS? They're gigantic compared to the actual model)

That confuses me. Perhaps it is the automatic scaling MilkShape does when you load a mesh? MilkShape sets the zoom to approximately the equivalent of the "frame all" when you first load a mesh.

Or else you need to post some picture(s) of what you are asking. I certainly have never had the time to import and look at more than 10% to 20% of the meshes in the game myself, so perhaps I am missing something in some of them here?

<* Wes *>

If you like to say what you think, be sure you know which to do first.
Original Poster
#14 Old 18th Aug 2009 at 1:26 AM
That's the version I'm using and it worked! I did it!

Thanks so much for your help. All I've done at this point was resize an EA object and plop it into the game (that tiny little fern on a stand just needed to be larger IMO) and I have a long way to go to learn the texturing part. But for now I feel great.

When I exported my object from MS it still gave me that bones not assigned thing which I ignored and my object is appearing in the game and behaving properly. Also, when I imported the piece with the little square, the little square was named group00 so I left it that way. I can't notice any problem with the texture (the pot and stand texture just as they should).

I think the actual import/export process involved in Sims 3 is easier than in Sims 2...there aren't as many steps. The texturing may be a different story but I'm leaving that for tomorrow.

Thanks again for your patient help.

Test Subject
#15 Old 18th Aug 2009 at 8:22 PM
OK! I have a question.. I just do not seem to get in that darn table into milkshape. I've done everything that the tutorial said (I think to 99%) And it still can't import the chair. Im so frustratet about this! Can you maybe post some pictures? I'm Swedish and sometime alot of english text can make my brain go mush. I'm going to read this tutorial very slow, careful again becuse this is driving me crazy.

ps. God, I'd feel so stupid if I've missed something obvious!

love Siv
Test Subject
#16 Old 19th Aug 2009 at 1:34 PM
I got it fixed anyways.

love Siv
#17 Old 21st Sep 2009 at 11:18 PM Last edited by Cocomama : 22nd Sep 2009 at 12:57 AM.
I thought that removing the hood from the expansive crib would be an easy project to start object meshing for TS3. And it worked, sort off............

I used the tutorial "Meshing Objects in TS3" from Deluxe Designs and also "Clone A Painting And Change The Texture (now wikified)" from xanathon.
Reading the tools threads and the modding discussions, and trying to do several tutorials, already learned me a lot, but I was not able to find answers about a few things. I hope somebody can help me or point me to information?

--Changed the MLOD-0 mesh first, but what about the other MODL and MLOD's, what are they exactly? Shadows or meshes with reduced polycount for zoom-out views?
In my first object I used the MLOD-0 mesh to make the other MLOD's, but in a second project the originals were so different scaled and reduced in polycount, that I doubt that is a good thing to do.

I guess the MODL is for the changing light shadows in game, is it important that that mesh is exactly the same as the MLOD-0? Or is roughly the same size good enough?

And about the other MLOD's, if they are for the zoomed-out views, why are they different in size. I mean, I would understand the reduced polycount but why are they sized differently too? And if they are only shadows..........It is very time-consuming to match the size in MilkShape with the original.
And what if the new mesh shape is totally different than the cloned mesh that is used as the base, how am I to find out how big to make them??

Is there some easy way to do the other meshes, because making all the same changes in the mesh 4 times is not uhhh ......logical

I've made a picture in Milkshape to show all 4 meshes at ones, so you can see the different sized meshes, 2 of each size.

I also would really appriciate any help in finding directions how to change the DDStextures in Gimp, as my PSP 8 can't edit them.

ObjectTool GUI V0.20
MilkShape 1.8.5
MilkShape Object plugins V0.20 S3PE 20 sept S3OC Cloner 19 sept
#18 Old 22nd Sep 2009 at 1:19 AM
The way you would go about this is starting just like you did, building a working "00000000" MLOD file. After you have that UV mapped, tested and are happy you use the mesh from it to make your "00000001" mesh. That mesh is a same-sized but reduced poly count version.

At the price of remaking the bone assignments, there is a polygon reducing plugin for MilkShape based on DirectX.

That leaves the two shadow meshes. One is for each of the visible lods, "00010000" matches up with "00000000" and "00010001" matches up with "00000001". What we know comes from observing how these are used in the game, we don't have any precise documentation on this. Generally, these are displaced from the main meshes, and often are then scaled differently, making the size difference. The shadow meshes may also be welded at all seams, to reduce vertex count, as these meshes are never directly rendered, they are used by the game to create the sun shadow.

You would usually make them by copying your visible lods, select all and moving the mesh to a similar displacement as the original, and using the Scale function to flatten and enlarge it like the original shadow mesh.

So now, you have made only one mesh and fussed over it, and then from that have made your other three model parts. You are right in your thought that trying to repeat the same edit three more times is inefficient and error prone. I have little doubt that the artists that made the original objects followed a similar procedure, perhaps with the added ease with which polygon reduction can be done in Maya.

If you like to say what you think, be sure you know which to do first.
#19 Old 22nd Sep 2009 at 9:55 AM
Thank you Wes, for your quick answer and for the great tools you always make for us!!
So this means I will have to experiment a lot more, especially with those shadow meshes and the polygon reducing plugin.
I definitly will need to read more about bone assignments and welding seams, and learning GIMP for the textures.
Now I'm going to dive into the object tutorials for TheSims2 again and experiment.
#20 Old 22nd Sep 2009 at 6:13 PM
Well, if you get any great insights into the way that shadow meshes affect the shadows in the game, please tell us. There have to be some underlying principles to the placement and sizing of the shadow meshes that went into the design, alas there is no Prima guide to meshing the Sims. We are just kind of expected to figure it out on our own.

<* Wes *>

If you like to say what you think, be sure you know which to do first.
Field Researcher
20th Nov 2009 at 5:20 PM Last edited by melanise : 20th Nov 2009 at 5:47 PM.
This message has been deleted by melanise. Reason: Solved
Field Researcher
#21 Old 24th Nov 2009 at 6:24 PM
erm a quick question if at any time you get the " Bone assignments missing" dialog is that something to worry about ?? or..., because basically i've assigned the bones to the new mesh with the old mesh still there just in case it needs to be while you assign bones to a new mesh. I tried it without the old mesh being there and still got that dialog box pop up upon exporting via Weshows object exporter.

But anyway iw ent along with it because i check selassigned button and it showed my whole mesh was assigned.. so anyway i continued i recompiled through object tool just to make sure there was no errors and it was fine... so is this ok or am i in for trouble later ?
Field Researcher
#22 Old 24th Nov 2009 at 8:26 PM Last edited by melanise : 24th Nov 2009 at 9:08 PM.


Ok well i'll leave the bone asignments issue in a bag for now but i finally got the mesh into the game when i noticed the front of the desk was quite distorted and the legs...., the rest of the body was fine, but the thing is it never looked like this when i exported it. And now back in milkshape, i now see the reason why it was like that in game (look at picture) I reimported my .obj file i made and it was perfect untill... i tried to scale it down to match and replace this mess, only to find it distorted the front of that one aswell... and then the scale tool stops working it scales it distorts it and doesnt function... i have no clue at all what the problem is.. is scarey pleease please point me in the right direction ty x

EDIT: Now its even the slightest movement even if i move a simple vert it just goes horrible like the pic just looks the same all the time...
Lab Assistant
#23 Old 24th Nov 2009 at 10:07 PM
Try going to the Groups tab and make sure Autosmooth is unchecked...
Field Researcher
#24 Old 24th Nov 2009 at 10:56 PM Last edited by melanise : 25th Nov 2009 at 1:07 AM.
It was the pressed unweld and it fixed this issue... for some strange reason but i'm gonna have to remake the package anyway, it comes up in game but now it dont show just invisable with the 2 green squares where its meant to be ... but ty anyway x

Edit: after squabbling around i've found my solution
Original Poster
#25 Old 25th Nov 2009 at 1:29 AM
"erm a quick question if at any time you get the " Bone assignments missing" dialog is that something to worry about ??"

It is something you should worry about unless it is the shadow mesh that is causing it to appear. If you don't assign bones the object will work correctly but it will take on a strange and unappealing appearance at times when you move it from one place to another in the game. Assigning joints is so easy that it's worth taking the extra seconds to do it.

When you export the MLOD with shadow you will still get the message if the object has all its bones assigned but the shadow is still unassigned. WesHowe has posted that it is ok to leave the shadow mesh unassigned so if this is the issue raising the error message you can ignore it in this particular case. To the best of my knowledge that is the only time it is ok to ignore the error message.

Page 1 of 2
Back to top