Replies: 67 (Who?), Viewed: 38029 times.
Page 3 of 3
Lab Assistant
Original Poster
#51 Old 17th May 2010 at 7:31 PM
Quote:
Originally Posted by Raven Shadow
Thanks for the info CMX :0
It wasn't supposed to be recognised as a rotation matrix, I was hoping the format would be recognized as a translation matrix,
But if a 4x4 matrix can't be saved , yet, exactly as entered by the user, I'll have to play some more with the 2nd formulea I posted above.



So you can't use Triexporteres code for writing them?


Unfortunately, Triexporter merely imports the data from the grannyrig files, it does not write/export to them.

The only program in the community that could actually write grannyrig files was the Expotron plug-in for 3DS Max.

As far as I know, the source code for the Expotron plug-in is off limits, because they actually bought the $12,000 API and were therefore under its DRM NDA BS. However, if you do manage to find the source code for the Expotron plug-in, that'd be awesome.
Lab Assistant
#52 Old 18th May 2010 at 2:16 AM
That's odd, EVE's forum posts talk of using triexporter to import modify and export EVE models,
textures and bone data, all of which are in that game's .gr2 files.

But anywho, while writing this I have been rooting around Google.
and besides going a little cross-eyed I did find a few uninformative comments NWN's IGN Vault section
about someone called tazpn having made his/her own max importer/exporter, of which no work
be done on it since May of '09, but he did post the source code of an early version here
His comments imply that it loads .gr2 files, but say nothing about exporting to .gr2,
But comments made elswhere claim that he was doing file i/o using the granny2.dll
Lab Assistant
#53 Old 18th May 2010 at 2:05 PM Last edited by Raven Shadow : 25th May 2010 at 10:40 PM.
NO luck on expotron, but I did find out that in '06, '07 a guy named John Ratcliff posted source code
for a project of his that loaded a mesh, and a skeleton in .gr2 format and applied physics to it,
called The CreateDynamics Toolkit .
He accidently included the official source code needed to read/write .gr2 files in the download.
Unfortunately, he later removed the files from his public downloads.
All I've found so far, is a verion hosted at http://www.amillionpixels.us/sourcecode.htm
I doesn't appear to have the 2 files, but does appear to have what I believe you called, wrappers for for them
that may be of help.
It also has source code for dealing with the Matrices, which maybe usefull to you.
Lab Assistant
Original Poster
#54 Old 18th May 2010 at 3:45 PM Last edited by ChaosMageX : 25th May 2010 at 4:04 PM.
If you could find this source code, that'd be great, Raven Shadow.

Remember a fundamental rule of the internet: Once something is put on the internet, it is NEVER TRULY taken off of it.

However, I'm not sure where to go to find internet stuff that no longer exists where it used to. If internet archives fail, you could always try looking through p2p places.
Lab Assistant
#55 Old 21st May 2010 at 11:46 PM
Dude, read your PMs
Lab Assistant
#56 Old 6th Jun 2010 at 10:15 PM
It doesn't correctly save changes to the 2 LOD Type entries.
I've edited them, several times, to the same value, but when reloaded
thier is a different value saved each time.

Correction.
the editor isn't loading an LOD Type value, it's different each time you
load a file.
Lab Assistant
#57 Old 15th Jun 2010 at 6:21 AM
First off, amazing tool and thank you for making it.

Im trying to edit the position in which the sim routes to the sit_template coordinates.
I have moved the sit_template across the game's Z-axis (Blender's Y).
Currently the sim ends up at the desired coordinates of the sit_template, but routes to the original coordinates...
I tried editing the Z coordinates of the route_sitTemplate files by the same increment that I moved the sit_template, but no luck.
I'm guessing that I need to try the route_1, route_2, (etc..) files, but I'm lost as where to start with these because I still dont quite understand the meanings of the: R, U, A, P labels on the Y-axis of your editor.

Can anyone tell me what those labels mean and possibly if those route_# files are the ones I need to edit to fix my problem?

Thanks,
BH
Instructor
#58 Old 26th Jun 2010 at 4:30 AM Last edited by Nukael : 26th Jun 2010 at 5:26 AM.
I'm trying to open a RIG resource I exported with S3PE and I'm getting this error:



I have these files in the CAW directory (the one where caw.exe is located):
S3RIGMaker.exe
ChaosMageX.Granny2.dll
granny2.dll

EDIT: so I tried on my second PC which has only CAW installed and the basegame patched up to 1.9 (before the CAW breaking patch), and on that PC it works perfectly.
Yet on my first PC with Ambitions and the latest patch, it gives me this error.
Screenshots

This space intentionally left blank...
Lab Assistant
#59 Old 27th Jun 2010 at 5:40 PM
Just wondering if someone is willing to finnish this app, or is it dead?
One horse disagreer of the Apocalypse
#60 Old 27th Jun 2010 at 6:05 PM
You can't draw a conclusion yet. Maybe in the school holidays someone will have time.

"You can do refraction by raymarching through the depth buffer" (c. Reddeyfish 2017)
Test Subject
DELETED POST
29th Jul 2010 at 6:26 PM
This message has been deleted by Cosmas.
Test Subject
#61 Old 24th Aug 2010 at 3:14 AM Last edited by Cosmas : 24th Aug 2010 at 4:50 AM.
Fixed the error, those of us that use a true 64-bit OS needed a 64-bit version so we wouldn't throw an exception. After a minute of research I found this explanation of the error. Mine appears to work fine now, let me know if you have success as well. Chaos, remember to build for both OSes next time. Great program btw.

*EDIT: The TransformEditorDialog was also messed up apparently, this has been resolved.
Download - please read all instructions before downloading any files!
File Type: rar S3RigMakerX64.rar (59.0 KB, 44 downloads) - View custom content
Description: X64 Version of S3RigMaker
Lab Assistant
#62 Old 24th Sep 2010 at 3:58 AM
Cosmas, I don't suppose you could post a *fixed* 32bit version, could you?
or that you'd be willing to finnish the app, would you?
One horse disagreer of the Apocalypse
#63 Old 27th Sep 2010 at 7:51 PM
Well, we have a new RIG maker now, don't we? Raven Shadow, you gonna give everyone the link?

"You can do refraction by raymarching through the depth buffer" (c. Reddeyfish 2017)
Test Subject
#64 Old 29th Sep 2010 at 2:32 AM
The 32-bit version should be fine I think, but I'll take a look at it. I'm actually not much of a programmer at all, but I did learn a few things from the required 9 hours of comp-sci at my college.

What error are you getting specifically?
Forum Resident
#65 Old 10th Jun 2011 at 7:23 AM Last edited by omegastarr82 : 10th Jun 2011 at 7:35 PM.
Necromancy is bad I know. But in post four, he talks about changing the IK for the butt bone from the rig. How the hell do you do this? I've poked around the rig file but didn't see anything that would look like it would be the butt bone. I'd like to be able to raise the seating position on a chair I made.

NM, I figured it out. Since my chair wasn't on the ground I had to change the "sit template bone" not the butt bone.
Test Subject
#66 Old 4th Aug 2011 at 10:54 PM
Hello, I'm from "Understrech Imagination," does not know him, but I've been trying to take your tool "S3RIGMAKER" and because I do not work, try using that to my car Mercedez Benz AMG SLS, but when you put it in The Sims 3, operates as if it had the previous Rig file and review it, but the data are OK, but in the Sims 3 does not work, what you think is the problem?
Test Subject
#67 Old 7th Aug 2011 at 2:00 PM
Thanks for the cool rig maker. I'm using Vista 32 bit and I'm having some issues viewing a few of the _RIG files. While it works for most files some files like auRig might be getting corrupted when exporting from s3pe. I also can't open this file in any other programs like the granny viewer or the 3ds max importer. Is anyone else able to open auRig after exporting from s3pe_11-0402-0951?
Instructor
#68 Old 7th Aug 2011 at 3:37 PM
auRig (and all the other people Sim rigs, not the objects) has some extra bytes at the beginning, making the plugins not able to recognize it as a true Granny Rig. If you search on the this website, you'll find Sim rigs already edited so they can be recognized by Granny.

This space intentionally left blank...
Page 3 of 3
Back to top