Replies: 26 (Who?), Viewed: 26767 times.
Page 1 of 2
Test Subject
Original Poster
#1 Old 31st May 2010 at 3:47 PM
Default Exporting .obj from Google Sketchup and importing into Milkshape & TSRW
I'm trying to make my first CC, a stool. I am making it in Google Sketchup 7 Pro because I find it easier to use and I can scale one face. (Btw, it's a two-group two-material object.) The problem is that, when using the obj exporter plugin, it doesn't export the groups at all, and then the objects don't work correctly in TSR Workshop.

The model in Sketchup:

The export dialogue:

The Built-in exporter:

How they appear in Milkshape:
Plugin: http://i380.photobucket.com/albums/...elp-stool_4.png
Built-in: http://i380.photobucket.com/albums/...elp-stool_5.png
This is what happens in TSRW with both of them:
http://i380.photobucket.com/albums/...elp-stool_6.png
(The top one shows an error about the groups, and the bottom one shows the model when exported as 1 group.)

If someone could help me, it would be greatly appreciated, and you'd be credited as well.
(BTW, I would have posted this at TSR, but no-one seems to be helping me with a different problem there...the view count is a solid 0...)
Advertisement
Dancing Flamingo
staff: administrator
#2 Old 31st May 2010 at 4:02 PM
Looking at the first image (stool4) it looks like there are two groups in MS each assigned a different texture. In the second image(stool5) it has 5 groups. I don't know which of those pics is the right one, but MS you need to select all the groups and Regroup them into one - since that error in TSRW say it excpected one group. Your importing into your LOD mesh, which means it should have no shadow mesh and limited mesh groups(usually) for the mesh.

Sometimes with meshes made in other 3d programs MS will show double the mesh groups but one of those is empty. So the empty one can be deleted.
Alchemist
#3 Old 31st May 2010 at 4:01 PM Last edited by orangemittens : 31st May 2010 at 4:11 PM.
It sounds from what you're saying that the issue you're having isn't with TSRW or Milkshape but with the Sketchup plugin...right? Have you tried asking about it where you downloaded the Sketchup plugin? You may get lucky and someone who uses Sketchup will wander by...but most people here use Blender or Milkshape...very few are using Sketchup.

eta: shwew HL...you type so quickly you created a time warp...lol. I guess I must have misunderstood but I thought the OP was showing a picture of undesired results when the thing was regrouped to a single group in the last link.
Test Subject
Original Poster
#4 Old 31st May 2010 at 6:04 PM
Quote:
Originally Posted by HugeLunatic
Looking at the first image (stool4) it looks like there are two groups in MS each assigned a different texture.

I tried using just the 'Main' group with just one texture, and this is what it turned out like:
http://i380.photobucket.com/albums/...elp-stool_7.png
Only 3 of the sides are showing. (I used the SU plugin for the obj.)
Sockpuppet
#5 Old 31st May 2010 at 7:39 PM
I wouldn't tick any of the boxes and export as obj file, wat happens then?
Test Subject
Original Poster
#7 Old 2nd Jun 2010 at 1:41 PM Last edited by Nedjem : 2nd Jun 2010 at 2:22 PM.
UV Mapping helps, doesn't it? 'Cause I UV Mapped The 'Main' obj, and put it back into Milkshape then exported it to TSRW, and the model works!

I've just got to get the textures into dds format, then the textures should work...thanks to all of you for your help with the meshes.

Edit: I have another problem, I can't UV Map my higher LOD meshes. (The one with two groups and two textures.)
Dancing Flamingo
staff: administrator
#8 Old 2nd Jun 2010 at 2:34 PM
You high lod mesh has two groups (some meshes have more) but one is the shadow mesh and one is the object. If you are reusing the shadow mesh that was in your package you won't need to map to, so then just map the other group the same as you did the one above.
Test Subject
Original Poster
#9 Old 2nd Jun 2010 at 8:17 PM
How should I go about mapping the object? Should I map them seperate or the 'A' onto? Also, how would I make a shadow? The stool would look strange with a chair shadow...
Alchemist
#10 Old 3rd Jun 2010 at 1:21 AM
TSR has tutorials for some things...I think shadow-making is one. Try here and see if this helps with the shadow-making part:

http://www.thesimsresource.com/work...dows%20Tutorial
Test Subject
Original Poster
#11 Old 5th Jun 2010 at 2:15 PM
I looked at Cyclonesue's tutorial on object textures, and decided to have the 'A' on the texture/Multiplier.
Lab Assistant
#12 Old 9th Jun 2010 at 4:44 PM
Well, I just used Sketch up 7 (free version) to make the mesh for my 'Hills Hoist' rotary clothesline, and the OBJ exporter (i only did the actual mesh in sketch up), then i stuck it in milkshape and fixed all the groups up and scaled it to fit the actual clothesline section of the game clothesline... and tweaked a few issues.... and this is how it turned out.....
The first pic is my original try of it in game... all I did was delete the frame part of the game's clothes line, and then move my mesh around it and extend the lines a bit. Then I added extra 'deco' lines to complete it, just copying the ones on the game line. Except it had a flogging ginormous polygon count... so I went back and got rid of all the 'pegs' from the deco lines... neatened everything up and all, and ended up with the second pic
They both worked... but both of them had the same problem.... when you go in close, most of it disappears!! (see third pic!!)

But - at least it proves that sketch up and the OBJ exporter do work
(I used S3OC to clone and fix, Wes Howe's objtool to decompile the mlods and lithunrwap to do the UV...)
Screenshots

Mac-tastic Sims 3 - Tips and tutorials for making the most out of your Sims 3 experience on Mac :D
http://www.mactasticsims3.com
Alchemist
#13 Old 9th Jun 2010 at 7:04 PM
It looks like maybe you have a one-sided mesh? In the game, triangles are transparent when seen from the back side. I know nothing of using sketchup, but in MilkShape, if you right-click on a window and make sure that "draw backfaces" is turned off, you will get the same backside invisibility (called "culling").

Make all of your mesh either be cylinders or cubes, or duplicate the planes and reverse them (or rotate them around) so that you have visibility from all angles. If you duplicate a plane, be sure to move it very slightly or parts of it may display above the top (caused by very tiny rounding differences in the graphics display system).

But congratulations on getting past the "my object doesn't show in the game" step... that is a common starter issue.

<* Wes *>

If you like to say what you think, be sure you know which to do first.
Lab Assistant
#14 Old 10th Jun 2010 at 12:43 AM
LOL.
I did click 'export backfaces' when I used the OBJ exporter with sketch up....
and I made the mesh in sketch up by extruding a bunch of cylinders along planes. I did like the greater precision and control meshing it in sketch up gave me - particularly because this is a model of a RL object.
(I'm still just so stoked that it actually worked mostly right!!! I've tried quite a few objects that have had different kinds of issues, from UV mapping, to joints and animation!)
But so far, for doing a basic mesh to import to Sketch Up.... the OBJ exporter works Even if I have to take it into milkshape and make all new cylinders, place them over the original ones and then delete, it still gives me a very good guide to work with!

Oh, and turning off 'draw backfaces' in milkshape didn't produce the same effect... so i'm guessing that means the back faces are there?

Mac-tastic Sims 3 - Tips and tutorials for making the most out of your Sims 3 experience on Mac :D
http://www.mactasticsims3.com
Alchemist
#15 Old 10th Jun 2010 at 1:45 AM
My only other guess is that you have differences between the lod0 and lod1 meshes (to tell which is which, the instance ids for their MODL/MLOD parts are always 00000000 and 00000001). Lod0 would be seen closer up, and lod1 as you pull away from the mesh. If you were to add a sphere or something to only one of these lods, you could see as you zoom in and out that the mesh which is displayed changes.

But I had guessed it was backfaces because the angle your screenshot was made at is a lot lower than it was in the far away shots.

And I agree that MilkShape leaves a lot to be desired as a modeling tool (I use Maya mainly myself). However, it is a very flexible and has an easy to program plugin interface, which is why it has so many game-specific import and export plugins (from way before Sims games).

At any rate, with your enthusiasm and first taste of success, we will probably see plenty of your projects in the downloads section soon.

If you like to say what you think, be sure you know which to do first.
Alchemist
#16 Old 10th Jun 2010 at 2:12 AM
Apologies Nedjem since we're sort of digressing from your post topic. But I'm wondering what this object was cloned from LFD.

Was it the EA Clothes Hanging On A Line object? That object is a 6 x 1 object and yours appears to be much larger than that. Perhaps the disappearing part is some kind of footprint issue. It may not be, of course, but those kinds of issues do tend to pop up at close range and settle down when you're further away from the object.
Lab Assistant
#17 Old 10th Jun 2010 at 5:00 AM
I think you could be right about the footprint issue. It was cloned from the 4x1 standard clothesline in Ambitions, and I left the footprint the same, so that it is only the part you can actually use that has a footprint....

I'm wondering if I should just upload it anyway... it is kind of cool I was going to clone a statue or something and make a deco version as well.

Hee Hee.... anyone know anything about meshing bicycles?? I have a mesh for a bicycle I made... 2 actually... just having some issues with the animation!!! made one of them with sketch up!

Oh and Wes, the best thing about Milkshape compared to Maya and 3DS is the PRICE!!! I'm not a student or a pro graphic artist... so is too $$$ for me!!! I've recently discovered 'Cheetah 3D' for Mac that seems really good too...
But at least Sketch Up can help!

Mac-tastic Sims 3 - Tips and tutorials for making the most out of your Sims 3 experience on Mac :D
http://www.mactasticsims3.com
Alchemist
#18 Old 10th Jun 2010 at 5:11 AM
If you think it could be the footprint HL wrote a tutorial on how to fix that. Give that a try and if it doesn't work...it ain't the footprint and you need to look at something
else

I wish I could be more definitive but without looking at the actual package it's difficult.

Animation hasn't been an easy issue with this game unfortunately. Something about complex math, quaternions, and Euler rotations...lol. The whole thing makes my head hurt. It's an unresolved situation.
Lab Assistant
#19 Old 10th Jun 2010 at 9:58 AM
The clothes-line does have geostates, which can't be fixed (yet).

Minisite

TSR Workshop
A Custom Content Tool for The Sims 3
Alchemist
#20 Old 10th Jun 2010 at 12:57 PM
Ah...well there you go. Thanks for the info Teko.
Lab Assistant
#21 Old 11th Jun 2010 at 2:07 AM
Huh??? sprechen ze english? Geostates?

Mac-tastic Sims 3 - Tips and tutorials for making the most out of your Sims 3 experience on Mac :D
http://www.mactasticsims3.com
Dancing Flamingo
staff: administrator
#22 Old 11th Jun 2010 at 2:12 AM
Geostates are different parts of a mesh that show at different times.

The bookcase - they appear rather empty when purchasing and the books show up on the bookcase as your sim puts them away. The clothesline - it is just the posts and lines until the sim adds clothes.
Alchemist
#23 Old 11th Jun 2010 at 2:21 AM
"Geometry states are basically a way to make part of an object's mesh visible while the rest of it becomes invisible. The polygons and vertices that are visible in the geometry state are determined by the state's poly and vertex offsets and counts.

The purpose of geometry states is to sub-divide the mesh of a given group, allowing the model's visibility to be dynamically changed by the game through the function:

ScriptCore.World.ObjectSetGeometryVisibilityState(ObjectGuid objId, string geometryVisibilityState);
For most objects with geometry states, this function is commonly accessed through this function:

Sims3.Gameplay.Abstracts.GameObject.SetGeometryState(string state);
For some objects, the string argument is fnv32 hashed and matched to the corresponding geo_st name hash. However, in some cases, such as for the musicalInstrumentGuitar, it is unknown how some geometry states are located for the game. In the case of the guitar, two geometry states are given in the MLOD block:

0x4A9A1FD1 "guitarOnly"
0x019C3651 "standOnly"
However, the guitar's code uses the string "guitarAndStand" to combine the two states and get the complete mesh. How this is done is still unknown."

More here:

http://www.simswiki.info/wiki.php?t...ms_3:0x01D10F34

By the by...I looked at the adult bicycle and it goes through all the tools with its animations intact. Someone has posted modified versions of the children's bicycle with intact animations also. So it would seem that you should be able to get a working modified S3 bike. If you want help with it maybe try starting a new thread about it?...perhaps there are people who could help.
Lab Assistant
#24 Old 11th Jun 2010 at 3:36 AM
yeah well... both my bicycles (one adult and one child) have changed wheel base.
It's supposed to be top sekrit though :P

Mac-tastic Sims 3 - Tips and tutorials for making the most out of your Sims 3 experience on Mac :D
http://www.mactasticsims3.com
Alchemist
#25 Old 11th Jun 2010 at 4:08 AM
well people have been trying to rebuild the wheel from all the way back here:

http://modthesims.info/showthread.php?t=369089

my suggestion is post a new thread on it and hope one of the car people can help you with changing the wheel base on an object...it clearly can be done since they've done it Sorry again Nedjem for the digression.
Page 1 of 2
Back to top